Community discussions

 
nikc
Member Candidate
Member Candidate
Topic Author
Posts: 181
Joined: Wed Jul 13, 2016 6:05 pm

Performance - Speeds

Wed Jul 13, 2016 6:20 pm

Hi All, just got my HAP ac lite router that i am looking to replace a UK BT Homehub 5 with.

I've got it setup pretty quick and easily but noticed some speed issues that I thought related to wireless ..... (my home link is a fibre to the premises 300mbit down 30mbit up config). So i started to play around a little ... a basically removed as much as I could to go back to where i knew I was getting good speeds, that config is:

Laptop ethernet -> BT Home Hub ethernet -> fibre wall mounted connection - results look good !

Image

I then introduced the HAP ac lite
Laptop ethernet -> Mitokit ethernet -> BT Homehub ethernet -> Fibre Router

Image

These speeds are pretty similar to what I originally spotted when testing wifi speeds .... so before i dig into the wifi config, it looks like there is an issue somewhere else as far as I can tell ... the homehub to HAP lite link is via a good ethernet cable and both are gbit ports i believe, so that shouldn't be a bottleneck.

I'm running on pretty much the factory default config, can anyone point me in the right direction to where to start troubleshooting ?

Thanks !

Nik
 
User avatar
nickshore
Member
Member
Posts: 473
Joined: Thu Mar 03, 2005 4:14 pm
Location: Suffolk, UK.
Contact:

Re: Performance - Speeds

Wed Jul 13, 2016 6:35 pm

Well firstly the hAP AC lite only has 10/100 ports.

If you are using the default config, you have probably connected from ether1 on the hap ? If so you will be NATing.

Looking at tested speeds http://routerboard.com/RB952Ui-5ac2nD you should be getting close to the limit of the 10/100 ethernet - normally around 97 Mbps.

What is the CPU doing during your testing ?

Nick
Nick Shore MTCNA MTCWE MTCRE MTCINE MTCTCE
LinITX.com - MultiThread Consultants
Get your MikroTik RBs and Training: http://linitx.com/brand/mikrotik
Official UK MikroTik Distributor
IRC chan: #routerboard on irc.z.je (IPv4 and IPv6)
 
nikc
Member Candidate
Member Candidate
Topic Author
Posts: 181
Joined: Wed Jul 13, 2016 6:05 pm

Re: Performance - Speeds

Wed Jul 13, 2016 7:25 pm

Thanks for the reply .. the 10/100 is new news !

Correct on eth1 & NAT.

CPU doesn't go above 34% whilst the test is running.
 
nikc
Member Candidate
Member Candidate
Topic Author
Posts: 181
Joined: Wed Jul 13, 2016 6:05 pm

Re: Performance - Speeds

Wed Jul 13, 2016 11:26 pm

I tried another test .... removed the BT homehub out of the equation and just went ppoe direct from the hAP lite, similar results via ethernet or wifi :(
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: Performance - Speeds

Thu Jul 14, 2016 4:33 am

Are you able to pass more over the wifi locally?what are wifi link and signal values?
 
nikc
Member Candidate
Member Candidate
Topic Author
Posts: 181
Joined: Wed Jul 13, 2016 6:05 pm

Re: Performance - Speeds

Thu Jul 14, 2016 11:37 am

Are you able to pass more over the wifi locally?what are wifi link and signal values?
Doesn't seem so, this is a test uploading from my laptop on Wifi (sat right next to the AP with great signal) to an ftp server connected on the LAN via ethernet:
Image
It never goes over 20, my device is highlighted below:
Image
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: Performance - Speeds

Thu Jul 14, 2016 12:08 pm

ok.
first it is using only one stream. Check all streams are enabled in HT tab. Check your notebook have multichannel radio and all channels are enabled in the drivers properties.

There might be problem with some interference, as the client is keeping low modulation when transmitting. make spectral scan, try other frequencies.

What is ccq and signal-to-noise ratio? Maybe you should rise the tx power of the notebook if possible in drivers properties.
 
nikc
Member Candidate
Member Candidate
Topic Author
Posts: 181
Joined: Wed Jul 13, 2016 6:05 pm

Re: Performance - Speeds

Thu Jul 14, 2016 12:24 pm

Ok thanks will go look again when home tonight, same notebook on the homehub see's about 160 internal speeds.
 
nikc
Member Candidate
Member Candidate
Topic Author
Posts: 181
Joined: Wed Jul 13, 2016 6:05 pm

Re: Performance - Speeds

Thu Jul 14, 2016 12:26 pm

FYI the Wifi in my laptop (Surface book pro) has very limited options:

Image
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: Performance - Speeds

Thu Jul 14, 2016 12:34 pm

Well you will see at home. Even the driver is upgradable, so it could provide more options. Maybe. Maybe it has physically only one chain... I don't know your wifi card parameters...
 
nikc
Member Candidate
Member Candidate
Topic Author
Posts: 181
Joined: Wed Jul 13, 2016 6:05 pm

Re: Performance - Speeds

Thu Jul 14, 2016 6:32 pm

Had a look at the driver, no more options or later versions there for me to try :(

Here's the spectral scan results:
# jul/14/2016 16:25:22 by RouterOS 6.36rc40
# software id = 00UP-Q8C1
#
FREQ INTERFERENCE            DBM GRAPH                                         
2383 none                    -89 ::::::::.                                     
2389 none                    -89 ::::::::.                                     
2395 none                    -90 :::::::.                                      
2402 none                    -90 ::::::::..........                            
2408 none                    -90 ::::::::......                                
2414 none                    -90 ::::::::.........                             
2421 none                    -92 :::::::............                           
2427 none                    -97 :::..............................             
2433 none                    -95 ::::...............................           
2440 none                    -95 ::::............................              
2446 none                    -94 :::::..............                           
2453 none                   -101 :.............................................
2459 none                    -98 ::............................................
2465 none                    -98 ::............................................
2472 none                    -97 :::...........................................
2478 none                    -96 ::::..................................        
2484 none                    -92 :::::::..                                     
2491 none                    -94 :::::....                                     
2497 none                    -80 :::::::::::::::.                              
2503 none                    -80 :::::::::::::::.                              
2510 none                    -81 :::::::::::::::.                              
2516 none                    -94 ::::.                                         
# jul/14/2016 16:25:26 by RouterOS 6.36rc40
# software id = 00UP-Q8C1
#
FREQ INTERFERENCE            DBM GRAPH                                         
2383 none                    -91 :::::::..                                     
2389 none                    -91 :::::::..                                     
2395 none                    -89 ::::::::.                                     
2402 none                    -89 ::::::::.                                     
2408 none                    -89 ::::::::.                                     
2414 none                    -91 :::::::.                                      
2421 none                    -93 ::::::...........                             
2427 none                    -99 :................                             
2433 none                    -98 ::............                                
2440 none                    -97 :::...........................                
2446 none                    -98 ::..............................              
2453 none                    -97 :::...................................        
2459 none                    -97 :::...........................................
2465 none                    -97 :::...........................................
2472 none                    -95 ::::..........................................
2478 none                    -79 :::::::::::::::::......................       
2484 none                    -79 ::::::::::::::::.                             
2491 none                    -79 ::::::::::::::::.                             
2497 none                    -77 ::::::::::::::::::.                           
2503 none                    -74 ::::::::::::::::::::..                        
2510 none                    -75 ::::::::::::::::::::..                        
2516 none                    -94 :::::............                             
# jul/14/2016 16:25:27 by RouterOS 6.36rc40
# software id = 00UP-Q8C1
#
FREQ INTERFERENCE            DBM GRAPH                                         
2383 none                    -91 ::::::.                                       
2389 none                    -91 ::::::.                                       
2395 none                    -89 ::::::::.                                     
2402 none                    -89 ::::::::.                                     
2408 none                    -89 ::::::::.                                     
2414 none                    -91 ::::::.                                       
2421 none                    -93 ::::::...........                             
2427 none                    -99 :................                             
2433 none                    -98 ::............                                
2440 none                    -97 :::...........................                
2446 none                    -98 ::..............................              
2453 none                    -97 :::...................................        
2459 none                    -97 :::...........................................
2465 none                    -97 :::...........................................
2472 none                    -95 ::::..........................................
2478 none                    -79 :::::::::::::::::......................       
2484 none                    -79 ::::::::::::::::.                             
2491 none                    -79 ::::::::::::::::.                             
2497 none                    -77 ::::::::::::::::::.                           
2503 none                    -74 ::::::::::::::::::::..                        
2510 none                    -75 ::::::::::::::::::::..                        
2516 none                    -94 :::::............                             
I also had a look at the HT tab, in both instances all chains are enabled:

Image

Image

Just digging out my macbook to see if the results are any different on there.

Nik
 
nikc
Member Candidate
Member Candidate
Topic Author
Posts: 181
Joined: Wed Jul 13, 2016 6:05 pm

Re: Performance - Speeds

Thu Jul 14, 2016 6:36 pm

And one more screenshot showing the signal strength etc:

Image
 
User avatar
nickshore
Member
Member
Posts: 473
Joined: Thu Mar 03, 2005 4:14 pm
Location: Suffolk, UK.
Contact:

Re: Performance - Speeds

Thu Jul 14, 2016 6:39 pm

I tried another test .... removed the BT homehub out of the equation and just went ppoe direct from the hAP lite, similar results via ethernet or wifi :(
If you see the same speeds on ethernet you must have a config issue.

Have you checked the ethernet status to see if it has negotiated correctly ?

Are you using pppoe into the BT CPE ? Have you got the correct MTU set ?
Nick Shore MTCNA MTCWE MTCRE MTCINE MTCTCE
LinITX.com - MultiThread Consultants
Get your MikroTik RBs and Training: http://linitx.com/brand/mikrotik
Official UK MikroTik Distributor
IRC chan: #routerboard on irc.z.je (IPv4 and IPv6)
 
nikc
Member Candidate
Member Candidate
Topic Author
Posts: 181
Joined: Wed Jul 13, 2016 6:05 pm

Re: Performance - Speeds

Thu Jul 14, 2016 6:48 pm

I tried another test .... removed the BT homehub out of the equation and just went ppoe direct from the hAP lite, similar results via ethernet or wifi :(
If you see the same speeds on ethernet you must have a config issue.

Have you checked the ethernet status to see if it has negotiated correctly ?

Are you using pppoe into the BT CPE ? Have you got the correct MTU set ?
Forced the ports to 100 Full Duplex.
Correct on the BT CPE, the MTU was the default, i was trying to find the recomended value for BT FTTH.
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: Performance - Speeds

Thu Jul 14, 2016 9:25 pm

Oh, the device has only one chain radio on the ac. See the specification...
http://routerboard.com/RB952Ui-5ac2nD
It will not work with more than one, even your notebook could be capable of that.

Your spectral scan in 2G spectrum is for nothing, you should see the 5g instead. But ac is known to not support spectral scan on mikrotik so far. Maybe automatic channel selection could help a bit.
 
nikc
Member Candidate
Member Candidate
Topic Author
Posts: 181
Joined: Wed Jul 13, 2016 6:05 pm

Re: Performance - Speeds

Thu Jul 14, 2016 11:30 pm

I'm thinking the lite was a bad idea .... might look at the full hAP version and give the lite to my neighbor.

Would really love to get it working fully so I can bin the featureless homehub !
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: Performance - Speeds

Thu Jul 14, 2016 11:55 pm

Be also sure your notebook has also at least 2 but rather 3 chains...
 
nikc
Member Candidate
Member Candidate
Topic Author
Posts: 181
Joined: Wed Jul 13, 2016 6:05 pm

Re: Performance - Speeds

Thu Jul 14, 2016 11:59 pm

The docs dont seem to reference chains, unless its the 2x2 MIMO Spatial stream bit ?
The Avastar 88W8897 single-chip WLAN/Bluetooth/NFC solution provides both simultaneous and independent operation of the following: • IEEE 802.11ac (draft) compliant, 2x2 MIMO spatial stream multiplexing with data rates up to MCS9 (866.7 Mbps) • Bluetooth 4.2 + EDR/BDR/High-speed/Low Energy Dual Mode Controller • Near Field Communication (NFC) connectivity technology, per NFC Forum specification, for short-range, contactless communication In addition, internal coexistence arbitration and a Mobile Wireless Systems (MWS) serial transport interface provide the functionality for connecting an external Long Term Evolution (LTE) device. For security, the 802.11i security standard is supported through several protocols. For video, voice, and multimedia applications, 802.11e Quality of Service (QoS) is supported. Dynamic Rapid Channel Switching (DRCS) is also available enabling concurrent STA, AP and Wi-Fi Direct GO operating modes in separate channels.. The device supports 802.11h Dynamic Frequency Selection (DFS) for detecting radar pulses when operating in the 5 GHz range. Generic interfaces include HighSpeed Inter-Chip (HSIC), USB 2.0, SDIO 3.0, low-power PCI Express, high-speed UART and PCM interfaces for connecting WLAN and Bluetooth and NFC to the host processor. The device is available in QFN and CSP flip chip package options.
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: Performance - Speeds

Fri Jul 15, 2016 7:44 am

That's the two chain radio.
 
nikc
Member Candidate
Member Candidate
Topic Author
Posts: 181
Joined: Wed Jul 13, 2016 6:05 pm

Re: Performance - Speeds

Fri Jul 15, 2016 10:11 am

OK - so would expect better performance than seen :(
 
Zorro
Long time Member
Long time Member
Posts: 676
Joined: Wed Apr 16, 2014 2:43 pm

Re: Performance - Speeds

Fri Jul 15, 2016 10:48 am

well, aside "radio performance" sometimes CPU speed and amount of RAM - may be seriously more bottlenecking factor than radios used in.
if you compare HAP AC lite with say HAP AC
(in "Performance test results" below each product description page)
http://routerboard.com/RB952Ui-5ac2nD
http://routerboard.com/RB962UiGS-5HacT2HnT
you will notice that its rought 2-3x times slower, sadly.
fasttrack and fastpath - may help a lot in both cases, however.
thats why perhaps in similar case - i would pick HAP versus HAP AC lite in similar budget.
 
nikc
Member Candidate
Member Candidate
Topic Author
Posts: 181
Joined: Wed Jul 13, 2016 6:05 pm

Re: Performance - Speeds

Fri Jul 15, 2016 11:40 am

well, aside "radio performance" sometimes CPU speed and amount of RAM - may be seriously more bottlenecking factor than radios used in.
if you compare HAP AC lite with say HAP AC
(in "Performance test results" below each product description page)
http://routerboard.com/RB952Ui-5ac2nD
http://routerboard.com/RB962UiGS-5HacT2HnT
you will notice that its rought 2-3x times slower, sadly.
fasttrack and fastpath - may help a lot in both cases, however.
thats why perhaps in similar case - i would pick HAP versus HAP AC lite in similar budget.
Yeh, going to order a replacement this weekend, the lite will be perfect for my neighbors who have lots of problems with their current setup :)
 
sergyus2552
just joined
Posts: 1
Joined: Fri Aug 19, 2016 1:04 pm

Re: Performance - Speeds

Fri Aug 19, 2016 1:16 pm

RB962UiGS-5HacT2HnT
router cuts upload speed. installation-specific settings are default.

Configuration add.
[admin@MikroTik] > export
# aug/17/2016 19:34:38 by RouterOS 6.37rc16
#
/interface bridge
add admin-mac=***** auto-mac=no comment=defconf name=bridge
/interface ethernet
set [ find default-name=ether1 ] mac-address=*****
set [ find default-name=ether2 ] name=ether2-master
set [ find default-name=ether3 ] master-port=ether2-master
set [ find default-name=ether4 ] master-port=ether2-master
set [ find default-name=ether5 ] master-port=ether2-master
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce country=**** default-authentication=no disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=**** wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee country=***** default-authentication=no disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=**** wireless-protocol=802.11
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 password=**** use-peer-dns=yes user=****
/ip neighbor discovery
set ether1 discover=no
set bridge comment=defconf
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" management-protection-key="*****" mode=dynamic-keys wpa-pre-shared-key="****" wpa2-pre-shared-key="*****"
/ip pool
add name=dhcp ranges=****
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=ether2-master
add bridge=bridge comment=defconf interface=sfp1
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge comment=defconf interface=wlan2
/interface wireless access-list
add mac-address=****
add mac-address=****
/ip address
add address=***** comment=defconf interface=ether2-master network=192.168.1.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid interface=ether1
/ip dhcp-server network
add address=192.168.1.0/24 comment=defconf gateway=***** netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=***** name=router
/ip firewall filter
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related" connection-state=established,related
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface=ether1
add action=accept chain=input protocol=icmp
add action=accept chain=input connection-state=established
add action=accept chain=input connection-state=related
add action=drop chain=input in-interface=pppoe-out1
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" out-interface=pppoe-out1
/system clock
set time-zone-name=****
/system routerboard settings
set cpu-frequency=720MHz protected-routerboot=disabled
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=bridge
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=bridge

Who is online

Users browsing this forum: No registered users and 18 guests