Community discussions

 
ik3umt
Member Candidate
Member Candidate
Topic Author
Posts: 195
Joined: Tue Jul 08, 2014 3:58 pm

Navigation issue with Fasttrack in conjunction with pcc

Mon Jul 25, 2016 7:59 pm

I'm experiencing some navigation issues (website latency or hung, timeout during web bandwidth tests etc.) that disappear once fasttrack rules are disabled on ip firewall filter.
I'm using two wan PCC as per http://mum.mikrotik.com/presentations/US12/steve.pdf instructions.
What can I check and what could be the cause ?

Thank you
 
OKNET
Member Candidate
Member Candidate
Posts: 226
Joined: Mon Jun 22, 2015 9:22 am

Re: Navigation issue with Fasttrack in conjunction with pcc

Tue Jul 26, 2016 12:15 pm

Fasttrack rule is the one included in basic firewall settings:

add comment="accept ICMP" chain=input action=accept protocol=icmp 
add comment="accept establieshed,related" chain=input action=accept connection-state=established,related 
add comment="drop all from WAN" chain=input action=drop in-interface=ether9 
add comment="drop all from WAN" chain=input action=drop in-interface=ether10 
add comment="fasttrack" chain=forward action=fasttrack-connection connection-state=established,related 
add comment="accept established,related" chain=forward action=accept connection-state=established,related 
add comment="drop invalid" chain=forward action=drop connection-state=invalid 
add comment="drop all from WAN not DSTNATed" chain=forward action=drop connection-state=new connection-nat-state=!dstnat in-interface=ether9
add comment="drop all from WAN not DSTNATed" chain=forward action=drop connection-state=new connection-nat-state=!dstnat in-interface=ether10

I have two other machines with similar configurations both with issue gone once fasttrack rule was disabled
Should perhaps fasttrack to be avoided with PCC ??
Any idea ?
 
User avatar
soonwai
Member Candidate
Member Candidate
Posts: 162
Joined: Mon Feb 06, 2012 10:50 pm
Location: Kuala Lumpur

Re: Navigation issue with Fasttrack in conjunction with pcc

Sat Mar 04, 2017 6:41 pm

Did you all managed to solve this problem? I'm also load balancing 2 WANs with PCC and having the same problems with browser stalling when FastTrack is on. I've managed to solve it but not sure if this is the right way.

What I've done is to exclude WAN2 connections from FastTrack.
add action=fasttrack-connection chain=forward connection-mark=!WAN2_conn connection-state=established,related
That's all I did and it seems to be working. FastTrack is back on and everything is ok so far. CPU usage on my RB2011 is down from 80% to 50% when routing at 60mbps. The WANs are 30mbps each.
 
j528
just joined
Posts: 1
Joined: Sun Oct 29, 2017 12:21 am

Re: Navigation issue with Fasttrack in conjunction with pcc

Sun Oct 29, 2017 12:24 am

I'm experiencing exactly the same problem.

Confirmed that soonwai's workaround also seems to work for me.
 
vanderleiromera
just joined
Posts: 2
Joined: Wed Dec 23, 2015 4:00 pm

Re: Navigation issue with Fasttrack in conjunction with pcc

Fri Jul 27, 2018 1:35 am

Did you all managed to solve this problem? I'm also load balancing 2 WANs with PCC and having the same problems with browser stalling when FastTrack is on. I've managed to solve it but not sure if this is the right way.

What I've done is to exclude WAN2 connections from FastTrack.
add action=fasttrack-connection chain=forward connection-mark=!WAN2_conn connection-state=established,related
That's all I did and it seems to be working. FastTrack is back on and everything is ok so far. CPU usage on my RB2011 is down from 80% to 50% when routing at 60mbps. The WANs are 30mbps each.
Thank you!
 
stackflow
just joined
Posts: 10
Joined: Fri Nov 03, 2017 7:07 am

Re: Navigation issue with Fasttrack in conjunction with pcc

Fri Feb 08, 2019 5:14 pm

Same issue here.

Never found the best solution.
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1373
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: Navigation issue with Fasttrack in conjunction with pcc

Fri Feb 08, 2019 6:53 pm

This CAN'T be solved!

PCC needs mangling to work BUT Fast-track bypasses mangling

What you can do, is fast-track your default route (choose one), the other route needs to do the full processing, as done by @soonwai

Who is online

Users browsing this forum: No registered users and 3 guests