Community discussions

MikroTik App
 
igpetkov
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Thu Oct 09, 2014 10:27 pm

Hotspot Cookies

Thu Aug 11, 2016 9:57 am

Hi,
Can I make diffеrence between HTTP and MAC Cookies in Hotsot --> Cookies.
I have started Hotspot with HTTP CHAP, MAC Cookie and Cookie login and I can see when user login that two lines cookies appear in cookie table. I suppose that one line is for http cookie and one line for MAC cokie. Is that so?
And more one question, when I connect with mobile device (Android) cookie table import two lines everytime, but when I connect with Windows PC (Google Chrome) not everytime import two lines, its importonly one , and suppose this is a HTTP cookie, because I have to strat browser to make device active.

Can someone help me? This is a problem for me , because some of my users use applications without browser and can't activate internet connection

Thank You
2.png

And more, why two line have different Expire time?
You do not have the required permissions to view the files attached to this post.
 
igpetkov
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Thu Oct 09, 2014 10:27 pm

Re: Hotspot Cookies

Thu Aug 11, 2016 10:12 am

I saw the reason for the differences in Expire Time. When I Disconnect and Connect to network again the Mac cookie refresh its time, but when open browser HTTP cookie doesn't refresh its time. Have to be so or its is my config oversight?
 
igpetkov
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 52
Joined: Thu Oct 09, 2014 10:27 pm

Re: Hotspot Cookies

Thu Aug 11, 2016 10:59 am

I found some answers of my questions and will share, maybe will be usefull for someone.

1. When I connect for the first time to Hotspot Wireless and enter correc account in Web Browser, two lines with MAC address of my Laptop appear in a cookie table.
2. Then I connect to other wireless network
3. Directlly (without disconnect from other network) connect again to my hotspot network, and one line from cookie table disappear , I suppose that is because Hotspot replace my IP from another Wireless network (In Active table appear two lines with my Laptop MAC, with two IP's)
4. When I disconnect from Hotspot network again and keepalive time expire, the line from cookie table appear again.
5. If I connect to other wireless network, Disconnect from it, Disable wireless adapter and Enable again (to forget IP from other wireless network) and connect Hotspot wireless MAC Cookie works and Laptop is active without start Web Browser

All this is only when use PC, when I use my mobile device Sony Xperia (Android), there is no matter how switch over networks. Two lines cookies stay in table and works fine.

Can someone explain why it is so ?

Who is online

Users browsing this forum: No registered users and 72 guests