Community discussions

MikroTik App
 
berkhoff
just joined
Topic Author
Posts: 7
Joined: Sun Sep 18, 2016 12:03 pm

EoIP and DHCP question

Tue Sep 20, 2016 12:24 am

I am trying to bridge two sites using EoIP tunnels. One site (A) should be running the DHCP server and the other site (B) should support WLAN clients that become part of the L2 network at A and request an IP address from A.

DHCP Server <-> LAN A <-> ether5 <-> bridge <-> EoIP tunnel (id=101) <-> Internet <-> EoIP tunnel (id=101) <-> bridge <-> wlan1 <-> WLAN B <-> DHCP Client

However, after associating the WLAN client, no DHCP response seems to be received so the clients won't connect.
I cannot find any traces in the logs of A nor B. Should I include a DHCP Relay somewhere ?
Any suggestions?
Thanks
 
nwton
just joined
Posts: 2
Joined: Tue Sep 20, 2016 6:05 pm

Re: EoIP and DHCP question

Wed Sep 21, 2016 9:33 am

First, check that the channel is functional using static IP addresses. Then you can start to fix the DHCP service.
Verify that the DHCP server binding to an bridge interface, rather than an ordinary LAN.
 
jaytcsd
Member Candidate
Member Candidate
Posts: 293
Joined: Wed Dec 29, 2004 9:50 am
Location: Pittsboro IN
Contact:

Re: EoIP and DHCP question

Sun Oct 02, 2016 8:19 am

I have 2 Mikrotiks linked over an EOIP tunnel, both are on 192.168.100.0/24.
Each router runs DHCP with different pools. I tried using just one DHCP server but if the tunnel goes down (it does when my ISP changes my WAN address every couple of months) the far end can't get to the internet which means I can't remote into a PC to make any changes needed to the router. My mother-in-law's tech skills stop at rebooting...

The delay from the tunnel means the local router gives out the address 99% of the time.

Who is online

Users browsing this forum: No registered users and 47 guests