Community discussions

 
User avatar
Ishtiaque
newbie
Topic Author
Posts: 46
Joined: Sat Jul 30, 2016 5:17 pm
Location: Bangladesh
Contact:

Torrent Allow In CCR1016 12G

Fri Nov 04, 2016 5:54 am

Dear All Of Experts and Members , Peace For You !!!
I need an emergency Help,,
My customers can download torrent files easily but they can't upload and seed any file to local or any global torrent site
I can't catch this problem , No issue with my Upstream IIG ISP ,,
My CCR is running well , but customers are so sad and they telling me if i can't solve this problem they will leave
my network , :(
I need your help , please give me solution for this problem .

Thanks In advance

Sorry for my bad English
Learner Of MiKroTiK Please Help Me
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: Torrent Allow In CCR1016 12G

Fri Nov 04, 2016 7:58 am

Don't you have any investigation results?
 
User avatar
Ishtiaque
newbie
Topic Author
Posts: 46
Joined: Sat Jul 30, 2016 5:17 pm
Location: Bangladesh
Contact:

Re: Torrent Allow In CCR1016 12G

Sat Nov 05, 2016 2:29 am

Don't you have any investigation results?
Dear , I can see the result on torrent client not connectable and no incoming connection ,
i am not a specialist in ROS ,
if you need my router access please tell me and detect the problem .
Please help me :(
Learner Of MiKroTiK Please Help Me
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: Torrent Allow In CCR1016 12G

Sat Nov 05, 2016 7:52 am

Set fixed port in utorrent and redirect the incoming connections from wan to the device running torrents. Or use upnp if you have just one natting router. Hope the customers have their own individual public ip...
 
User avatar
Ishtiaque
newbie
Topic Author
Posts: 46
Joined: Sat Jul 30, 2016 5:17 pm
Location: Bangladesh
Contact:

Re: Torrent Allow In CCR1016 12G

Sun Nov 06, 2016 12:41 am

Set fixed port in utorrent and redirect the incoming connections from wan to the device running torrents. Or use upnp if you have just one natting router. Hope the customers have their own individual public ip...
Boss I enabled upnp service ,
my customer in individual public IP
all customer can download but no one cannot upload , upnp enabled .
give me a script of seed .
I have 4 vlan 1 for Internet 2 for youtube 3 for media 4 for bdix (bangladesh internet exchange )
and all 4 are nat rule .
.here is my natting script of 4 vlan
/ip firewall nat
add action=masquerade chain=srcnat disabled=no out-interface=INTERNET
add action=masquerade chain=srcnat disabled=no out-interface=MEDIA
add action=masquerade chain=srcnat disabled=no out-interface=BDIX
add action=masquerade chain=srcnat disabled=no out-interface=YOUTUBE

Boss Please do something , please take my router access to check what i am missing
if you tell me then i will give you my router id n pass

please boss :(
Learner Of MiKroTiK Please Help Me
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1712
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: Torrent Allow In CCR1016 12G

Sun Nov 06, 2016 1:17 am

strange issue, check with utorrent client if connectivity test are ok to confirm port forwarding are working.

maybe your upstream ISP are filtering upstream torrent, i have seen some isp doing that

if connectivity is ok, there is another factors specific to torrents like the tracker site policies, torrent client need to have a lot of files sharing to upload, and that files need to be popular (many people trying to donload) and without too many seeds (people sharing the same file) to improve the probability of uploading.

also check the utorrent settings to improve the ammount of connections and allow more upload slots per file.

I have a client sharing 1TB of files (600 torrents) ans uploads 1 to 2 GByte daily with only 2mbit/s of upload bandwidth
 
User avatar
Ishtiaque
newbie
Topic Author
Posts: 46
Joined: Sat Jul 30, 2016 5:17 pm
Location: Bangladesh
Contact:

Re: Torrent Allow In CCR1016 12G

Sun Nov 06, 2016 2:29 am

strange issue, check with utorrent client if connectivity test are ok to confirm port forwarding are working.

maybe your upstream ISP are filtering upstream torrent, i have seen some isp doing that

if connectivity is ok, there is another factors specific to torrents like the tracker site policies, torrent client need to have a lot of files sharing to upload, and that files need to be popular (many people trying to donload) and without too many seeds (people sharing the same file) to improve the probability of uploading.

also check the utorrent settings to improve the ammount of connections and allow more upload slots per file.

I have a client sharing 1TB of files (600 torrents) ans uploads 1 to 2 GByte daily with only 2mbit/s of upload bandwidth
Thank you Dear ,
I did all you suggested , my ISP not blocking upload , seeding or download , the only problem is no seeding or uploading from my mikrotik ccr1016 12g........
:(
Learner Of MiKroTiK Please Help Me
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1712
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: Torrent Allow In CCR1016 12G

Sun Nov 06, 2016 3:24 am

i think you have to test and verify torrent working before traffic passes the CCR to prove CCR is the cause of the problem
 
User avatar
Ishtiaque
newbie
Topic Author
Posts: 46
Joined: Sat Jul 30, 2016 5:17 pm
Location: Bangladesh
Contact:

Re: Torrent Allow In CCR1016 12G

Sun Nov 06, 2016 7:25 am

i think you have to test and verify torrent working before traffic passes the CCR to prove CCR is the cause of the problem
I can't catch The problem Dear , i don't know what can i do now :(
Learner Of MiKroTiK Please Help Me
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: Torrent Allow In CCR1016 12G

Sun Nov 06, 2016 7:54 am

First be sure it is your fault. Most probably it will be out of your reach.
 
User avatar
Ishtiaque
newbie
Topic Author
Posts: 46
Joined: Sat Jul 30, 2016 5:17 pm
Location: Bangladesh
Contact:

Re: Torrent Allow In CCR1016 12G

Sun Nov 06, 2016 8:15 am

First be sure it is your fault. Most probably it will be out of your reach.
I don't know too much , i need your help Boss ,
Nothing added for torrent , just upnp enabled dear ,
you can check for prove boss .
Learner Of MiKroTiK Please Help Me
 
User avatar
Ishtiaque
newbie
Topic Author
Posts: 46
Joined: Sat Jul 30, 2016 5:17 pm
Location: Bangladesh
Contact:

Re: Torrent Allow In CCR1016 12G

Tue Nov 08, 2016 2:43 am

Dear all experts
I need your help :(
Learner Of MiKroTiK Please Help Me
 
User avatar
Ishtiaque
newbie
Topic Author
Posts: 46
Joined: Sat Jul 30, 2016 5:17 pm
Location: Bangladesh
Contact:

Re: Torrent Allow In CCR1016 12G

Tue Nov 08, 2016 2:45 am

i think you have to test and verify torrent working before traffic passes the CCR to prove CCR is the cause of the problem
Checked and no problem in ccr and upstream , just need filter and nat cofig ....
Learner Of MiKroTiK Please Help Me
 
User avatar
Ishtiaque
newbie
Topic Author
Posts: 46
Joined: Sat Jul 30, 2016 5:17 pm
Location: Bangladesh
Contact:

Re: Torrent Allow In CCR1016 12G

Wed Nov 09, 2016 4:35 am

OH ......
Who will help me ??? , no one trying to understand me , I am a Learner of ROS ,
I ma a primary student but getting Higher school suggestions :(
Learner Of MiKroTiK Please Help Me
 
User avatar
Ishtiaque
newbie
Topic Author
Posts: 46
Joined: Sat Jul 30, 2016 5:17 pm
Location: Bangladesh
Contact:

Re: Torrent Allow In CCR1016 12G

Thu Nov 10, 2016 3:14 am

strange issue, check with utorrent client if connectivity test are ok to confirm port forwarding are working.

maybe your upstream ISP are filtering upstream torrent, i have seen some isp doing that

if connectivity is ok, there is another factors specific to torrents like the tracker site policies, torrent client need to have a lot of files sharing to upload, and that files need to be popular (many people trying to donload) and without too many seeds (people sharing the same file) to improve the probability of uploading.

also check the utorrent settings to improve the ammount of connections and allow more upload slots per file.

I have a client sharing 1TB of files (600 torrents) ans uploads 1 to 2 GByte daily with only 2mbit/s of upload bandwidth
Download Is Ok But Upload or seeding stopped ....
Learner Of MiKroTiK Please Help Me
 
User avatar
Ishtiaque
newbie
Topic Author
Posts: 46
Joined: Sat Jul 30, 2016 5:17 pm
Location: Bangladesh
Contact:

Re: Torrent Allow In CCR1016 12G

Fri Nov 11, 2016 7:28 am

Set fixed port in utorrent and redirect the incoming connections from wan to the device running torrents. Or use upnp if you have just one natting router. Hope the customers have their own individual public ip...
Boss explain dstnat i need this , i am missing something in dst natting ,
can use full x.x.x.x/24 block for dstnat ?
Please help me ....
Learner Of MiKroTiK Please Help Me
 
User avatar
Ishtiaque
newbie
Topic Author
Posts: 46
Joined: Sat Jul 30, 2016 5:17 pm
Location: Bangladesh
Contact:

Re: Torrent Allow In CCR1016 12G

Tue Nov 15, 2016 6:10 am

Set fixed port in utorrent and redirect the incoming connections from wan to the device running torrents. Or use upnp if you have just one natting router. Hope the customers have their own individual public ip...
Thank you Jarda Boss
for your Help
My problem is solved by your Tip .
God bless you . :D
Learner Of MiKroTiK Please Help Me
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: Torrent Allow In CCR1016 12G

Tue Nov 15, 2016 6:31 am

Good for you. Congratulations.
 
User avatar
Ishtiaque
newbie
Topic Author
Posts: 46
Joined: Sat Jul 30, 2016 5:17 pm
Location: Bangladesh
Contact:

Re: Torrent Allow In CCR1016 12G

Thu Nov 17, 2016 5:41 am

Good for you. Congratulations.
Jarda Boss ,
It's my pleasure .
I got your help in time .
Thank you again n again .
Love you .
Learner Of MiKroTiK Please Help Me
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: Torrent Allow In CCR1016 12G

Thu Nov 17, 2016 10:16 am

Nice. Almost like a poem. You can put it into haiku topic, follow the link in my signature.
 
User avatar
Ishtiaque
newbie
Topic Author
Posts: 46
Joined: Sat Jul 30, 2016 5:17 pm
Location: Bangladesh
Contact:

Re: Torrent Allow In CCR1016 12G

Fri Nov 18, 2016 1:47 am

Dear Jarda Boss,
I can't understood
What to put in haiku ? My full Topic ? or my last reply ?
Boss please tell me , i am bad in English .

Love You Boss .
Learner Of MiKroTiK Please Help Me
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: Torrent Allow In CCR1016 12G

Fri Nov 18, 2016 10:03 pm

Take it easy... I meant your last response was looking like a poetry, even you probably were not intended it so.
 
User avatar
Ishtiaque
newbie
Topic Author
Posts: 46
Joined: Sat Jul 30, 2016 5:17 pm
Location: Bangladesh
Contact:

Re: Torrent Allow In CCR1016 12G

Fri Nov 18, 2016 11:54 pm

Take it easy... I meant your last response was looking like a poetry, even you probably were not intended it so.
Boss
:? :? :?
Learner Of MiKroTiK Please Help Me

Who is online

Users browsing this forum: Google [Bot] and 23 guests