Community discussions

 
stef123
just joined
Topic Author
Posts: 12
Joined: Sun Jul 10, 2016 10:49 pm

Traffic-type load balancing with LTE interface

Tue Nov 08, 2016 6:25 am

Hi all,

Hope you can help. I also think I've found a bug, but let's see.

I have an office setup with ADSL that's really inconsistent. So I decided to get a second LTE WAN interface. The routing should work something like this:
IF ADSL UP and LTE UP: route over LTE -> VOIP traffic and the rest over ADSL
IF ADSL UP and LTE DOWN: route all traffic over ADSL
IF ADSL DOWN and LTE UP: route VOIP and essential Office traffic (http/s,email,specific application)

I bought a Huawei E3372 and plugged it into my RB2011 with OTG USB Cable. After a fair bit of struggling, I got to the LTE interface working. My ADSL sits behind a modem in DMZ mode.

I've configure some traffic and routing marks and added the static route to route over LTE. Where I'm stuck now is when the LTE interface is enabled, it generates a default route that takes priority and all traffic then routes over LTE. I have unticked the "Add Default Route" in the LTE interface setup, but it still creates one. I then ticked the option and made the distance 3, but when the dynamic route is created it the distance is still 0. Strange thing is that when I close winbox and re-opens, the settings I changed is not there anymore and default route is unticked again( bug ??)

Before LTE enabled:
/ip route> print detail

 0   S  dst-address=0.0.0.0/0 gateway=192.168.8.1 gateway-status=192.168.8.1 unreachable distance=2 scope=30 
        target-scope=10 routing-mark=route LTE 

 1 A S  dst-address=0.0.0.0/0 gateway=192.168.1.1 gateway-status=192.168.1.1 reachable via  ether1-gateway distance=2 
        scope=30 target-scope=10 

 2 ADC  dst-address=192.168.1.0/30 pref-src=192.168.1.2 gateway=ether1-gateway gateway-status=ether1-gateway reachable 
        distance=0 scope=10 

 3 ADC  dst-address=192.168.88.0/24 pref-src=192.168.88.1 gateway=bridge-local gateway-status=bridge-local reachable 
        distance=0 scope=10 
After LTE enabled:
/ip route> print detail

 0 A S  dst-address=0.0.0.0/0 gateway=192.168.8.1 gateway-status=192.168.8.1 reachable via  lte1 distance=2 scope=30 
        target-scope=10 routing-mark=route LTE 

 1 ADS  dst-address=0.0.0.0/0 gateway=192.168.8.1 gateway-status=192.168.8.1 reachable via  lte1 distance=0 scope=30 
        target-scope=10 vrf-interface=lte1 

 2   S  dst-address=0.0.0.0/0 gateway=192.168.1.1 gateway-status=192.168.1.1 reachable via  ether1-gateway distance=2 
        scope=30 target-scope=10 

 3 ADC  dst-address=192.168.1.0/30 pref-src=192.168.1.2 gateway=ether1-gateway gateway-status=ether1-gateway reachable 
        distance=0 scope=10 

 4 ADC  dst-address=192.168.8.0/24 pref-src=192.168.8.100 gateway=lte1 gateway-status=lte1 reachable distance=0 scope=10 

 5 ADC  dst-address=192.168.88.0/24 pref-src=192.168.88.1 gateway=bridge-local gateway-status=bridge-local reachable 
        distance=0 scope=10 
I have still to figure out the failover scripts etc. but this is where I'm stuck for now.
Capture_LTE.PNG
Any assistance would be greatly appreciated.

Stefan
You do not have the required permissions to view the files attached to this post.
 
GoogleFoo
just joined
Posts: 2
Joined: Fri Nov 18, 2016 1:19 am

Re: Traffic-type load balancing with LTE interface

Fri Nov 18, 2016 1:25 am

I am having the same issue using a Telstra Huawei device, running the latest router os.

I tried via the command line but i can not see these details in an export or changed in settings window.

A bug in router os maybe?
 
stef123
just joined
Topic Author
Posts: 12
Joined: Sun Jul 10, 2016 10:49 pm

Re: Traffic-type load balancing with LTE interface

Sun Nov 20, 2016 9:04 pm

I've found the cause for my issue: The DHCP Client created the default route, I disabled it and my initial routing issue was resolved.

At the moment I'm struggling to get VoIP working over the LTE interface.I disable eth1 (ADSL) and enable LTE with LTE routing and NAT configured. Browsing & email works fine, but for some reason VoIP doesn't. My VoiP provider requested that I disable the firewall or SIP ALG on my router. Seeing that VoIp works fine over my eth1 interface I don't think the issue is on RouterOS. The admin console for the E3372 dongle does not have options for SIP ALG.

Someone told me they suspect a double NAT to be the issue - but would that not also influence the working traffic??

I'm at my wits' end.
 
GoogleFoo
just joined
Posts: 2
Joined: Fri Nov 18, 2016 1:19 am

Re: Traffic-type load balancing with LTE interface

Mon Nov 21, 2016 11:47 pm

double or triple nat, in the case of some 4G\LTE could be getting you stuck.

You can try a vpn tunnel, to get out to an external service, i have seen it done for a mail server(onsite exchange) over a 4G dongle to get mail in.

Also try port Forwarding sip 5060 and RTP traffic 10000 - 11000 range usually.

SIP ALG can cause issues but you can usually register a hand set still, your call just don't work so well.

Also i updated my DHCP client default route setting and fixed my issue, thanks!
 
User avatar
pennytone
just joined
Posts: 19
Joined: Wed Oct 09, 2013 10:50 pm
Location: USA

Re: Traffic-type load balancing with LTE interface

Tue May 30, 2017 8:32 pm

I just gave a presentation on SIP ALG at the Mikrotik MUM in Denver Colorado 2017 explaining everything about SIP ALG in RouterOS
watch here:
https://youtu.be/tM7wyKdnIKA
David

Who is online

Users browsing this forum: No registered users and 30 guests