Community discussions

 
Alexybg
just joined
Topic Author
Posts: 12
Joined: Tue Dec 13, 2016 5:10 pm

Problem whit POP3 mail Server / Load Balance whit recursive GW

Tue Dec 13, 2016 7:49 pm

Hello all,
I have used load balance Configuration whit recursive GW.
2 WAN
Configuration work good.
I have problem whit my POP3 Mail. My mail is on one of my Internet Provider WAN1.
I can send Email's only from him, receive is not a problem ( that is the configuration from Provider ) It can't be changed .
That is the reason that want to make my local PC when try to access mail server of this provider to go through WAN1.
I have try this :
/ip route
add comment=Mail distance=1 dst-address=212.39.90.0/24 gateway=ether1-gateway
not work

Try whit mark of source (local) IP which use POP3,
/IP mangle
add action=mark-connection chain=prerouting new-connection-mark=Mail passthrough=yes src-address=192.168.0.11
/ip route
add comment=Mail distance=1 dst-address=212.39.90.0/24 gateway=ether1-gateway routing-mark=Mail
Try whit mark of dst adress of POP3,
/IP mangle
add action=mark-connection chain=prerouting dst-address=212.39.90.60 new-connection-mark=Mail passthrough=yes
/Ip route
add comment=Mail distance=1 scr-address=192.168.0.104 gateway=ether1-gateway routing-mark=Mail

Mark is working ....
but routing not working always

Pls Help
Regards
 
tr00g33k
Frequent Visitor
Frequent Visitor
Posts: 84
Joined: Sun Mar 29, 2015 3:58 pm

Re: Problem whit POP3 mail Server / Load Balance whit recursive GW

Tue Dec 13, 2016 10:19 pm

Two ideas, do you maybe have fast path enabled ? Common error when dealing with mangle rules.

Other try with packet marking.

And if still you cannot solve this, try to post the whole configuration so we can see the whole picture
 
Alexybg
just joined
Topic Author
Posts: 12
Joined: Tue Dec 13, 2016 5:10 pm

Re: Problem whit POP3 mail Server / Load Balance whit recursive GW

Wed Dec 14, 2016 10:23 am

I have try fast path :(
I think problem is whit my routing table may be
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: No registered users and 27 guests