Community discussions

 
BorislavTP
just joined
Topic Author
Posts: 3
Joined: Fri Nov 25, 2016 3:52 pm

Vodafone K4201-Z LTE USB Modem Installation

Thu Dec 15, 2016 9:41 pm

I am new in RouterOS.
I have tried to establish internet connection with Vodafone K4201-Z LTE USB Modem in RB2011UAS-IN router with OS v6.38rc.
But I can't configure it.
I connect the modem to USB port and it lights blue, showing it work on LTE and it appears in interfaces view in the router.
I have configured entering APN, Username, Password and LTE box checked.
Entered DHCP client:
/ip dhcp-client
add default-route-distance=51 disabled=no interface=lte1
And NAT firewall:
/ip firewall nat
add action=masquerade chain=srcnat out-interface=lte1

I have tried to scan LTE:
[admin@MikroTik] > /interface lte scan
number: 0
failure: Modem does not have serial interface!

[admin@MikroTik] > /interface lte info LTE once
failure: Modem does not have serial interface!

Could anyone please help me?
Thank you in advance.
Last edited by BorislavTP on Thu Mar 09, 2017 12:08 pm, edited 1 time in total.
 
BorislavTP
just joined
Topic Author
Posts: 3
Joined: Fri Nov 25, 2016 3:52 pm

Re: Vodafone K4201-Z LTE USB Modem Installation

Thu Mar 09, 2017 12:06 pm

I have finally found solution for my problem.
Now LTE modem works fine.
:D
 
janus20
Member Candidate
Member Candidate
Posts: 111
Joined: Thu Nov 03, 2016 10:31 am
Location: Pitesti, Romania

Re: Vodafone K4201-Z LTE USB Modem Installation

Thu Mar 09, 2017 1:28 pm

Hi,

And the solution was/is ? Might help other users in the same situation too :)

kind regards,
 
gszpiniak
just joined
Posts: 14
Joined: Mon Oct 25, 2010 9:52 pm
Location: Barcelona

Re: Vodafone K4201-Z LTE USB Modem Installation

Wed Mar 15, 2017 12:01 pm

Hi friend, I have the same problem with the E3272 modem, please you can share the solution with everyone so we solve it too ... thank you very much for the collaboration.
 
bazilio
just joined
Posts: 3
Joined: Wed Mar 15, 2017 9:54 pm
Location: Ukraine

Re: Vodafone K4201-Z LTE USB Modem Installation

Wed Mar 15, 2017 10:04 pm

So, friends, anyone fix this problem also? Can anybody give solution about that?
PS.
I'm using a 3G modem, but I have the same problem. But I found that if I connect the modem through the USB hub, and if the hub and modem are defined as 12Mbps, then in this case everything works and practically does not vanish. But I use it no long time. But if the modem is defined as 480Mbps, the device permanently disappears from the list and the connection does not work. I think I will buy the USB 1.1 hub. It will be slower than 2.0, but it works. And since this is a backup link, it will suit me.
The only bad thing is that the manufacturer does not fix this problem, which, judging by the topics on the Internet, occurs quite often.
 
User avatar
matiaszon
Member
Member
Posts: 305
Joined: Mon Jul 09, 2012 9:26 am

Re: Vodafone K4201-Z LTE USB Modem Installation

Sat Mar 18, 2017 2:19 am

Most probably, described situations with 4G modems here are for HiLink modems. It means, that they have NAT built in. MikroTik get the IP, but the real gateway is 4G modem itself.
You have 3 options.

1. Set up everything on your modem. Configure DMZ on your MikroTik IP and make a routing there. For home purposes should be enough.
2. Buy a Dovado router, which is able to bridge USB with Ethernet. As the result you have the IP from your ISP assigned directly to your ether port working as WAN.
3. Change (or modify if possible) your HiLink modem to normal modem and create ppp connection on MikroTik. Disadvantage is, thet it is limited with speed to 20-30 Mbps. If you can't get more, that's OK, but if in your are you can get 100 Mbps, you will miss them...

Who is online

Users browsing this forum: Google [Bot] and 33 guests