Community discussions

MikroTik App
 
nigslaysa
just joined
Topic Author
Posts: 15
Joined: Wed Apr 06, 2016 11:08 am

Routing connections to 2nd Gateway

Tue Jan 17, 2017 3:28 pm

Good day I want to route my steam connection to my 2nd gateway
/ip firewall mangle
add action=mark-connection chain=prerouting comment=Steam dst-port=27000-27060 new-connection-mark=steam protocol=udp passthrough=yes
add action=mark-routing connection-mark=steam new-routing-mark=GW2 passtrough=no
/ip route
add gateway=ether2 routing-mark=GW2
I just can't make it work. :(
Last edited by nigslaysa on Sun Jan 22, 2017 10:16 am, edited 1 time in total.
 
tclafoe
just joined
Posts: 7
Joined: Thu Dec 29, 2016 1:36 pm

Re: Routing connections to 2nd Gateway

Thu Jan 19, 2017 6:36 pm

Do you really meant "dst-port=27000-2760" and not instead "dst-port=27000-27600"?
If this was a typo, it might be part of the problem.
 
nigslaysa
just joined
Topic Author
Posts: 15
Joined: Wed Apr 06, 2016 11:08 am

Re: Routing connections to 2nd Gateway

Sun Jan 22, 2017 10:17 am

that was a type sorry fixed it. anyhow steam connection still wont go to 2nd gateway
 
savage
Forum Guru
Forum Guru
Posts: 1220
Joined: Mon Oct 18, 2004 12:07 am
Location: Cape Town, South Africa
Contact:

Re: Routing connections to 2nd Gateway

Sun Jan 22, 2017 11:02 am

As UDP is stateless, you can't use mark-connection - there is no connection to mark.

try
/ip firewall mangle
add action=mark-routing chain=preprouting comment=Steam dst-port=27000-27600 protocol=udp passthrough=no new-routing-mark=GW2
Regards,
Chris
 
User avatar
pukkita
Trainer
Trainer
Posts: 3037
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Routing connections to 2nd Gateway

Sun Jan 22, 2017 1:20 pm

UDP protocol is stateless per se, you're right.

But ROS conntrack keeps state of UDP connections by its own, you can mark-connections on UDP.
Captura de pantalla 2017-01-22 a la(s) 12.21.48.png
Post a screenshot where counters can be seen. Is that router masquerading correctly (if it needs to)?. Post a diagram with rest of devices, IPs and routes.
You do not have the required permissions to view the files attached to this post.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum

Who is online

Users browsing this forum: boyko and 31 guests