Community discussions

 
User avatar
lapsio
Member
Member
Topic Author
Posts: 472
Joined: Wed Feb 24, 2016 5:19 pm

How to connect to CCR1009 using RS232?

Thu Jan 26, 2017 2:48 am

Hi, CC1009-PC just arrived and providing it has RS232 port and I happen to have RS232 port in PC and RS232 cable I'd like to configure router using RS232 instead of ssh/web/winbox.

So I connected cable aaaand I think it doesn't work. I never really used serial port in Linux before. I tried to connect using minicom but no luck. I got random characters. Then I tried to connect using picocom. The same:
lapsio@linux-qzuq ~> sudo picocom -b 9600 /dev/ttyS0
picocom v1.6

port is        : /dev/ttyS0
flowcontrol    : none
baudrate is    : 9600
parity is      : none
databits are   : 8
escape is      : C-a
local echo is  : no
noinit is      : no
noreset is     : no
nolock is      : no
send_cmd is    : sz -vv
receive_cmd is : rz -vv
imap is        : 
omap is        : 
emap is        : crcrlf,delbs,

Terminal ready
�������
Welcome to minicom 2.7                                                                                                          
                                                                                                                                
OPTIONS: I18n                                                                                                                   
Port /dev/ttyS0, 01:41:37                                                                                                       
                                                                                                                                
Press CTRL-A Z for help on special keys                                                                                         
                                                                                                                                
a���a���a����������������������h��e�l�p�                                                                                        
�   
With following settings:
OPTI+-----------------------------------------------------------------------+                                                   
Port| A -    Serial Device      : /dev/ttyS0                                |                                                   
    |                                                                       |                                                   
Pres| C -   Callin Program      :                                           |                                                   
    | D -  Callout Program      :                                           |                                                   
a���| E -    Bps/Par/Bits       : 9600 8N1                                  |                                                   
�   | F - Hardware Flow Control : No                                        |                                                   
    | G - Software Flow Control : No                                        |                                                   
    |                                                                       |                                                   
    |    Change which setting?                                              |                                                   
    +-----------------------------------------------------------------------+ 
Those non-printable characters seem to be echoed-back after I type something. When I don't type anything terminal is just empty and nothing happens.
On networking laboratories at uni we just typed minicom and it connected automatically to Cisco router so I'm a bit confused :C
Also I'm not entirely absolutely sure if it's null-modem cable but I guess it is.
MTCNA, MTCRE, MTCINE
 
turnip
Frequent Visitor
Frequent Visitor
Posts: 66
Joined: Wed Sep 11, 2013 7:01 pm

Re: How to connect to CCR1009 using RS232?

Thu Jan 26, 2017 6:24 am

The default baud rate on Mikrotik devices is 115200.

Who is online

Users browsing this forum: No registered users and 28 guests