Community discussions

 
dreal
just joined
Topic Author
Posts: 6
Joined: Wed Mar 08, 2017 7:49 pm

Usb modem settings/provider page

Wed Mar 08, 2017 7:57 pm

Hello to everyone,

Another noob to the forum.....
Let cut to the chase. I have a mikrotik rb951ui-2hnd router and a huaweie3531 usb modem. I have create they wifi and everything but some times when i login in the wifi with a device it opens up the usb settings page.

How can i avoid to user of the wifi dont entering in that page? and pls give easy steps to follow as i am a noob.

thanks in advance.
 
User avatar
matiaszon
Member
Member
Posts: 305
Joined: Mon Jul 09, 2012 9:26 am

Re: Usb modem settings/provider page

Wed Mar 08, 2017 9:05 pm

Not sure about your question... You mean, that sometimes instead of opening a desired website you open a web interface of huawei modem?
 
dreal
just joined
Topic Author
Posts: 6
Joined: Wed Mar 08, 2017 7:49 pm

Re: Usb modem settings/provider page

Wed Mar 08, 2017 9:19 pm

exactly!!!!!!!!
 
User avatar
matiaszon
Member
Member
Posts: 305
Joined: Mon Jul 09, 2012 9:26 am

Re: Usb modem settings/provider page

Wed Mar 08, 2017 9:53 pm

Is the IP of the huawei modem 192.168.8.1 and your WAN on MikroTik is from the range 192.168.8.0/24? And what is your LAN address range?

Assuming that:
1) your huawei modem is 192.168.8.1
2) your WAN has to be in range 192.168.8.0/24
3) your LAN is 10.1.1.0/24

then put this in your MikroTik's console:
/ip firewall filter add chain=forward src-address=10.1.1.0/24 dst-address=192.168.8.1 action=drop
However, if you do this, you won't be able to access modem's web interface as well! To avoid that, you have disable that rule everytime before you want to log in, or add accepting rule BEFORE you put the above. Otherwise, you have to place accepting rule as first:
/ip firewall filter add chain=forward src-address=ALLOWED_IP_ADDRESS dst-address=192.168.8.1 action=accept
After all it has to look like this:
[admin@MikroTik] > /ip firewall filter print 
Flags: X - disabled, I - invalid, D - dynamic 

 1    chain=forward action=accept src-address=YOUR_ALLOWED_IP dst-address=192.168.8.1 log=no log-prefix="" 

 2    chain=forward action=drop src-address=10.1.1.0/24 dst-address=192.168.8.1 log=no log-prefix="" 
YOUR_ALLOWED_IP is of course the IP of the computer that you want TO GIVE access to your modem's web interface.
Last edited by matiaszon on Thu Mar 09, 2017 11:47 pm, edited 1 time in total.
 
dreal
just joined
Topic Author
Posts: 6
Joined: Wed Mar 08, 2017 7:49 pm

Re: Usb modem settings/provider page

Thu Mar 09, 2017 11:52 am

Worked..... thank you!!!!!

Who is online

Users browsing this forum: Google [Bot] and 23 guests