Community discussions

MUM Europe 2020
 
academic
just joined
Topic Author
Posts: 2
Joined: Thu Mar 09, 2017 3:29 pm

Bridge src-nat does not work

Thu Mar 09, 2017 4:15 pm

I have a several EoIP-tunnels builded via RB951Ui-2nD RouterOS 6.37.3. Clients devices over the tunnels are united into common local network.
I ned to hide the real mac addresses of clients devices, connected to ethernet ports of router (sometimes client mac-adresses are repeated).
I configured src-nat on the bridge:
/interface bridge port
add bridge=EoIP-Br-0 interface=ether1-Lan
add bridge=EoIP-Br-0 interface=eoip-tunnel
/interface bridge nat
add action=src-nat chain=srcnat out-interface=eoip-tunnel to-src-mac-address=02:5E:C3:10:AF:0F

But it doesn't work. On the other side of tunnel i see the real mac-address of device, connected to ether1.
What i am doing wrong?
 
Zwodka
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Fri Sep 19, 2014 9:41 pm
Location: Hungary

Re: Bridge src-nat does not work

Wed Nov 01, 2017 12:32 am

I'am also interested in, but I use only ethernet interfaces:

/interface bridge port
add bridge=Br-Lan interface=ether1
add bridge=Br-Lan interface=ether2
add bridge=Br-Lan interface=ether3
add bridge=Br-Lan interface=ether4
add bridge=Br-Lan interface=ether5

And:

/interface bridge nat
add action=src-nat chain=srcnat out-interface=ether1 src-mac-address=12:34:56:78:90:AB to-src-mac-address=23:45:67:89:AB:CD

Is it the right usage?

Who is online

Users browsing this forum: No registered users and 24 guests