Community discussions

 
User avatar
mikrotom
just joined
Topic Author
Posts: 3
Joined: Sun Mar 19, 2017 12:00 am

Using MikroTik hAP as simple switch plus wireless AP

Sun Mar 19, 2017 12:22 am

Greetings everyone,

I'm new to RouterOS and my shiny MikroTik hAP.
Please forgive me if this question has been asked before, I could not find the answer by myself.

The problem, I already have a router from my provider, this one does NAT, DHCP and wireless on the ground floor.
Now, in the basement is the new MikroTik hAP, connected to the main router with ethernet.

As the MikroTik hAP acts as a router and DHCP server itself of course there are now problems on my little home LAN.
Too many cooks spoil the broth.

My question, how can I configure the MikroTik hAP to use ether1 as uplink and ether2 - ether5 as "dumb" switch ports?
While preserving the router/dhcp/etc functionality on the wireless part?

Sorry for the terms, I'm still trying to sort them. :)

Cheers, Tom
 
User avatar
null31
Member Candidate
Member Candidate
Posts: 177
Joined: Fri Dec 23, 2016 6:07 pm
Location: Brazil

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Mar 21, 2017 2:01 am

Hi, default configuration does exactly that.
https://wiki.mikrotik.com/wiki/Manual:D ... s#WAN_Port
  • Ether2 - Ether5, switch mode.
  • Wireless is bridge with "switch" ports
  • LAN (switch mode) side have DHCP Server and DNS cache
  • Ether1 is the WAN ("Internet") with DHCP Client to get some an IP from the Router ISP.
You can reset the configuration to Default.
https://wiki.mikrotik.com/wiki/Manual:Reset
 
erlinden
Member Candidate
Member Candidate
Posts: 166
Joined: Wed Jun 12, 2013 1:59 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Mar 21, 2017 1:30 pm

If I understand correctly, you are looking for a way to let your device work as a switch with accesspoint functionallity.

This can be easaly done by resetting the device with no default configuration:
viewtopic.php?t=71522
Then create a bridge and attach all the interfaces.
Configure DHCP client and WiFi and you're done.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24157
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Mar 21, 2017 1:58 pm

actually null31 already answered. the devices are configured in SWITCH configuration out of the box already
No answer to your question? How to write posts
 
erlinden
Member Candidate
Member Candidate
Posts: 166
Joined: Wed Jun 12, 2013 1:59 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Mar 21, 2017 2:13 pm

Thought default configuration contained masquerade and DHCP server...my mistake.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24157
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Mar 21, 2017 2:21 pm

Thought default configuration contained masquerade and DHCP server...my mistake.
not between the switched ports. ports 2-5 are simply switched together. NAT exists between the bridge and the first port.
No answer to your question? How to write posts
 
User avatar
mikrotom
just joined
Topic Author
Posts: 3
Joined: Sun Mar 19, 2017 12:00 am

Re: Using MikroTik hAP as simple switch plus wireless AP

Mon Mar 27, 2017 10:31 pm

Thank you everyone for the answers!

With the default config, there is a NAT between port 1 and port2-5 (the ports behind the bridge), right?
Would it be possible to configure the MikroTik hAP so there is 'nothing' on and between all ethernet ports? No DHCP server and no bridge/NAT?

So the MikroTik just acts as a switch on the ethernet ports?
But still acts as a DHCP server for the bridge/NAT to the WLAN interfaces?

The idea is to safe energy and devices.
I'm currently using a switch between the 'master' on the ground floor and the MikroTik in the basefloor, because I need the same subnet in the basement too.
If possible I'd like to remove that switch and do the 'switching' with the MikroTik (I'm currently not using ethernet port 2-5 due to the NAT).

The WLANs in the basement are no problem, those can be different networks.

Is is somewhat clear what I'm trying to achieve?
I tried a few things, but my knowledge is limited and I now really like the 'Safe Mode' button. :)

Cheers, Tom
 
User avatar
mikrotom
just joined
Topic Author
Posts: 3
Joined: Sun Mar 19, 2017 12:00 am

Re: Using MikroTik hAP as simple switch plus wireless AP

Mon Mar 27, 2017 10:38 pm

Addendum;
If I understand correctly, you are looking for a way to let your device work as a switch with accesspoint functionallity.
Yes!
This can be easaly done by resetting the device with no default configuration:
viewtopic.php?t=71522
Then create a bridge and attach all the interfaces.
Configure DHCP client and WiFi and you're done.
That's the point I was happy with safe mode. I was never able to connect to the device with no default configuration. :?
 
erlinden
Member Candidate
Member Candidate
Posts: 166
Joined: Wed Jun 12, 2013 1:59 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Mar 28, 2017 3:41 pm

That's the point I was happy with safe mode. I was never able to connect to the device with no default configuration. :?
Think I had to connect through WiFi to be able to connect...
 
User avatar
matiaszon
Member
Member
Posts: 305
Joined: Mon Jul 09, 2012 9:26 am

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Mar 28, 2017 4:34 pm

That's the point I was happy with safe mode. I was never able to connect to the device with no default configuration. :?
And how did you wanted to do that?
 
ukracer
just joined
Posts: 14
Joined: Sun Feb 17, 2019 7:21 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Sun Feb 17, 2019 7:26 pm

If I understand correctly, you are looking for a way to let your device work as a switch with accesspoint functionallity.

This can be easaly done by resetting the device with no default configuration:
viewtopic.php?t=71522
Then create a bridge and attach all the interfaces.
Configure DHCP client and WiFi and you're done.
I realise this is an old thread but its very relevant to me. lol

IF I could just find a dummies guide to "Then create a bridge and attach all the interfaces.
Configure DHCP client and WiFi and you're done." all would be fantastic.

Grateful for any replies.
 
User avatar
vecernik87
Long time Member
Long time Member
Posts: 642
Joined: Fri Nov 10, 2017 8:19 am

Re: Using MikroTik hAP as simple switch plus wireless AP

Mon Feb 18, 2019 11:05 pm

It is actually not that hard, as it may look. Basic knowledge of network is recommended. (I thought there is some basic manual on wiki but I couldn't find one... I assume you are asking for such simple questions that nobody ever thought to write it up...)
  1. Create Bridge - well, this literary says what to do. Go to Bridge menu, create new bridge (button with "+" symbol in winbox or button with "add new" text in webfig), name it as you want and hit OK/Save
  2. Attach interfaces - again pretty simple: Go to Bridge Menu, tab "ports" (because you want to add port to the bridge) again hit the "add new" button, select port and bridge and thats it :) You can either select ports one by one or you can simply select "all" item which will add all of them at once (but then you lose ability to control them separately)
  3. Configure DHCP client - Go to IP -> DHCP Client, again "add new", name it properly and select your "bridge" as interface (you should never select specific port which is on the bridge, because such interface is in "slave" mode and the configuration will not work correctly)
  4. Configure wifi - fortunately, there is a tutorial: https://wiki.mikrotik.com/wiki/Manual:M ... ireless_AP (just the first part about wireless and security profile)
Or you can reset your config and go the easy way with "quickset", in top-left corner of the window select "wisp AP" and select "bridge" mode... That will do practically same result...

If something does not work as expected, most likely there is a mistake in your config. If you can't find a solution using https://wiki.mikrotik.com/wiki/Category:Manual , try to summarize your situation, explain what you are trying to achieve, what worked, what didnt worked and export your config using terminal command
/export hide-sensitive
(and paste it here). That way, anyone will easily understand your whole config and there is higher chance that you get your answers.
 
mkx
Forum Guru
Forum Guru
Posts: 2828
Joined: Thu Mar 03, 2016 10:23 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Feb 19, 2019 8:28 am

I guess the big problem with such "simple" tasks is that prior to starting to configure, RB needs to be reset with no configuration. And then usual (by SOHO standards) configuration method (use web browser) doesn't work, one needs to use Winbox. If there was a really basic preset configuration (e.g. bridge with only last ethernet port attached and basic IP setup - IP address and DHCP server running), this would be much easier.
After that, this kind of setup (ethernet switch with AP) would be easy to do even using Webfig (just add the rest of ethernet ports to the bridge, add all wlan interfaces to the bridge ... and if you're happy with IP subnet, you're already done).
The above mentioned basic configuration could be a good start even for more complex configurations ... after all, one could configure the rest of ports (including setting up another bridge) leaving out the last ether port ... then reconnect to another ether port and finish own setup by adding the last ether port and removing the rest of settings (IP setup, original bridge).

As there's no such simple default config to choose in quickset, things get complicated out of beginner users' proportions.
BR,
Metod
 
User avatar
vecernik87
Long time Member
Long time Member
Posts: 642
Joined: Fri Nov 10, 2017 8:19 am

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Feb 19, 2019 10:09 am

True :(
Unfortunately the "Home AP" or "Home AP dual" is not just pure AP but router+AP.
This seems to be solved in the "WISP AP" which offers choice between "router" and "bridge" mode (and really adds everything into one bridge) Unfortunately it offers only 5G wifi config within quickset, so user has to configure 2G wifi separately.
So if Mikrotik implements the mode (bridge/router) selector into Home AP / Home AP dual, it would actually cover all possible cases.

(during all these tests I also noticed that
/system reset-configuration
creates backup file in ramdisk instead of flash storage, so it actually does not survive reboot and therefore switch
skip-backup=yes
is completely irrelevant on devices with ramdisk because backup never stays... Now I wonder if it is feature or bug and whether it should be reported through support@...)
 
anav
Forum Guru
Forum Guru
Posts: 2940
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Feb 19, 2019 3:25 pm

I use the wisp mode for my capACs because it works and is simple.
The default mode passes everything through the ACL part of the wisp configuration by default (which I use my other RB for anyway).
no nat to worry about.
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
ukracer
just joined
Posts: 14
Joined: Sun Feb 17, 2019 7:21 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Feb 19, 2019 5:50 pm

It is actually not that hard, as it may look. Basic knowledge of network is recommended. (I thought there is some basic manual on wiki but I couldn't find one... I assume you are asking for such simple questions that nobody ever thought to write it up...)
  1. Create Bridge - well, this literary says what to do. Go to Bridge menu, create new bridge (button with "+" symbol in winbox or button with "add new" text in webfig), name it as you want and hit OK/Save
  2. Attach interfaces - again pretty simple: Go to Bridge Menu, tab "ports" (because you want to add port to the bridge) again hit the "add new" button, select port and bridge and thats it :) You can either select ports one by one or you can simply select "all" item which will add all of them at once (but then you lose ability to control them separately)
  3. Configure DHCP client - Go to IP -> DHCP Client, again "add new", name it properly and select your "bridge" as interface (you should never select specific port which is on the bridge, because such interface is in "slave" mode and the configuration will not work correctly)
  4. Configure wifi - fortunately, there is a tutorial: https://wiki.mikrotik.com/wiki/Manual:M ... ireless_AP (just the first part about wireless and security profile)
Or you can reset your config and go the easy way with "quickset", in top-left corner of the window select "wisp AP" and select "bridge" mode... That will do practically same result...

If something does not work as expected, most likely there is a mistake in your config. If you can't find a solution using https://wiki.mikrotik.com/wiki/Category:Manual , try to summarize your situation, explain what you are trying to achieve, what worked, what didnt worked and export your config using terminal command
/export hide-sensitive
(and paste it here). That way, anyone will easily understand your whole config and there is higher chance that you get your answers.

AAarRRgg I have a head ache,

I thought I understood what I needed to do but ports are already added and all but 2 are disabled.

I will try and get my config but to be honest I have not altered anything just assigned a static IP followed the tutorial and then logged in again.

To be honest I looks like it has not installed the latest firmware...but as I say I am off to find that config..
 
ukracer
just joined
Posts: 14
Joined: Sun Feb 17, 2019 7:21 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Feb 19, 2019 6:00 pm

Ok I have run that command and got something.

[admin@MikroTik] > /export
# jan/02/1970 00:29:12 by RouterOS 6.43.2
# software id = 8F26-FZVB
#
# model = RouterBOARD 952Ui-5ac2nD
# serial number = 7C3307CE4102
/interface bridge
add admin-mac=64:D1:54:73:5D:A2 auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-735DA7 wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-735DA6 wireless-protocol=802.11
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.0.101-192.168.0.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge interface=ether1
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
add interface=ether5 list=LAN
add interface=wlan2 list=LAN
add interface=wlan1 list=LAN
/ip address
add address=192.168.0.100/24 comment=defconf interface=ether2 network=192.168.0.0
/ip dhcp-client
# DHCP client can not run on slave interface!
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.0.0/24 comment=defconf gateway=192.168.0.100 netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.0.100 name=router.lan
/ip firewall filter
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
/system routerboard settings
set silent-boot=no
[admin@MikroTik] >




I cant find any identifying/personal info so here goes..
 
anav
Forum Guru
Forum Guru
Posts: 2940
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Feb 19, 2019 8:03 pm

edit: first half of post removed due to error.

/ip address
add address=192.168.0.100/24 comment=defconf interface=ether2 network=192.168.0.0

(2) The interface should be the bridge NOT ether2.
Last edited by anav on Fri Feb 22, 2019 5:07 pm, edited 1 time in total.
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
User avatar
vecernik87
Long time Member
Long time Member
Posts: 642
Joined: Fri Nov 10, 2017 8:19 am

Re: Using MikroTik hAP as simple switch plus wireless AP

Wed Feb 20, 2019 2:21 am

@ukracer: Well, this config is clearly default one. I wrongly assumed that you did the config reset with "no-defaults" as mentioned in the original text which you quoted:
This can be easaly done by resetting the device with no default configuration:
viewtopic.php?t=71522
If you start with some config already applied, it is bit more challenging because there will be a lot of setting which needs to be removed/changed. Given the config you posted I would suggest following:
(keep in mind that I still assume you want to have switch+wifi. If your goal is different, let us know)
  1. go to interface -> interface list: double-click on entry with ether1 interface and change the List from WAN to LAN
  2. go to IP -> dhcp-server: remove or disable the DHCP server (buttons - or x)
  3. go to IP -> addresses: doubleclick on the entry with 192.168.0.100 and change interface from ether2 to bridge
  4. go to IP -> dhcp-client: doubleclick on the entry and change interface from ether1 to bridge - if your home network is in 192.168.0.xxx range and you want to keep static IP 192.168.0.100, you may disable/remove the dhcp-client instead of changing it.
  5. go to Bridge -> ports: one by one, attach remaining ports ether3, ether4, ether5 and wlan2 to bridge (for each, add new entry by clicking on + button, select corresponding ethernet interface and bridge, confirm with OK button)
  6. go to Wireless -> Security Profiles: doubleclick on "default" entry, change Mode to dynamic keys, check WPA2 PSK and both aes ccm, uncheck WPA PSK, WPA EAP, WPA2 EAP, and both tkip. Set some wifi password into "WPA2 Pre-Shared Key" fields This step is not necessary but without it, your wifi will be open to everyone and that is dangerous. If you have some really old device which won't connect, you may try to check "WPA PSK" and both tkip fields. In such case, don't forget to put your password also to "WPA Pre-Shared Key" field. Old WPA protocol or TKIP encryption are not considered very secure but if your devices require it, I guess you don't have much choice. You can change it anytime later.
I recommend to do it in order as written, otherwise your mikrotik dhcp-server may interfere with rest of the network.
When you disable your DHCP server, you might lose connection. In such case, don't panic and connect your winbox via MAC address (works best if you are directly connected by ethernet cable to LAN port - currently ether2)

Once you are done with all these things, you should see your network without any issue on all ports. If you have any issues, share again your current config. As you already noticed, no personal stuff is there and it gives us complete overview of your setting which makes it easy to help.
If everything goes right, you can also clear your firewall rules in IP->firewall->filter and IP->firewall->NAT

@anav
does the wisp ap mode on your cAP configure only 5G wifi or both 2G and 5G? I actually tried that earlier on my hAP ac^2 and it worked perfectly, except skipping the 2G wifi configuration.
 
anav
Forum Guru
Forum Guru
Posts: 2940
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: Using MikroTik hAP as simple switch plus wireless AP

Wed Feb 20, 2019 2:29 am

oops my bad, ether1 is not an ISP port its just a switch trunk port from the router my apologies the second issue remains and needs to be fixed.


Also you only need to configure
interfaces
bridge
wifi
vlans
Everything else is covered by the MT router

@vern, dont remember and cant play with capac at the moment
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
ukracer
just joined
Posts: 14
Joined: Sun Feb 17, 2019 7:21 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Wed Feb 20, 2019 5:31 pm

@ukracer: Well, this config is clearly default one. I wrongly assumed that you did the config reset with "no-defaults" as mentioned in the original text which you quoted:
This can be easaly done by resetting the device with no default configuration:
viewtopic.php?t=71522
If you start with some config already applied, it is bit more challenging because there will be a lot of setting which needs to be removed/changed. Given the config you posted I would suggest following:
(keep in mind that I still assume you want to have switch+wifi. If your goal is different, let us know)
  1. go to interface -> interface list: double-click on entry with ether1 interface and change the List from WAN to LAN
  2. go to IP -> dhcp-server: remove or disable the DHCP server (buttons - or x)
  3. go to IP -> addresses: doubleclick on the entry with 192.168.0.100 and change interface from ether2 to bridge
  4. go to IP -> dhcp-client: doubleclick on the entry and change interface from ether1 to bridge - if your home network is in 192.168.0.xxx range and you want to keep static IP 192.168.0.100, you may disable/remove the dhcp-client instead of changing it.
  5. go to Bridge -> ports: one by one, attach remaining ports ether3, ether4, ether5 and wlan2 to bridge (for each, add new entry by clicking on + button, select corresponding ethernet interface and bridge, confirm with OK button)
  6. go to Wireless -> Security Profiles: doubleclick on "default" entry, change Mode to dynamic keys, check WPA2 PSK and both aes ccm, uncheck WPA PSK, WPA EAP, WPA2 EAP, and both tkip. Set some wifi password into "WPA2 Pre-Shared Key" fields This step is not necessary but without it, your wifi will be open to everyone and that is dangerous. If you have some really old device which won't connect, you may try to check "WPA PSK" and both tkip fields. In such case, don't forget to put your password also to "WPA Pre-Shared Key" field. Old WPA protocol or TKIP encryption are not considered very secure but if your devices require it, I guess you don't have much choice. You can change it anytime later.
I recommend to do it in order as written, otherwise your mikrotik dhcp-server may interfere with rest of the network.
When you disable your DHCP server, you might lose connection. In such case, don't panic and connect your winbox via MAC address (works best if you are directly connected by ethernet cable to LAN port - currently ether2)

Once you are done with all these things, you should see your network without any issue on all ports. If you have any issues, share again your current config. As you already noticed, no personal stuff is there and it gives us complete overview of your setting which makes it easy to help.
If everything goes right, you can also clear your firewall rules in IP->firewall->filter and IP->firewall->NAT

@anav
does the wisp ap mode on your cAP configure only 5G wifi or both 2G and 5G? I actually tried that earlier on my hAP ac^2 and it worked perfectly, except skipping the 2G wifi configuration.
actually you assumed correctly...BUT it appears to not have worked I have tried the same again to confirm and when I get in I will check and export the config again so we know what is going on.

I THOUGHT I had set it to no defaults as per the text I quoted. :)
 
ukracer
just joined
Posts: 14
Joined: Sun Feb 17, 2019 7:21 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Fri Feb 22, 2019 4:15 pm

Ok I have finally managed to get to my PC and copied the config.

[admin@MikroTik] > /export
# feb/22/2019 14:13:11 by RouterOS 6.43.2
# software id = 8F26-FZVB
#
# model = RouterBOARD 952Ui-5ac2nD
# serial number = 7C3307CE4102
/interface bridge
add admin-mac=64:D1:54:73:5D:A2 auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-735DA7 wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-735DA6 wireless-protocol=802.11
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp ranges=192.168.0.101-192.168.0.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/interface bridge filter
add action=drop chain=input dst-port=68 in-interface=ether1 ip-protocol=udp mac-protocol=ip
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge interface=ether1
add bridge=bridge interface=ether3
add bridge=bridge interface=ether4
add bridge=bridge interface=ether5
add bridge=bridge interface=wlan2
/interface list member
add comment=defconf interface=ether1 list=WAN
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
add interface=ether5 list=LAN
add interface=wlan2 list=LAN
add interface=wlan1 list=LAN
/ip address
add address=192.168.0.100/24 comment=defconf disabled=yes interface=ether2 network=192.168.0.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=bridge
/ip dhcp-server network
add address=192.168.0.0/24 comment=defconf gateway=192.168.0.100 netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.0.100 name=router.lan
/ip firewall filter
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
/system clock
set time-zone-name=Europe/London
/system routerboard settings
set silent-boot=no
[admin@MikroTik] >


Any observations appreciated. ;)
 
ukracer
just joined
Posts: 14
Joined: Sun Feb 17, 2019 7:21 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Sun Feb 24, 2019 4:22 pm

is that a non default config or do i need to start all over again.

cheers

Andy T
 
anav
Forum Guru
Forum Guru
Posts: 2940
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: Using MikroTik hAP as simple switch plus wireless AP

Sun Feb 24, 2019 5:30 pm

If you are using this as a switch ap only then no that is not the default config.
There are many clues.
There is no need for any Ip address dhcp servers etc...……..
There is no need for bridge filter rules etc...…….
It does not look like a default router mode let alone AP switch mode.
But the real question is when will Liverpool score on MU.
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
ukracer
just joined
Posts: 14
Joined: Sun Feb 17, 2019 7:21 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Feb 26, 2019 3:11 pm

You know that headache I had ...well its got much worse. :(

I was indeed not flashing the box correctly as there was no blue activity line appearing.

Anyway I did it again 3 times and now I see what I should have seen the first time. lol

BUT the problem is I cant see what IP address the router now has. It does not work as I expect a switch to work with the main feed from the internet connected to the lan port 2 and computer to lan port 3.

I remember now why I hated networks so much. ;)
 
anav
Forum Guru
Forum Guru
Posts: 2940
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Feb 26, 2019 3:23 pm

I indeed feel your pain.
What i did was connect my PC to the router first by setting up my ipv4 static on the pc 192.168.88.2 etc............ just to access the device,
Then go to quick setup and change the mode to AP wisp.
Then change the IP address to static one that will work on your network.
Go to the main router add manually in the IP static with proper mac address.
Now add the AP to the network.
Access the AP.
Now add the rest of the info needed.
interfaces.................
identify any vlans you need
identify any wlans you need
add wifi rules
add to bridge
create bridge rules.
done
sorta
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
ukracer
just joined
Posts: 14
Joined: Sun Feb 17, 2019 7:21 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Feb 26, 2019 6:14 pm

Thats my first problem I dont know what the IP address is of the router box....since I set it with no default config and then re flashed it.
 
anav
Forum Guru
Forum Guru
Posts: 2940
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Feb 26, 2019 9:26 pm

Thats why you use your magic pin and reset it to defaults and then following the steps.
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
ukracer
just joined
Posts: 14
Joined: Sun Feb 17, 2019 7:21 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Feb 26, 2019 11:02 pm

Thats why you use your magic pin and reset it to defaults and then following the steps.
Not sure if i am just ultra thick but. I cant understand this.

"What i did was connect my PC to the router first by setting up my ipv4 static on the pc 192.168.88.2 etc............ just to access the device,"
Sorry....
 
anav
Forum Guru
Forum Guru
Posts: 2940
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: Using MikroTik hAP as simple switch plus wireless AP

Tue Feb 26, 2019 11:34 pm

Yup exactly, so why cannot you connect to the router from the PC.
If the PC is setup with static IP 192.168.88.2 and point to gateway 192.168.88.1 and the router reset to defaults it should just work
Did you startup winbox??
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
ukracer
just joined
Posts: 14
Joined: Sun Feb 17, 2019 7:21 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Wed Feb 27, 2019 12:14 am

Yup exactly, so why cannot you connect to the router from the PC.
If the PC is setup with static IP 192.168.88.2 and point to gateway 192.168.88.1 and the router reset to defaults it should just work
Did you startup winbox??
Yes tried winbox.

I can see the PC is set ok with a static IP of 192.168.88.2

But even checking with Angry IP scanner I cant see 192.168.88.1

Maybe I am just not understanding what this means " and point to gateway 192.168.88.1" I tried it in the default gateway section when setting the static IP and without but still cant see the router box..

regards Andy T
 
ukracer
just joined
Posts: 14
Joined: Sun Feb 17, 2019 7:21 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Wed Feb 27, 2019 12:19 am

I guess the big problem with such "simple" tasks is that prior to starting to configure, RB needs to be reset with no configuration. And then usual (by SOHO standards) configuration method (use web browser) doesn't work, one needs to use Winbox.
I am trying that but cant connect.

As there's no such simple default config to choose in quickset, things get complicated out of beginner users' proportions.
Tell me about it...I thought it was complicated enough but I am in a right mess now...
 
anav
Forum Guru
Forum Guru
Posts: 2940
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: Using MikroTik hAP as simple switch plus wireless AP

Wed Feb 27, 2019 1:57 am

Okay after you have used the pin to reset the router, and have setup your pc.
Just plug eth2 directly to your PC. You should be able to winbox directly into the router unless its broken???
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
ukracer
just joined
Posts: 14
Joined: Sun Feb 17, 2019 7:21 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Wed Feb 27, 2019 1:56 pm

Okay after you have used the pin to reset the router, and have setup your pc.
Just plug eth2 directly to your PC. You should be able to winbox directly into the router unless its broken???

Ok I got that to work.

I can see why I am struggling. I used to do tech support and ran into the same problem. lol

I used to assume the person I was speaking do had previous knowledge or knew what I was thinking. Its easy to not realise they dont know certain things you take for granted.

Like I did not realise winbox could connect without an IP address. :)

SO its working for now.

I am busy for the next few days but will be back onto it next week.

Thanks to all who asisted.

Out of interest can any one suggest a free mail server as I use mailtraq and it does not work with my ISP any longer. :(
 
anav
Forum Guru
Forum Guru
Posts: 2940
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: Using MikroTik hAP as simple switch plus wireless AP

Wed Feb 27, 2019 2:09 pm

Well any slight bit of research would have pointed that out, which is something most of us do and would expect one to conduct.
https://wiki.mikrotik.com/wiki/Manual:Winbox
https://wiki.mikrotik.com/wiki/Manual:F ... me_startup

Probably a few gazillon youtube examples to boot.
But I agree impossible to configure with your eyes closed.
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
opkky
just joined
Posts: 4
Joined: Mon Jan 02, 2017 8:19 am

Re: Using MikroTik hAP as simple switch plus wireless AP

Thu Apr 25, 2019 10:54 pm

If you start with some config already applied, it is bit more challenging because there will be a lot of setting which needs to be removed/changed. Given the config you posted I would suggest following:
(keep in mind that I still assume you want to have switch+wifi. If your goal is different, let us know)
  1. go to interface -> interface list: double-click on entry with ether1 interface and change the List from WAN to LAN
  2. go to IP -> dhcp-server: remove or disable the DHCP server (buttons - or x)
  3. go to IP -> addresses: doubleclick on the entry with 192.168.0.100 and change interface from ether2 to bridge
  4. go to IP -> dhcp-client: doubleclick on the entry and change interface from ether1 to bridge - if your home network is in 192.168.0.xxx range and you want to keep static IP 192.168.0.100, you may disable/remove the dhcp-client instead of changing it.
  5. go to Bridge -> ports: one by one, attach remaining ports ether3, ether4, ether5 and wlan2 to bridge (for each, add new entry by clicking on + button, select corresponding ethernet interface and bridge, confirm with OK button)
  6. go to Wireless -> Security Profiles: doubleclick on "default" entry, change Mode to dynamic keys, check WPA2 PSK and both aes ccm, uncheck WPA PSK, WPA EAP, WPA2 EAP, and both tkip. Set some wifi password into "WPA2 Pre-Shared Key" fields This step is not necessary but without it, your wifi will be open to everyone and that is dangerous. If you have some really old device which won't connect, you may try to check "WPA PSK" and both tkip fields. In such case, don't forget to put your password also to "WPA Pre-Shared Key" field. Old WPA protocol or TKIP encryption are not considered very secure but if your devices require it, I guess you don't have much choice. You can change it anytime later.
I recommend to do it in order as written, otherwise your mikrotik dhcp-server may interfere with rest of the network.
When you disable your DHCP server, you might lose connection. In such case, don't panic and connect your winbox via MAC address (works best if you are directly connected by ethernet cable to LAN port - currently ether2)

Once you are done with all these things, you should see your network without any issue on all ports. If you have any issues, share again your current config. As you already noticed, no personal stuff is there and it gives us complete overview of your setting which makes it easy to help.
If everything goes right, you can also clear your firewall rules in IP->firewall->filter and IP->firewall->NAT
vecernik87
Great thanks for your post. It saved a lot of time to me :-)
Really appreciated.
 
meszaroskrisztian
just joined
Posts: 3
Joined: Sun Apr 22, 2018 6:53 pm

Re: Using MikroTik hAP as simple switch plus wireless AP

Mon Aug 26, 2019 6:56 pm

Hi all,
I do not know this is the right thread, but I would like to set my hAP mini as the following device act:
http://www.silex.jp/support/downfile/sx ... al-eng.pdf
I would set it to be transparent, and my end-device MAC (like a laptop, set-top box) should be visible in the main routers table (without Ethernet cable, of course).
Is it possible somehow with RouterOS/Mikrotik device?

Who is online

Users browsing this forum: Bing [Bot] and 23 guests