Community discussions

 
ElVale
just joined
Topic Author
Posts: 5
Joined: Wed May 16, 2012 3:45 pm

Help getting to Internet over IPv6

Sat Apr 22, 2017 1:11 pm

I'm new to IPv6 and I'm strugling to connect to IPv6 Internet from my home LAN. My ISP gives me an ethernet port with IPv6 support. When I plug directly to the port using my laptop it automatically configures itself and I can browse IPv6 websites successfully. I look at the configuration parameters and I can see:

Router: fe80::4e09:b4ff:fef1:abcd (ISP's local link address)
IPv6 address: 2001:da8:8001:1234::ab (my global address)
Prefix length: 128

Then I unplug from the laptop and plug into ether1 on a routerboard and after after doing /ping ff02::1%ether1 and I can see the ISP’s local link address. The question now is how can I get IPv6 over WiFi? I have ether2-master and wlan bridged. I tried
/ipv6 address 
add address=2001:da8:8001:1234::ab/128 interface=ether1 advertise=no

/ipv6 route 
add gateway=fe80::4e09:b4ff:fef1:abcd%ether1
I also configured manually the same address and gateway on the laptop but it's not working, I'm quite confused here, any help would be greatly appreciated.
 
irghost
Member Candidate
Member Candidate
Posts: 281
Joined: Sun Feb 21, 2016 1:49 pm

Re: Help getting to Internet over IPv6

Sat Apr 22, 2017 1:12 pm

Mikrotik does not support IPv6 NAT
you have just one single IP (/128)
Ask ur ISP for IPv6 PD (/48-/60)
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
ElVale
just joined
Topic Author
Posts: 5
Joined: Wed May 16, 2012 3:45 pm

Re: Help getting to Internet over IPv6

Sat Apr 22, 2017 1:24 pm

I'm algo connecting over IPv4 on the same cable via PPPoE, is there a way to transparently bridge the IPv6 address to another port so that I can use both IPv6 and IPv4?
 
Lex1020
just joined
Posts: 18
Joined: Sat Apr 01, 2017 4:07 pm

Re: RE: Re: Help getting to Internet over IPv6

Sat Apr 22, 2017 2:28 pm

Mikrotik does not support IPv6 NAT
you have just one single IP (/128)
Ask ur ISP for IPv6 PD (/48-/60)
Its my understanding that IPv6 by design doesn't NAT.

Sent from my LG-H872 using Tapatalk
 
User avatar
null31
Member Candidate
Member Candidate
Posts: 177
Joined: Fri Dec 23, 2016 6:07 pm
Location: Brazil

Re: Help getting to Internet over IPv6

Wed Apr 26, 2017 5:35 am

Did you tried to configure DHCPv6-Client?

Also your ISP need to delegate an prefix to you.

Who is online

Users browsing this forum: MSN [Bot] and 27 guests