Community discussions

 
dcjcalisin
just joined
Topic Author
Posts: 8
Joined: Mon Apr 24, 2017 3:03 am

just a guy with mikrotik haplite

Mon Apr 24, 2017 3:08 am

so i bought this haplite with config from a guy

its much better than the router provided by my isp.

5mbps speed now can handle games and streaming at the same time without lag.

now the only problem i have is that when a page is loading. the ping for the games of my brother goes up but once it loads fully its already stable. mainly cs go and dota 2.

another problem is that i dont have the login for my router too. he only adjust it via teamviewer.

can anyone help?

ss attached for you to see.
You do not have the required permissions to view the files attached to this post.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: just a guy with mikrotik haplite

Mon Apr 24, 2017 10:49 am

I think you already answered the question yourself:

1. you have a guy that makes this setup and has access
2. you have no access anyway
No answer to your question? How to write posts
 
flynno
Member Candidate
Member Candidate
Posts: 241
Joined: Wed Aug 27, 2014 8:11 pm

Re: just a guy with mikrotik haplite

Mon Apr 24, 2017 1:10 pm

You would want to get onto the "guy" and get login details for the router.
 
InoX
Forum Guru
Forum Guru
Posts: 1963
Joined: Tue Jan 09, 2007 6:44 pm

Re: just a guy with mikrotik haplite

Mon Apr 24, 2017 1:23 pm

It is normal for the ping to raise when you only have 5mbps internet...
 
User avatar
Steveocee
Forum Guru
Forum Guru
Posts: 1110
Joined: Tue Jul 21, 2015 10:09 pm
Location: UK
Contact:

Re: just a guy with mikrotik haplite

Mon Apr 24, 2017 4:30 pm

You need more bandwidth or to prioritise your stuff over your brothers although to do this you need access to your router.
Steve "Steveocee" Carter
PC Gamer, Airsofter, MikroTik Nerd
My Website - My MikroTik Tutorials
 
benblack
just joined
Posts: 1
Joined: Fri Jun 17, 2016 7:18 pm

Re: just a guy with mikrotik haplite

Mon Apr 24, 2017 11:45 pm

I think you'll get the same answers as you did over in r/Mikrotik. You'll still need access to the router to make any changes yourself. Or that guy needs to fix his queues. I really doubt they are setup correctly.
 
dcjcalisin
just joined
Topic Author
Posts: 8
Joined: Mon Apr 24, 2017 3:03 am

Re: just a guy with mikrotik haplite

Tue May 02, 2017 2:01 am

i was able to get a copy of the back up. if i post it would we be able to identify whats wrong or missing?
so i can apply the changes and format the device.
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: just a guy with mikrotik haplite

Tue May 02, 2017 3:01 pm

Do not post backup here. It is for nothing and you can disclose your passwords. Post export instead, if something...
 
dcjcalisin
just joined
Topic Author
Posts: 8
Joined: Mon Apr 24, 2017 3:03 am

Re: just a guy with mikrotik haplite

Mon May 08, 2017 3:21 am

/ip firewall layer7-protocol
add name=Stream regexp="^.+(youtube|dailymotion|metacafe|mccont).*\$"
add name=streaming regexp=videoplayback|video
add name=SocialMedia regexp="^.+(facebook.com|twitter|linkedin|pinterest|tumbl\
r|instagram|VK|flickr|vine|meetup|tagged|ask.fm|meetme|classm).*\$"
add name=layer7-bittorrent-exp regexp="^(\\x13bittorrent protocol|azver\\x01\$\
|get /scrape\\\?info_hash=get /announce\\\?info_hash=|get /client/bitcomet\
/|GET /data\\\?fid=)|d1:ad2:id20:|\\x08'7P\\)[RP]"
add name=block regexp="^.+(sex|scandal|xxx|porn).*\$"
add name=torrent-dns regexp="^.+(torrent|thepiratebay|isohunt|demonii|bittorre\
nt|entertane|demonoid|btjunkie|mininova|flixflux|torrentz|vertor|h33t|btsc\
ene|bitunity|bittoxic|thunderbytes|entertane|zoozle|vcdq|bitnova|bitsoup|m\
eganova|fulldls|btbot|flixflux|seedpeer|fenopy|gpirate|utorrent|commonbits\
).*\$"
add name=torrent-www regexp="^.*(get|GET).+(torrent|thepiratebay|isohunt|enter\
tane|demonoid|btjunkie|mininova|flixflux|torrentz|vertor|h33t|btscene|bitu\
nity|bittoxic|thunderbytes|entertane|zoozle|vcdq|bitnova|bitsoup|meganova|\
fulldls|btbot|flixflux|seedpeer|fenopy|gpirate|commonbits).*\$"
add name=torrentsites regexp="^.*(get|GET).+(torrent|thepiratebay|isohunt|ente\
rtane|demonoid|btjunkie|mininova|flixflux|torrentz|vertor|h33t|btscene|bit\
unity|bittoxic|thunderbytes|entertane|zoozle|vcdq|bitnova|bitsoup|eganova|\
fulldls|btbot|flixflux|seedpeer|fenopy|gpirate|commonbits).*\$"
add name=idm-7.1 regexp="get /.*(user-agent: mozilla/4.0|range: bytes=)"
/ip pool
add name=dhcp_pool1 ranges=192.168.88.2-192.168.88.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=lan name=dhcp1
/queue simple
add max-limit=1M/5M name="Parent Pipe (MainISP)" target=192.168.88.0/24
add max-limit=1M/5M name=vip/ip parent="Parent Pipe (MainISP)" priority=1/1 \
target=192.168.88.100/32
/queue type
add kind=pfifo name=online pfifo-limit=10
add kind=pfifo name=browsing pfifo-limit=10
add kind=pcq name="online up" pcq-classifier=src-address \
pcq-dst-address6-mask=64 pcq-limit=712000KiB pcq-src-address6-mask=64
add kind=pcq name="online down" pcq-classifier=dst-address \
pcq-dst-address6-mask=64 pcq-limit=3000000KiB pcq-src-address6-mask=64
add kind=pcq name="browsing up" pcq-classifier=src-address \
pcq-dst-address6-mask=64 pcq-limit=160000KiB pcq-src-address6-mask=64
add kind=pcq name="browsing down" pcq-classifier=dst-address \
pcq-dst-address6-mask=64 pcq-limit=3000000KiB pcq-src-address6-mask=64
/queue simple
add max-limit=712k/2500k name="Online Games" packet-marks=gpkt parent=\
"Parent Pipe (MainISP)" priority=1/1 queue="online up/online down" \
target=192.168.88.0/24
add max-limit=180k/2500k name=Browsing-Streaming-Download-FB parent=\
"Parent Pipe (MainISP)" priority=2/2 queue="browsing up/browsing down" \
target=192.168.88.0/24
add max-limit=180k/2M name=SocialMediaPipe packet-marks=smpkt parent=\
Browsing-Streaming-Download-FB priority=3/3 target=192.168.88.0/24
add max-limit=80k/1500k name=BrowsingPipe packet-marks=bpkt parent=\
Browsing-Streaming-Download-FB priority=4/4 target=192.168.88.0/24
add max-limit=120k/2M name=StreamsPipe packet-marks=spkt parent=\
Browsing-Streaming-Download-FB priority=5/5 target=192.168.88.0/24
add max-limit=90k/2M name=P2PDownloadPipe packet-marks=dpkt parent=\
Browsing-Streaming-Download-FB priority=6/6 target=192.168.88.0/24
add max-limit=100k/2M name=others packet-marks=opkt parent=\
Browsing-Streaming-Download-FB priority=7/7 target=192.168.88.0/24
/interface bridge port
add bridge=lan interface=ether2
add bridge=lan interface=ether4
add bridge=lan interface=wlan1
add bridge=lan interface=ether3
/ip address
add address=192.168.88.1/24 interface=lan network=192.168.88.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
interface=ether1
/ip dhcp-server network
add address=192.168.1.0/24 gateway=192.168.1.1
add address=192.168.88.0/24 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip firewall address-list
add address=92.51.156.78 comment=tcp list=csgo
add address=103.28.54.10 comment=udp list=csgo-udp
add address=103.10.124.102 list=csgo-udp
add address=119.81.179.147 list=csgo
add address=155.133.253.18 list=csgo-udp
/ip firewall mangle
add action=mark-connection chain=prerouting comment="ONLINE GAME PORTS" \
new-connection-mark=game-cm port=\
5340-5352,6000-6152,10001-10011,14009-14030,18901-18909 protocol=tcp
add action=mark-connection chain=prerouting new-connection-mark=game-cm port=\
39190,27780,29000,22100,10009,4300,15001,15002,7341,7451 protocol=tcp
add action=mark-connection chain=prerouting comment="ONLINE GAME PORTS" \
new-connection-mark=game-cm port=\
5340-5352,6000-6152,10001-10011,14009-14030,18901-18909 protocol=tcp
add action=mark-connection chain=prerouting new-connection-mark=game-cm port=\
39190,27780,29000,22100,10009,4300,15001,15002,7341,7451 protocol=tcp
add action=mark-connection chain=prerouting comment="ONLINE GAME PORTS" \
new-connection-mark=game-cm port=\
5340-5352,6000-6152,10001-10011,14009-14030,18901-18909 protocol=tcp
add action=mark-connection chain=prerouting new-connection-mark=game-cm port=\
39190,27780,29000,22100,10009,4300,15001,15002,7341,7451 protocol=tcp
add action=mark-connection chain=prerouting new-connection-mark=game-cm port=\
40000,9300,9400,9700,7342,8005-8010,37466,36567,8822 protocol=tcp
add action=mark-connection chain=prerouting new-connection-mark=game-cm port=\
47611,16666,20000,5105,29000,18901-18909,9015 protocol=tcp
add action=mark-connection chain=prerouting comment=sf_playpark_tcp \
new-connection-mark=game-cm port=\
49490,50045,50066,50068,50072,50079,50083,51723 protocol=tcp
add action=mark-connection chain=prerouting comment=sf_playpark \
new-connection-mark=game-cm port=50969,49159,58466,49471 protocol=udp
add action=mark-connection chain=prerouting comment="League Of Legends" \
new-connection-mark=game-cm port=8393-8400,2099,5222-5223 protocol=tcp
add action=mark-connection chain=prerouting comment="League Of Legends" \
new-connection-mark=game-cm port=20466,9100,21033 protocol=tcp
add action=mark-connection chain=prerouting comment="League Of Legends" \
new-connection-mark=game-cm port=20466,9100,21033 protocol=udp
add action=mark-connection chain=prerouting comment="League Of Legends" \
new-connection-mark=game-cm port=5000-5500 protocol=udp
add action=mark-connection chain=prerouting comment="Ragnarok Online" \
new-connection-mark=game-cm port=5000-5500 protocol=tcp
add action=mark-connection chain=prerouting comment=DOTA2 \
new-connection-mark=game-cm passthrough=no port=27015-28999 protocol=udp
add action=mark-connection chain=prerouting new-connection-mark=game-cm port=\
27005-27020,13055,7800-7900,12060-12070 protocol=udp
add action=mark-connection chain=prerouting new-connection-mark=game-cm port=\
8005-8010,9068,1293,1479,9401,9600,30000 protocol=udp
add action=mark-connection chain=prerouting new-connection-mark=game-cm port=\
14009-14030,42051-42052,40000-40050,13000-13080 protocol=udp
add action=mark-connection chain=prerouting comment="RAN Online" \
new-connection-mark=game-cm port=5001,5502,5105 protocol=tcp
add action=mark-connection chain=prerouting comment="RAN Online" \
new-connection-mark=game-cm port=5001,5502,5105 protocol=udp
add action=mark-connection chain=prerouting comment=I-Date \
new-connection-mark=game-cm port=8132 protocol=tcp
add action=mark-connection chain=prerouting comment=I-Date \
new-connection-mark=game-cm port=8132 protocol=udp
add action=mark-connection chain=prerouting comment=CrossFire \
new-connection-mark=game-cm port=16666,9110,13006,10008 protocol=tcp
add action=mark-connection chain=prerouting comment=CrossFire \
new-connection-mark=game-cm port=16666,9110,13006,10008 protocol=udp
add action=mark-connection chain=prerouting comment="Dragon Nest" \
new-connection-mark=game-cm port=14300,14301,7000,14500 protocol=tcp
add action=mark-connection chain=prerouting comment="Cabal Online" \
new-connection-mark=game-cm port=38111-38125 protocol=tcp
add action=mark-connection chain=prerouting comment="Cabal Online" \
new-connection-mark=game-cm port=6800-6899 protocol=udp
add action=mark-connection chain=prerouting comment=GARENA \
new-connection-mark=game-cm port=7456-7459,7456-7459,6112-6119,999 \
protocol=tcp
add action=mark-connection chain=prerouting comment=GARENA \
new-connection-mark=game-cm port=1512-1515,6112-6119,4000-4200 protocol=\
udp
add action=mark-connection chain=prerouting comment="Soldier Front" \
new-connection-mark=game-cm port=22001-22999 protocol=udp
add action=mark-connection chain=prerouting comment="Soldier Front" \
new-connection-mark=game-cm port=27230-27235 protocol=tcp
add action=mark-connection chain=prerouting comment="Audition TCP" \
new-connection-mark=game-cm port=18805-18811,62050,65041 protocol=tcp
add action=mark-connection chain=prerouting comment="HON UDP" \
new-connection-mark=game-cm port=11235-11335,11031 protocol=udp
add action=mark-connection chain=prerouting comment="HON TCP" \
new-connection-mark=game-cm port=11235-11335,11031 protocol=tcp
add action=mark-connection chain=prerouting comment="Audition UDP" \
new-connection-mark=game-cm port=18805-18811,62050,65041 protocol=udp
add action=mark-connection chain=prerouting comment="Assault Fire" \
new-connection-mark=game-cm port=\
28526,9030,8000,65000,28540,7552,7515,7631,7586 protocol=udp
add action=mark-connection chain=prerouting comment="CLASH OF ROYALE" \
new-connection-mark=game-cm port=51660 protocol=tcp
add action=mark-connection chain=prerouting comment="MU TITAN" \
new-connection-mark=game-cm port=49556 protocol=tcp
add action=mark-connection chain=prerouting comment=MU-TITAN-1 \
new-connection-mark=game-cm port=\
49161,49275,49283,49579,49584,49589,49592,49594,49595 protocol=tcp
add action=mark-connection chain=prerouting comment="CLASH OF CLAN" \
new-connection-mark=game-cm port=9339 protocol=tcp
add action=mark-connection chain=prerouting comment="CLASH OF CLAN" \
new-connection-mark=game-cm port=9339 protocol=udp
add action=mark-connection chain=prerouting comment="mobile legends tcp" \
new-connection-mark=game-cm port=34242,41741,49354 protocol=tcp
add action=mark-connection chain=prerouting comment="mobile legends udp" \
dst-port=57538 new-connection-mark=game-cm protocol=udp
add action=mark-packet chain=prerouting connection-mark=game-cm \
new-packet-mark=gpkt passthrough=no
add action=mark-connection chain=prerouting comment=STREAM layer7-protocol=\
Stream new-connection-mark=Stream-cm
add action=mark-connection chain=prerouting comment=STREAMING \
layer7-protocol=streaming new-connection-mark=Stream-cm
add action=mark-packet chain=prerouting comment=STREAMING connection-mark=\
Stream-cm new-packet-mark=spkt passthrough=no
add action=mark-connection chain=prerouting comment=SocialMedia \
layer7-protocol=SocialMedia new-connection-mark=sm-cm
add action=mark-packet chain=prerouting comment=SocialMedia connection-mark=\
sm-cm new-packet-mark=smpkt passthrough=no
add action=mark-connection chain=prerouting comment="torent dns" \
layer7-protocol=torrent-dns new-connection-mark=download-cm
add action=mark-connection chain=prerouting comment="torrent www" \
layer7-protocol=torrent-www new-connection-mark=download-cm
add action=mark-connection chain=prerouting comment="torrent sites" \
layer7-protocol=torrentsites new-connection-mark=download-cm
add action=mark-connection chain=prerouting comment=DOWNLOAD-P2P \
new-connection-mark=download-cm p2p=all-p2p
add action=mark-connection chain=prerouting comment=DownloadTorrent dst-port=\
!0-1024,8291,5900,5800,3389,14147,5222,59905 layer7-protocol=\
layer7-bittorrent-exp new-connection-mark=download-cm protocol=tcp
add action=mark-connection chain=prerouting dst-port=\
!0-1024,8291,5900,5800,3389,14147,5222,59905 layer7-protocol=\
layer7-bittorrent-exp new-connection-mark=download-cm protocol=udp
add action=mark-packet chain=prerouting connection-mark=download-cm \
new-packet-mark=dpkt passthrough=no
add action=mark-connection chain=prerouting comment=BROWSING \
connection-bytes=0-1000000 new-connection-mark=browsing-cm port=443,80 \
protocol=tcp
add action=mark-packet chain=prerouting connection-mark=browsing-cm \
new-packet-mark=bpkt passthrough=no
add action=mark-connection chain=prerouting comment=OTHERS connection-mark=\
no-mark new-connection-mark=others-cm
add action=mark-packet chain=prerouting connection-mark=others-cm \
new-packet-mark=opkt passthrough=no

is there anything wrong with this? missing or i should remove?
 
User avatar
null31
Member Candidate
Member Candidate
Posts: 177
Joined: Fri Dec 23, 2016 6:07 pm
Location: Brazil

Re: just a guy with mikrotik haplite

Mon May 08, 2017 8:52 am

You have too much Mangle rules, when occurs the browsing that rules is the last ones that have the match to mark. And of course because is a SoC low-end to process those firewall rules and the CPU usage will be high at the point to drop packets or delay them.
Also is better to use Queue Tree than the Queue Simple to do the priority in your case.

EDIT:
Summary: You need to optimize the Mangle rules and Queues to have a better performance.
 
dcjcalisin
just joined
Topic Author
Posts: 8
Joined: Mon Apr 24, 2017 3:03 am

Re: just a guy with mikrotik haplite

Thu May 11, 2017 3:31 am

You have too much Mangle rules, when occurs the browsing that rules is the last ones that have the match to mark. And of course because is a SoC low-end to process those firewall rules and the CPU usage will be high at the point to drop packets or delay them.
Also is better to use Queue Tree than the Queue Simple to do the priority in your case.

EDIT:
Summary: You need to optimize the Mangle rules and Queues to have a better performance.

by this you mean make two queues gaming and others
then under others make queue about social media youtube stream downloads and what not?
by too much mangles how do i know which ones to delete?

thank you sir
 
User avatar
null31
Member Candidate
Member Candidate
Posts: 177
Joined: Fri Dec 23, 2016 6:07 pm
Location: Brazil

Re: just a guy with mikrotik haplite

Thu May 11, 2017 4:26 am

Seven months ago I have used those two methods, both works but with no fasttrack rule.

http://metalspawn-mikrotik.blogspot.com ... ce-go.html
-For queue tree, I made my own rules
-This works with Valve games

https://r1ch.net/blog/routerboard
-This is better for you
-Filter all packets, the that ones aren't marked, got the worst priority (p2p traffic that isn't in 80 and 443 ports)
-You can ignore the streaming rules
by this you mean make two queues gaming and others
then under others make queue about social media youtube stream downloads and what not?
by too much mangles how do i know which ones to delete?
Also is better doing this with all mangle and queue rules removed.
 
dcjcalisin
just joined
Topic Author
Posts: 8
Joined: Mon Apr 24, 2017 3:03 am

Re: just a guy with mikrotik haplite

Fri May 12, 2017 12:59 am

thank you for that. ive seen both blogs you mentioned. would you think it would still work even if its 2015 and 2013 post? thank you sir
 
User avatar
null31
Member Candidate
Member Candidate
Posts: 177
Joined: Fri Dec 23, 2016 6:07 pm
Location: Brazil

Re: just a guy with mikrotik haplite

Fri May 12, 2017 1:17 am

thank you for that. ive seen both blogs you mentioned. would you think it would still work even if its 2015 and 2013 post? thank you sir
It'll works with no problems, since I used them in october of 2016 with RouterOS v6.37.
I not use more because I need the fasttrack rule and I solved the upload problem with my family (simple queue that limit up, but one rule using an /29). :)
Last edited by null31 on Fri May 12, 2017 1:20 am, edited 1 time in total.
 
dcjcalisin
just joined
Topic Author
Posts: 8
Joined: Mon Apr 24, 2017 3:03 am

Re: just a guy with mikrotik haplite

Fri May 12, 2017 1:19 am

thanks ill try to use https://r1ch.net/blog/routerboard

ill post again for updates.

thank you for all the help
 
dcjcalisin
just joined
Topic Author
Posts: 8
Joined: Mon Apr 24, 2017 3:03 am

Re: just a guy with mikrotik haplite

Tue May 16, 2017 9:04 am

question guys

should i put a value on the limit at part for target upload and download?
You do not have the required permissions to view the files attached to this post.
 
User avatar
null31
Member Candidate
Member Candidate
Posts: 177
Joined: Fri Dec 23, 2016 6:07 pm
Location: Brazil

Re: just a guy with mikrotik haplite

Tue May 16, 2017 9:14 am

question guys

should i put a value on the limit at part for target upload and download?
Yes.
Any value more than 10M for high priority (this is based on your connection speed).
 
dcjcalisin
just joined
Topic Author
Posts: 8
Joined: Mon Apr 24, 2017 3:03 am

Re: just a guy with mikrotik haplite

Wed May 17, 2017 2:20 am

so if my speed is 5mb download and .90 upload what should be the values there?
 
User avatar
null31
Member Candidate
Member Candidate
Posts: 177
Joined: Fri Dec 23, 2016 6:07 pm
Location: Brazil

Re: just a guy with mikrotik haplite

Wed May 17, 2017 5:48 am

so if my speed is 5mb download and .90 upload what should be the values there?
For priority 1 and 2, 10M in both fields.
For http and unmarked, at 60% of your speed should not be a problem to lag the games.

Also, I don't know how is your config now and the parameters from queue types and tree.
 
eann
just joined
Posts: 1
Joined: Tue Aug 07, 2018 5:08 pm

Re: just a guy with mikrotik haplite

Tue Aug 07, 2018 5:13 pm

hi do you have a script for prioritizing online game steam dota 2???
can i see??

Who is online

Users browsing this forum: No registered users and 56 guests