Community discussions

 
radnet
just joined
Topic Author
Posts: 6
Joined: Wed Apr 26, 2017 10:57 pm

Connection Mark (or Packet Mark) Not Work In Firewall/NAT

Wed Apr 26, 2017 11:32 pm

dear all

when user are going to send request to mail.abcde.com:80 , i want that user's request forward to mail.abcde.com:8080 directly.
in other word when domain is exactly 'mail.abcde.com' (not for other domain) this process to be happened.

i have done this issue in 3 step :

Step 1 : Create Layer7 Protocol :

# NAME REGEXP
0 mail.abcde.com ^.+(mail.abcde.com).*$

STEP 2 : Create a Mangle
chain=prerouting action=mark-connection new-connection-mark=MailServerConnection passthrough=no layer7-protocol=mail.abcde.com protocol=tcp log=no log-prefix=""

STEP 3 : Create NAT
chain=dstnat action=dst-nat to-addresses=192.168.100.100 to-ports=8080 protocol=tcp dst-address=MY_PUBLIC_IP connection-mark=MailServerConnection dst-port=80 log=no log-prefix=""

Mangle are receiving packets when user are going to send request to mail.abcde.com:80 but NAT not working !

any idea?
 
radnet
just joined
Topic Author
Posts: 6
Joined: Wed Apr 26, 2017 10:57 pm

Re: Connection Mark (or Packet Mark) Not Work In Firewall/NAT

Thu Apr 27, 2017 8:01 pm

any idea ????
 
Sob
Forum Guru
Forum Guru
Posts: 4780
Joined: Mon Apr 20, 2009 9:11 pm

Re: Connection Mark (or Packet Mark) Not Work In Firewall/NAT

Thu Apr 27, 2017 8:39 pm

It doesn't work like this. See e.g. this thread about similar problem.
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply.
 
radnet
just joined
Topic Author
Posts: 6
Joined: Wed Apr 26, 2017 10:57 pm

Re: Connection Mark (or Packet Mark) Not Work In Firewall/NAT

Fri Apr 28, 2017 4:12 pm

It doesn't work like this. See e.g. this thread about similar problem.
Thank you for your replay, so we don't have any solution for this in mikrotik OS :(
 
pe1chl
Forum Guru
Forum Guru
Posts: 5909
Joined: Mon Jun 08, 2015 12:09 pm

Re: Connection Mark (or Packet Mark) Not Work In Firewall/NAT

Fri Apr 28, 2017 5:25 pm

This is not a matter of "no solution in RouterOS", what you want to do is simply impossible in networking!
You are trying to redirect a connection setup based on things you find in a running connection.
That requires "crystal ball" functionality.
 
radnet
just joined
Topic Author
Posts: 6
Joined: Wed Apr 26, 2017 10:57 pm

Re: Connection Mark (or Packet Mark) Not Work In Firewall/NAT

Sat Apr 29, 2017 12:35 pm

This is not a matter of "no solution in RouterOS", what you want to do is simply impossible in networking!
You are trying to redirect a connection setup based on things you find in a running connection.
That requires "crystal ball" functionality.
Thank you pe1chl
 
User avatar
horhay
newbie
Posts: 28
Joined: Sat Jun 20, 2015 7:19 pm
Location: Ontario, Canada
Contact:

Re: Connection Mark (or Packet Mark) Not Work In Firewall/NAT

Sat May 27, 2017 5:45 pm

Unless all you were really looking for was this.

https://wiki.mikrotik.com/wiki/Sync_Add ... _A_Records
 
pe1chl
Forum Guru
Forum Guru
Posts: 5909
Joined: Mon Jun 08, 2015 12:09 pm

Re: Connection Mark (or Packet Mark) Not Work In Firewall/NAT

Sat May 27, 2017 6:49 pm

That is old and should probably be removed. Today, an address list can simply be set to a DNS name and it
will do what that script does. But, it is not at all related to the question asked in this topic...

Who is online

Users browsing this forum: No registered users and 21 guests