Community discussions

MUM Europe 2020
 
wfalcon
just joined
Topic Author
Posts: 24
Joined: Thu Mar 23, 2017 3:03 pm

Redirection, and Graphing [Solved]

Thu Jun 15, 2017 5:32 pm

Hello Mikrotik Community! this is my first post and i'm really hoping you guys can help me out with this issue.

i know i should use web proxy or accounting or traffic flow... but i'm pretty beginner so if some of you could post briefly instead of posting links to manuals because i've surfed them tons of times and i didnt understand. ( some may say "take network courses first, then come and ask"... well... no thanks... )


i have an RB951 upgraded to 6.39, running through another router ( tenda ) via a cable, and all users including me the admin are on the mikrotik's ap
i wanted to make a traffic flow but i found it complex to me as a beginner so i went with the graphing option under tools.. so i gave for each user the ability to access the default gateway 192.168.88.1 and to check their graphs to let them see how much they have consumed based on daily / weekly and monthly analysis.
so what i did was, i made all of their IPs fixed using DHCP, and through arp list. i also created a simple queue with unlimited bandwidth for each user ( 21 queues ) and named them accordingly to their names. then i went to graphing and gave each name access to his relative IP only so no one can get to know the other's statistics. and it worked.. but now i have these issues

1 - graphing statistics is showing zero like always although i chose the option to refresh every 5mins
2- i want to redirect users from 192.168.88.1 to 192.168.88.1/graphs/ instantly so they wont have the right to see the root page in anyway.

here's my default firewall configurations i dont wanna mess up or delete anything because i dont understand the rules.
# jun/15/2017 17:27:54 by RouterOS 6.39.2
# software id = LJG6-T7CB
#
/ip firewall layer7-protocol
add name=streaming regexp=videoplayback|video
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept establieshed,related" \
connection-state=established,related
add action=drop chain=input comment=\
"defconf: drop all from WAN" in-interface=ether1
add action=fasttrack-connection chain=forward comment=\
"defconf: fasttrack" connection-state=\
established,related
add action=accept chain=forward comment=\
"defconf: accept established,related" \
connection-state=established,related
add action=drop chain=forward comment=\
"defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" \
connection-nat-state=!dstnat connection-state=new \
in-interface=ether1
/ip firewall mangle
add action=mark-packet chain=prerouting comment=\
"Mark Packet Streaming" layer7-protocol=streaming \
new-packet-mark=streaming passthrough=no
/ip firewall nat
add action=masquerade chain=srcnat comment=\
"defconf: masquerade" out-interface=ether1



the streaming is used to limit the video usage and its working


i really appreciate your help and thanks in advance.
Last edited by wfalcon on Fri Jun 16, 2017 3:21 pm, edited 1 time in total.
 
wfalcon
just joined
Topic Author
Posts: 24
Joined: Thu Mar 23, 2017 3:03 pm

Re: Redirection, and Graphing

Fri Jun 16, 2017 3:21 pm

i solved the graphing thing. all you have to do is not to set the limits to unlimited.
and concerning the redirect thingy nevermind about it i can go with it.
thanks
 
demonspade
just joined
Posts: 1
Joined: Thu Jul 20, 2017 2:43 am

Re: Redirection, and Graphing [Solved]

Thu Jul 20, 2017 2:49 am

thanks!! sir

Who is online

Users browsing this forum: IPANetEngineer and 25 guests