Community discussions

 
lp13
just joined
Topic Author
Posts: 21
Joined: Thu Jul 27, 2017 10:31 am

Downgrade

Mon Jul 31, 2017 2:02 pm

Hay all.

I try to downgrade firmware. Procedure looks very simple but i'm unseccessful in it.

My device:

/system resource> print
uptime: 3d10m52s
version: 6.40 (stable)
build-time: Jul/21/2017 08:45:31
factory-software: 6.35.4
free-memory: 41.4MiB
total-memory: 64.0MiB
cpu: MIPS 24Kc V7.4
cpu-count: 1
cpu-frequency: 650MHz
cpu-load: 2%
free-hdd-space: 5.0MiB
total-hdd-space: 16.0MiB
write-sect-since-reboot: 102289
write-sect-total: 103681
bad-blocks: 0%
architecture-name: mipsbe
board-name: hEX PoE lite
platform: MikroTik

As you can see my current version is 6.40.
I want to downgrade it to 6.29.1

Step-by-step
1) From official website I downloaded "routeros-mipsbe-6.29.1.npk
2) Using winbox i copy this file to /file>
3) Go to /system package downgrade
4) Reboot device
5) Version doesn't change. Stil 6.40

What I do wrong? Any ideas?
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: Downgrade

Mon Jul 31, 2017 2:09 pm

You can see that minimal supported RouterOS version is "factory-software: 6.35.4". You can not downgrade router below this version.
 
irghost
Member Candidate
Member Candidate
Posts: 281
Joined: Sun Feb 21, 2016 1:49 pm

Re: Downgrade

Mon Jul 31, 2017 2:25 pm

You can see that minimal supported RouterOS version is "factory-software: 6.35.4". You can not downgrade router below this version.
even with netinstall?
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
lp13
just joined
Topic Author
Posts: 21
Joined: Thu Jul 27, 2017 10:31 am

Re: Downgrade

Mon Jul 31, 2017 2:26 pm

I don't have any ways to downgrade it, do I?
I found out that certificate scep client doesn't work with other vendor CAs in new versions (after 6.3).
Now I'm in situation when it's impossible to get certificate in 6.40 and at the same time with no possibility to downgrade to working version.
What I can do? Perhaps I need wait new version of software?
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: Downgrade

Mon Jul 31, 2017 2:28 pm

Yes, of course. Device can not be downgraded to older version than factory version since it would not work 100% reliably (for example, no drivers for memory installed, etc.).

If there is some software level issue which requires downgrade in order to work as suspected, then please contact support@mikrotik.com and report the problem. We will try to fix the issue if there will be any so you could use latest version.

Who is online

Users browsing this forum: No registered users and 26 guests