Community discussions

MikroTik App
 
ofis
just joined
Topic Author
Posts: 6
Joined: Fri Sep 29, 2017 1:34 pm

Guide for connection mikrotik router with dsl isp modem/router

Fri Sep 29, 2017 1:45 pm

Hi I have the mikrotik router rb951g-2hnd .I have trouble connecting it to the modem/router provided by my isp, and use the latter as just a modem. I can’t have an internet connection. I have followed a few generic guides, put the isp router in bridge mode, turned off dhcp server nat, etc, but it doesn’t work. Is there a more detailed, brand specific, but basic level guide, of how to achieve connection between the microtik router and the modem? thank you
 
User avatar
pcunite
Forum Guru
Forum Guru
Posts: 1080
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: Guide for connection mikrotik router with dsl isp modem/router

Fri Sep 29, 2017 7:44 pm

Can you draw a diagram of what your wanting, along with services and IP schemes?

A text example:
ISP Modem (public IP) - > MikroTik on ether1 (client dhcp set to grab public IP from ISP) - > ether2-ether10 will be bridge switch offering DHCP to my lan. Etc. you get the idea.
 
ofis
just joined
Topic Author
Posts: 6
Joined: Fri Sep 29, 2017 1:34 pm

Re: Guide for connection mikrotik router with dsl isp modem/router

Fri Sep 29, 2017 11:08 pm

isp adsl modem/router(set as i have read in generic guides in bridge mode, dhcp server NAT firewall off, IP dynamic by ISP)->lan cable in mikrotik lan ports,( have tried all of them) -> lan to PC for configuration, wifi on. In normal circumstances all devices are connected through wifi, I have to use a 15 meters cable to connect to the router and modem in serial to make the changes. Now only the modem is on in normal mode because otherwise I wouldn’t had internet. Is there a basic guide provided by Mikrotik of how to connect the routers with modem?
 
User avatar
pcunite
Forum Guru
Forum Guru
Posts: 1080
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: Guide for connection mikrotik router with dsl isp modem/router

Fri Sep 29, 2017 11:42 pm

Is there a basic guide provided by Mikrotik of how to connect the routers with modem?
I'm not sure if there is one. Here is what you'll need to do.

Plug the ISP modem into ether1 on the MikroTik. This will become your WAN port. The other ports will become switch ports called bridge-LAN.

Below is a sample config for you. Plug a laptop/PC into ether2. Then negotiate a connection to the MikroTik with Winbox using a MAC address. Go to System / Reset Configuration. Check No Default and Do Not Backup. Reboot. Then slowly copy paste each section of this script into a terminal window. If you get disconnected, just connect back again.
# Configure ports
/interface ethernet
set [ find default-name=ether1 ] master-port=none
set [ find default-name=ether2 ] master-port=none
set [ find default-name=ether3 ] master-port=ether2
set [ find default-name=ether4 ] master-port=ether2
set [ find default-name=ether5 ] master-port=ether2


# Create and setup bridge
/interface bridge
add name=bridge-LAN protocol-mode=none
/interface bridge port
add bridge=bridge-LAN interface=ether2
add bridge=bridge-LAN interface=wlan1
/interface bridge settings
set use-ip-firewall=yes


# Give bridge an IP
/ip address
add interface=bridge-LAN address=192.168.88.1/24


# Get an IP from ISP
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=ether1


# Setup Wireless
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no distance=indoors wps-mode=disabled frequency=auto mode=ap-bridge ssid="MYSSID"
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk group-key-update=60m mode=dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key="PASSWORD"


# Setup DHCP for LAN
/ip pool
add name=dhcp_pool1 ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add add-arp=yes address-pool=dhcp_pool1 always-broadcast=yes authoritative=yes disabled=no interface=bridge-LAN lease-time=1d name=dhcp1
/ip dhcp-server network
add address=192.168.88.0/24 dns-server=192.168.88.1 domain=home.local gateway=192.168.88.1


# Setup DNS for LAN
/ip dns
set allow-remote-requests=yes cache-max-ttl=5d


# Setup WAN port
/ip firewall nat
add action=masquerade chain=srcnat comment="Default masq" out-interface=ether1


# Setup WAN firewall
/ip firewall filter
add action=accept chain=input comment="Accept established related" connection-state=established,related
add action=accept chain=input comment="Allow LAN access to router and Internet" in-interface=bridge-LAN
add action=accept chain=input comment="Allow ping ICMP from anywhere" protocol=icmp
add action=drop chain=input comment="Drop all other input"
add action=accept chain=forward comment="Accept established related" connection-state=established,related
add action=accept chain=forward comment="Allow LAN access to router and Internet" connection-state=new in-interface=bridge-LAN
add action=accept chain=forward comment="Accept Port forwards" connection-nat-state=dstnat in-interface=ether1
add action=drop chain=forward comment="Drop all other forward"


# Turn off unneeded helpers
/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set irc disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
set udplite disabled=yes
set dccp disabled=yes
set sctp disabled=yes


# Turn off unneeded services
/ip service
set telnet disabled=yes
set ftp disabled=yes
set api disabled=yes
set ssh address=192.168.88.0/24
set winbox address=192.168.88.0/24
set api-ssl disabled=yes


# Misc IP settings
/ip ssh
set strong-crypto=yes
/ip settings
set rp-filter=strict secure-redirects=no send-redirects=no tcp-syncookies=yes
 
ofis
just joined
Topic Author
Posts: 6
Joined: Fri Sep 29, 2017 1:34 pm

Re: Guide for connection mikrotik router with dsl isp modem/router

Sat Sep 30, 2017 4:39 pm

thank you I will try it. Should i paste all of it at once,?
 
Paternot
Long time Member
Long time Member
Posts: 645
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: Guide for connection mikrotik router with dsl isp modem/router

Sat Sep 30, 2017 5:25 pm

What kind of modem you ISP gave you? Is is xDSL? Don't You have to configure ppp/pppoe user/password?

If this isn't a DSL/cable modem, why not get rid of it, and use just the mikrotik?

*EDIT*

Just saw the "dsl" part. Well, did You set up user/password? With the modem bridged, the router will have to do the authentication part.
 
User avatar
pcunite
Forum Guru
Forum Guru
Posts: 1080
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: Guide for connection mikrotik router with dsl isp modem/router

Sun Oct 01, 2017 12:28 am

thank you I will try it. Should i paste all of it at once,?
Generally, the parts with /interface ethernet will kick you off. So, I would get through that, then you can reconnect and try pasting it all. Better to go a couple of sections at a time and check for errors.
 
ofis
just joined
Topic Author
Posts: 6
Joined: Fri Sep 29, 2017 1:34 pm

Re: Guide for connection mikrotik router with dsl isp modem/router

Sun Oct 01, 2017 9:29 pm

Tried again with graphic ui, Winbox, until now no skript. Reset router and make the topology again, it connects with pppoe to the isp and gets external ip. Pinged 8.8.8.8 Google OK. Web connectivity is not working. Windows 7 diagnostics showed the dns server problem. I go to Winbox ip-dns it is empty. Alow remote requests is ticked. Googled for the problem, couldn't find something.

Android phone has web connectivity, I am posting through this.
 
ofis
just joined
Topic Author
Posts: 6
Joined: Fri Sep 29, 2017 1:34 pm

Re: Guide for connection mikrotik router with dsl isp modem/router

Sun Oct 01, 2017 9:43 pm

i manually added 8.8.8.8 to dns servers box to test it.
Now I have web connectivity to the PC but canot even connect with wifi to the android phone!!! I am completely baffled . How can the router get automaticaly the isp DNS servers?
 
ofis
just joined
Topic Author
Posts: 6
Joined: Fri Sep 29, 2017 1:34 pm

Re: Guide for connection mikrotik router with dsl isp modem/router

Sun Oct 01, 2017 10:18 pm

since i got temporary web connectivity i cliked check for updates, I updated, reset configuration, and run gui quick setup again and it magically got automatically DNS servers. of my ISP Everything seams to work fine. Is deafult security configuration, firewall, etc OK for general use? Thanks everyone for helping
 
mikrotikuser143
just joined
Posts: 1
Joined: Sun Feb 10, 2019 5:23 am

Re: Guide for connection mikrotik router with dsl isp modem/router

Sun Feb 10, 2019 5:34 am

Hello PCUNITE,

Good Day..
I have questions about my newly purchased mikrotik RB750. I have currently 2 ISP_DSL wired connections (i disabled all wifis on them) which i need to connect to my new mikrotik router. What are prerequisite settings (if there are) on my ISP_DSL modems before configuring my mikrotik?
 
pedroSwan
just joined
Posts: 18
Joined: Fri Jun 28, 2019 11:01 pm

Re: Guide for connection mikrotik router with dsl isp modem/router

Fri Jun 28, 2019 11:12 pm

Is there a basic guide provided by Mikrotik of how to connect the routers with modem?
I'm not sure if there is one. Here is what you'll need to do.

Plug the ISP modem into ether1 on the MikroTik. This will become your WAN port. The other ports will become switch ports called bridge-LAN.

Below is a sample config for you. Plug a laptop/PC into ether2. Then negotiate a connection to the MikroTik with Winbox using a MAC address. Go to System / Reset Configuration. Check No Default and Do Not Backup. Reboot. Then slowly copy paste each section of this script into a terminal window. If you get disconnected, just connect back again.
# Configure ports
/interface ethernet
set [ find default-name=ether1 ] master-port=none
set [ find default-name=ether2 ] master-port=none
set [ find default-name=ether3 ] master-port=ether2
set [ find default-name=ether4 ] master-port=ether2
set [ find default-name=ether5 ] master-port=ether2

Yes, I'm dragging up an old post but there isn't much out which answers these questions.

I'm in the process of putting my ISP router into Bridge Mode and then using my RB2011UiAS-RM as a router for the home network.

When I stumbled across your post I thought I was on a winner but I'm guessing commands have changed significantly in the last two years since you made the post first time around.

When I add the about line by line I get no further than the first line then an error
expected end of command (line 1 column 34
Is the original code tweakable for the latest firmware?

Thanks guys!
MikroTik RB2011UiAS-RM
Firmware Type: ar9344
Current Firmware: 6.45.6
------
MikroTik RB2011UiAS-2HnD-IN
Current Firmware: 6.45.6

Who is online

Users browsing this forum: atatakobry, JPMARTINS, mikroru and 58 guests