Community discussions

MUM Europe 2020
 
MikroTikFan
Member Candidate
Member Candidate
Topic Author
Posts: 200
Joined: Sat Aug 02, 2014 1:13 am

DHCP problem in access point virtual wireless interface

Sun Jan 14, 2018 10:10 pm

My problem is to get from DHCP address in virtual wireless interface.
I have Mikrotik wAP AC access point in mode: WISP AP
Main DHCP server is router Mikrotik RB3011

From main wireless interfaces i-wifi1 and i-wifi2 I'm getting addresses and DHCP is working fine.
From v-wifi (virtual interface) I can't get address and probably something wrong is with DHCP.
Please help me to find how to fix this problem.

Current configuration:
name="i-wifi1" mtu=1500 l2mtu=1600 mac-address=64:XX:XX:XX:XX:85 
      arp=enabled interface-type=Atheros AR9300 mode=station ssid="wifi1" 
      frequency=2462 band=2ghz-b/g/n channel-width=20mhz secondary-channel="" 
      scan-list=default wireless-protocol=802.11 vlan-mode=no-tag vlan-id=1 
      wds-mode=disabled wds-default-bridge=none wds-ignore-ssid=no 
      bridge-mode=enabled default-authentication=yes default-forwarding=yes 
      default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=no 
      security-profile=secure compression=no 

 1  R name="i-wifi2" mtu=1500 l2mtu=1600 mac-address=64:XX:XX:XX:XX:84 
      arp=enabled interface-type=Atheros AR9888 mode=ap-bridge ssid="wifi2" 
      frequency=auto band=5ghz-a/n/ac channel-width=20/40/80mhz-eeeC 
      secondary-channel="" scan-list=default wireless-protocol=802.11 
      vlan-mode=no-tag vlan-id=1 wds-mode=disabled wds-default-bridge=none 
      wds-ignore-ssid=no bridge-mode=enabled default-authentication=yes 
      default-forwarding=yes default-ap-tx-limit=0 default-client-tx-limit=0 
      hide-ssid=no security-profile=default compression=no 

 2    name="v-wifi1" mtu=1500 l2mtu=1600 mac-address=66:XX:XX:XX:XX:85 
      arp=enabled interface-type=virtual master-interface=i-wifi1 
      mode=ap-bridge ssid="virt1" vlan-mode=no-tag vlan-id=1 wds-mode=disabled 
      wds-default-bridge=none wds-ignore-ssid=no bridge-mode=enabled 

Who is online

Users browsing this forum: dt1510, gfucka, Znevna and 36 guests