Community discussions

MUM Europe 2020
 
kapi2454
just joined
Topic Author
Posts: 8
Joined: Mon Oct 09, 2017 2:54 pm

DVR Forwarding

Tue Feb 20, 2018 5:30 pm

Hi people, I new in this world (not in linux).

I bought 2 RB951G-2HnD Router to test it. I update the 2 devices. All work fine, I configure de PPPoE conections. etc

Buen I Try to forward wan to lan with out success.
The old Router (tp-link) work fine, the mobile app work fine to that means that I have a problem in the Mikrotik configuration.

I use this rule
/ip firewall nat add chain=dstnat dst-port=1234 action=dst-nat protocol=tcp to-address=192.168.1.253 to-port=1234

Then I try this other rule https://www.youtube.com/watch?v=VXodO1-Bq_c

I can not conect from outside of my house.

I put the old router and all work fine againg, what i doing wrong?
I reset the 2 router to test and the problems is the same :(
Thank you!!
 
Sob
Forum Guru
Forum Guru
Posts: 4863
Joined: Mon Apr 20, 2009 9:11 pm

Re: DVR Forwarding

Wed Feb 21, 2018 1:42 am

There's nothing clearly wrong with your rule (in breaking way). But there may be other reasons, e.g. packets can be stopped by filter in forward chain. So you'll need to share a little more info about your config.
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply.
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 945
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: DVR Forwarding

Wed Feb 21, 2018 1:56 am

When I try to forward wan to lan with out success ... I can not connect from outside of my house.
How are you verifying this? Are you trying to connect from inside your LAN to your external IP and trying to come back in that way?
 
kapi2454
just joined
Topic Author
Posts: 8
Joined: Mon Oct 09, 2017 2:54 pm

Re: DVR Forwarding

Wed Feb 21, 2018 2:08 am

To verifying that work I only test my mobile app.
In this app I have configured the IP direction (External or wan) mydvr.dyndns.org and the port 1234.
I try changing the port to other and put the wan IP and not the dyndns address.
for example: 196.68.56.48:4499 but it doen't work, whit this configuration I put the TP-link then I re configure the
Forwarding and work fine.

Is not another configuration in the router, only pppoe conection, and the DVR that doesn't work :(
The pppoe conection is fine because I can browser to this forum :)
 
User avatar
Steveocee
Forum Guru
Forum Guru
Posts: 1110
Joined: Tue Jul 21, 2015 10:09 pm
Location: UK
Contact:

Re: DVR Forwarding

Thu Feb 22, 2018 10:01 am

Try adding in an in-interface which is your PPPoE client to the forward rule. Currently it’s just grabbing all traffic and not looking at a particular direction, traffic is probably dropping at your firewall as it is not specified as NAT’d traffic.
Steve "Steveocee" Carter
PC Gamer, Airsofter, MikroTik Nerd
My Website - My MikroTik Tutorials
 
BigTrumpet
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Thu Feb 07, 2008 7:46 pm

Re: DVR Forwarding

Thu Feb 22, 2018 4:13 pm

kapi,
of course on the DVR network you have the gateway IP pointing to the Mikrotik, right?
 
zakynthoswifi
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Thu Jul 17, 2014 12:38 am
Location: Zakynthos
Contact:

Re: DVR Forwarding

Tue Mar 06, 2018 8:05 pm

Hello,
By default MikroTik has Firewall enabled that block's all traffic initiated from wan side except dst-natted rules. Please try this port forward rule:
/ip firewall nat
add action=dst-nat chain=dstnat comment=port forward dst-port=8888 in-interface=WAN1 protocol=tcp to-addresses=10.155.15.2 to-ports=8888

WAN1 is my wan interface. Please change it according to your setup
Ilias Theodosis
Network & Security Engineer
Cisco CCNA,CCNP,CCIE
Network Solutions Ltd.
Zakynthos, Greece
 
solar77
Member
Member
Posts: 437
Joined: Thu Feb 04, 2016 11:42 am
Location: Scotland

Re: DVR Forwarding

Wed Mar 07, 2018 1:19 pm

can you ping your wan IP from the Internet?
enable filter rule that accept ICMP on the input chain first.
MTCNA MTCTCE UEWA
 
kapi2454
just joined
Topic Author
Posts: 8
Joined: Mon Oct 09, 2017 2:54 pm

Re: DVR Forwarding

Wed Mar 07, 2018 2:03 pm

Hello,
By default MikroTik has Firewall enabled that block's all traffic initiated from wan side except dst-natted rules. Please try this port forward rule:
/ip firewall nat
add action=dst-nat chain=dstnat comment=port forward dst-port=8888 in-interface=WAN1 protocol=tcp to-addresses=10.155.15.2 to-ports=8888

WAN1 is my wan interface. Please change it according to your setup
I Will try this in the night, yesterday I move a server in the nigh :( I very very tired.
can you ping your wan IP from the Internet?
enable filter rule that accept ICMP on the input chain first.
I don try this, I test this too in the night
The external WAN IP is right, I look it searching in the router config and late in whatismyip.com
kapi,
of course on the DVR network you have the gateway IP pointing to the Mikrotik, right?
Yep, The DVR that is a PC is pointing to the gateway. (IP, DG and DNS)
I Configure the TP-Link same as the Mikrotik. If I put the tplink all work fine, if I put the Mikrotik the DVR can surf and the cameras only work in local mode, not from outside.


Thank for the help!! I need to configure all this device to start workin in some bussisnes . Than for helping me
 
erfanurmia
newbie
Posts: 28
Joined: Wed Mar 07, 2018 11:14 am
Contact:

Re: DVR Forwarding

Wed Mar 07, 2018 3:03 pm

hi
if you wanna watch the camera from internet
your configuration steps :
chain:dst-nat
dst-address:public-ip
dst-port=80
action: dst-nat
to address:dvr-ip
to port : dvr-port
 
zakynthoswifi
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Thu Jul 17, 2014 12:38 am
Location: Zakynthos
Contact:

Re: DVR Forwarding

Wed Mar 07, 2018 4:17 pm

can you write how your MT has internet? pppoe,dhcp,static ip?
Ilias Theodosis
Network & Security Engineer
Cisco CCNA,CCNP,CCIE
Network Solutions Ltd.
Zakynthos, Greece
 
kapi2454
just joined
Topic Author
Posts: 8
Joined: Mon Oct 09, 2017 2:54 pm

Re: DVR Forwarding

Wed Mar 07, 2018 4:52 pm

can you write how your MT has internet? pppoe,dhcp,static ip?
very important.
pppoe, dynamic ip. Generally I use a dyndns addres. or in the mikrotik case I use the cloud address.
When that does't work I try to configure in the app the IP and note the addres.
It's doesn.t work too
 
arnoldmikro
newbie
Posts: 25
Joined: Sun Apr 14, 2013 5:12 pm
Location: miami fl usa

Re: DVR Forwarding

Wed Mar 07, 2018 4:54 pm

my dvr rules

/ip firewall filter
add action=accept chain=forward dst-address=192.168.2.163 dst-port=37777 \
in-interface=ether1-gateway protocol=tcp
/ip firewall nat
add action=dst-nat chain=dstnat dst-port=37777 in-interface=ether1-gateway \
protocol=tcp to-addresses=192.168.2.163 to-ports=37777
 
zakynthoswifi
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Thu Jul 17, 2014 12:38 am
Location: Zakynthos
Contact:

Re: DVR Forwarding

Thu Mar 08, 2018 1:05 am

Ok please use my code and change the WAN1 name with your pppoe client name e.g. pppoe-out1 .
It should work ...
Ilias Theodosis
Network & Security Engineer
Cisco CCNA,CCNP,CCIE
Network Solutions Ltd.
Zakynthos, Greece
 
solar77
Member
Member
Posts: 437
Joined: Thu Feb 04, 2016 11:42 am
Location: Scotland

Re: DVR Forwarding

Thu Mar 08, 2018 12:50 pm

the nat rule looks OK, make sure you have dst-address, if still not working, I'd suggest to try adding the port you need in /ip firewall service-port
MTCNA MTCTCE UEWA
 
kapi2454
just joined
Topic Author
Posts: 8
Joined: Mon Oct 09, 2017 2:54 pm

Re: DVR Forwarding

Mon Mar 19, 2018 8:53 pm

Well, it's working after a lot of works.
I use this rules but doesn't work.
/ip firewall filter add action=accept chain=forward dst-address=192.168.1.254 dst-port=3777 in-interface=ether1-gateway protocol=tcp 
/ip firewall nat add action=dst-nat chain=dstnat dst-port=81 in-interface=ether1-gateway \protocol=tcp to-addresses=192.168.1.254 to-ports=3777
I change this in the GUI interface.
interface=ether1 to interface=all ppp

Thats Work for me. I try to pppoe-out1 but does't work, only work with "all ppp"
The PPPOE is connect in the ether1

Who is online

Users browsing this forum: MSN [Bot] and 27 guests