Community discussions

MikroTik App
 
kingkross
just joined
Topic Author
Posts: 8
Joined: Sun Feb 18, 2018 5:19 am

How Can I connect to 1st dhcp server from other dhcp server.

Wed Feb 21, 2018 7:40 am

How Can I connect to 1st dhcp server from other dhcp server.

I want to connect my server in 1st dhcp server with machine in other dhcp server.

What can I do?
/ip pool
add name=10.0.0.0 ranges=10.0.0.99
add name=10.0.1.0 ranges=10.0.1.101-10.0.1.110
add name=10.0.2.0 ranges=10.0.2.101-10.0.2.120
add name=10.0.3.0 ranges=10.0.3.101-10.0.3.200
/ip dhcp-server
add add-arp=yes address-pool=10.0.0.0 always-broadcast=yes disabled=no interface=ether5 name=Server
add address-pool=10.0.1.0 disabled=no interface=wlan1 name=Kings
add address-pool=10.0.2.0 disabled=no interface=wlan2 name=Homes
add address-pool=10.0.3.0 disabled=no interface=wlan3 name=Lands
/ip address
add address=10.0.0.1/24 interface=ether5 network=10.0.0.0
add address=10.0.1.1/24 interface=wlan1 network=10.0.1.0
add address=10.0.2.1/24 interface=wlan2 network=10.0.2.0
add address=10.0.3.1/24 interface=wlan3 network=10.0.3.0
/ip dhcp-server network
add address=10.0.0.0/24 dns-server=8.8.8.8 gateway=10.0.0.1 netmask=32
add address=10.0.1.0/24 dns-server=8.8.8.8 gateway=10.0.1.1
add address=10.0.2.0/24 dns-server=8.8.8.8 gateway=10.0.2.1
add address=10.0.3.0/24 dns-server=8.8.8.8 gateway=10.0.3.1
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out1
add action=masquerade chain=srcnat out-interface=pppoe-out2
add action=dst-nat chain=dstnat dst-address-type=local dst-port=80 in-interface=pppoe-out2 protocol=tcp to-addresses=10.0.0.99 to-ports=8080
add action=dst-nat chain=dstnat dst-port=21 in-interface=pppoe-out2 protocol=tcp to-addresses=10.0.0.99 to-ports=21
add action=dst-nat chain=dstnat dst-port=3389 in-interface=pppoe-out2 protocol=tcp to-addresses=10.0.0.99 to-ports=3389
/ip route
add check-gateway=ping distance=1 gateway=pppoe-out1 routing-mark=TO-ROUTER1
add check-gateway=ping distance=1 gateway=pppoe-out2 routing-mark=TO-ROUTER2
add check-gateway=ping disabled=yes distance=1 gateway=pppoe-out1
add check-gateway=ping disabled=yes distance=2 gateway=pppoe-out2
 
User avatar
cdiedrich
Forum Veteran
Forum Veteran
Posts: 997
Joined: Thu Feb 13, 2014 2:03 pm
Location: Basel, Switzerland // Bremen, Germany
Contact:

Re: How Can I connect to 1st dhcp server from other dhcp server.

Wed Feb 21, 2018 12:33 pm

Have a look at DHCP relay.
But I'm not really sure if that is what you're looking for. Bear in mind that the machine getting an address from the DHCP-server relayed to will not be able to communicate on the machine interface which is in a different subnet unless you enable proxy-arp on that interface.

-Chris
 
kingkross
just joined
Topic Author
Posts: 8
Joined: Sun Feb 18, 2018 5:19 am

Re: How Can I connect to 1st dhcp server from other dhcp server.

Wed Feb 21, 2018 1:10 pm

Please describe me step by step.

I am beginner.

thanks.
 
User avatar
acruhl
Member
Member
Posts: 371
Joined: Fri Jul 03, 2015 7:22 pm

Re: How Can I connect to 1st dhcp server from other dhcp server.

Thu Feb 22, 2018 4:34 am

Diagram it please.

You don't really "connect" DHCP servers together, so I don't understand what you are asking.
 
kingkross
just joined
Topic Author
Posts: 8
Joined: Sun Feb 18, 2018 5:19 am

Re: How Can I connect to 1st dhcp server from other dhcp server.

Thu Feb 22, 2018 6:46 am

I want to use pc in 10.0.1.0/24 for connecting server at 10.0.0.99

thanks.
You do not have the required permissions to view the files attached to this post.
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 2098
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Krugersdorp (Home town of Brad Binder)
Contact:

Re: How Can I connect to 1st dhcp server from other dhcp server.

Thu Feb 22, 2018 2:09 pm

Very confused now, wtf does this have to do with DHCP
 
User avatar
acruhl
Member
Member
Posts: 371
Joined: Fri Jul 03, 2015 7:22 pm

Re: How Can I connect to 1st dhcp server from other dhcp server.

Thu Feb 22, 2018 7:10 pm

What you wrote in the diagram isn't really in English, maybe you should try in your native language and see if someone can answer.

Who is online

Users browsing this forum: jmszuch1, marsando, unhuzpt and 117 guests