Community discussions

MikroTik App
 
RamonetNet
just joined
Topic Author
Posts: 12
Joined: Thu Dec 21, 2017 6:50 pm

same IP on 2 interfaces ?

Thu Feb 22, 2018 2:26 am

Hi.
I read "Top 10 RouterOS configuration mistakes" on url = https://www.youtube.com/watch?v=BkZHRD6svQU
Number 10 is "never set same IP on different interfaces"

But here comes my configuration :
   .-------------------.------.
   |       RB 750      |      | 
   |  10.139.130.33    | eth1 | --- PC proxy      ip = 10.139.130.34
   |  192.168.1.247    | eth2 | --- GW to ADSL    ip = 192.168.1.254
   |                   | eth3 | -
   |                   | eth4 | --- Nano5 Antena  ip = 10.139.130.35
   |                   | eth5 | 
   |                   |      | 
   .-------------------.------.
The RB750 is the router between a WLAN, whose data comes from the Nano5 antena,
a PC that has a Squid Proxy,
and the ADSL where the authorized users can access.

So, I have one IP for eth1 (10.139.130.33)
another IP for eth2 (192.168.1.247)
and here comes the problem :

*** the antena is in the same network as the PC ***

What IP shall I assign to eth4 ?
 
User avatar
ochaconm
Trainer
Trainer
Posts: 28
Joined: Fri Feb 22, 2013 9:39 pm

Re: same IP on 2 interfaces ?  [SOLVED]

Thu Feb 22, 2018 3:46 am

If you want to keep the Nano5 Antena and the PC proxy in the same subnet you can bridge the ether1 and ether4 interfaces and just set an IP address to the bridge, then you will have something like a two port switch:
/interface bridge
add name=br1
/interface bridge port
add bridge=br1 interface=ether1
add bridge=br1 interface=ether4

/ip address add address=10.139.130.33 interface=br1
I hope this helps.
 
RamonetNet
just joined
Topic Author
Posts: 12
Joined: Thu Dec 21, 2017 6:50 pm

Re: same IP on 2 interfaces ?

Mon Mar 05, 2018 10:17 am

This is *** EXACTLY *** the pointer to the idea I was missing

Thanks a lot, a lot, a lot

Who is online

Users browsing this forum: No registered users and 31 guests