Community discussions

MUM Europe 2020
 
ilja
newbie
Topic Author
Posts: 49
Joined: Thu Feb 22, 2018 1:15 pm

Web server deployed within local network

Thu Feb 22, 2018 1:49 pm

Hey all.

I have recently got MiktoTik wAP for our work office and i love it! However, i need a little help setting it up.

What i need:
Raspberry Pi running local web server, which is accessible for all users, who connect to my wi-fi network, without need of hotspot authentication. I have a link "visit local web server" on my captive portal. So i need ppl to be able to click it and be redirected to web server. That web server should be accessible only from local network, no need to go global.

Before:
I had raspberry pi web server. With an old setup i would deploy that server on a static raspberry pi's IP and it would be accessible from every device which is connected to the same network.

New setup with MikroTik:
I have created hotspot(w Radius userman) on 10.0.0.1 address, added dhcp server 10.0.0.3-10.0.0.254. Allocated static IP for my raspberry pi(10.0.0.2), added Pi to IP binding list, so it would be able to connect to the network without authentication. This part works fine. But when I configure Raspberry Pi web server to run on it's IP (10.0.0.2) or try to ssh to my pi using "ssh 10.0.0.2" being connected to the same hotspot i am not getting anything. :/

My best guess is that there might be something i need to tweak in firewall to allow all incoming/outcoming traffic to my Pi.
I have read about NAT, but that does not seem to be what I am looking for.

Any help will be highly appreciated. At least maybe a hint which direction i should be looking at
 
ilja
newbie
Topic Author
Posts: 49
Joined: Thu Feb 22, 2018 1:15 pm

Re: Web server deployed within local network

Fri Feb 23, 2018 4:09 pm

anyone?

What's even more weird, that without doing anything it worked for some time and I was able to both ping the Pi and connect to web server over wifi from my laptop, but it worked for like 10-15 mins... And it doesn't anymore.... I cannot ping, i cannot connect. IP is assigned i can see from Winbox, but I can't connect to Pi :/
 
2frogs
Long time Member
Long time Member
Posts: 542
Joined: Fri Dec 03, 2010 1:38 am

Re: Web server deployed within local network

Sat Feb 24, 2018 6:37 am

Who is online

Users browsing this forum: bpwl, CZFan, erlinden, mbovenka, r0ckr and 55 guests