Page 1 of 1

Assigning real IP to re-seller

Posted: Mon Feb 26, 2018 11:27 pm
by kheyali
Hi,

I have a small scale ISP business. I always have to work with local client.
But now some people wanted to do business as well in other town,
so I gave them connection via air device with local ip but one of them asking me for real ip. Company gave me
the real ip buty I don't know how I can assign a real ip on my mikrotik for my reseller. So now I am asking for help.

FIY,

My real IP:
IP: 180.***.***204
Subnet: 255.255.255.248
Gateway: 180.***.***.201
DNS: 180.***.129.3
DNS: 8.8.8.8

Now for my resaler they just gave me one ip
IP: 180.***.***.202
For your information my resaler is now connected to me via local ip
IP: 192.168.64.2/30

Now how can I configure on my mikrotik and theirs to provide them the real ip?

Thanks in advance.

Re: Assigning real IP to re-seller

Posted: Tue Feb 27, 2018 8:10 pm
by kheyali
Anyone please help. Really it will be too much helpful for me.
Thanks.

Re: Assigning real IP to re-seller

Posted: Tue Feb 27, 2018 9:57 pm
by poizzon

Re: Assigning real IP to re-seller  [SOLVED]

Posted: Wed Feb 28, 2018 5:51 pm
by Sob
If you got only one new address and it's routed to you, then simply route it further to your reseller, i.e. something like:
/ip route
dst-address=180.***.***.202 gateway=192.168.64.2
That's if the reseller is connected directly to your router. If not, repeat this config on as many intermediate routers as required. Reseller can then add this address to their router in addition to 192.168.64.2, and set it up to be used as required.

Re: Assigning real IP to re-seller

Posted: Wed Feb 28, 2018 7:41 pm
by kheyali
#poizzon,

Thanks. But it didn't work for me.

Re: Assigning real IP to re-seller

Posted: Wed Feb 28, 2018 8:47 pm
by kheyali
If you got only one new address and it's routed to you, then simply route it further to your reseller, i.e. something like:
/ip route
dst-address=180.***.***.202 gateway=192.168.64.2
That's if the reseller is connected directly to your router. If not, repeat this config on as many intermediate routers as required. Reseller can then add this address to their router in addition to 192.168.64.2, and set it up to be used as required.
#Sob,

Lots of thanks for your reply.
It worked. :-D:-D:-D
Again thanks.

Re: Assigning real IP to re-seller

Posted: Wed Feb 28, 2018 8:51 pm
by kheyali
#Sob,

Just want an additional information.

Is it possible to configure the real IP to my re-seller without local IP (means 192.168.64.2)?

Thanks in advance.

Re: Assigning real IP to re-seller

Posted: Wed Feb 28, 2018 10:34 pm
by Sob
It depends on used equipment. Since there's only one address, you can't use the usual subnet-based config. Other way is to use point to point addressing, where it's possible to connect two completely different addresses with /32 netmask.

If both devices use RouterOS, then just this on yours:
/ip address
add address=192.168.64.x network=180.***.***.202 interface=<to reseller>
And this in theirs:
/ip address
add address=180.***.***.202 network=192.168.64.x interface=<reseller's wan>
If they don't have device with RouterOS, it's also possible to make it work at least with Linux and Windows (>=NT6). But not every Linux-based device will necessarily support that in its configuration interface.

But it shouldn't be really necessary. Unless their device is some really limited kind, it must be able to deal with more addresses.

Re: Assigning real IP to re-seller

Posted: Wed Feb 28, 2018 11:00 pm
by kheyali
#Sob,

Thanks a ton.