Community discussions

 
nicutdk
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 99
Joined: Sat Sep 24, 2016 12:06 pm

Multiple PPPoE clients to ISP

Tue Jun 26, 2018 12:31 pm

Hi,

My ISP offer multiple IPs just with multiple PPPoE user.

So....I have 3 PPPoE users from ISP with on IP on each user.

My problem is when I try to ping to all IPs I have response just from one. I try with change distance default route but not working.

Can anybody help with that ?


Best Regards,
 
Sob
Forum Guru
Forum Guru
Posts: 4684
Joined: Mon Apr 20, 2009 9:11 pm

Re: Multiple PPPoE clients to ISP

Tue Jun 26, 2018 3:49 pm

You can find some inspiration here:

https://wiki.mikrotik.com/wiki/Manual:PCC

Ignore the main topic of the article, and just focus on how incoming traffic from each WAN gets own connection mark and how returning traffic gets the right routing mark, based on previously set connection mark.
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply.
 
nicutdk
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 99
Joined: Sat Sep 24, 2016 12:06 pm

Re: Multiple PPPoE clients to ISP

Tue Jun 26, 2018 8:29 pm

Hi try that.

My problem is PPPoE because I don't hav IP for default gateway
 
Sob
Forum Guru
Forum Guru
Posts: 4684
Joined: Mon Apr 20, 2009 9:11 pm

Re: Multiple PPPoE clients to ISP

Wed Jun 27, 2018 12:22 am

It's actually even easier with PPPoE, because it supports gateway=<PPPoE interface>.
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply.
 
nicutdk
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 99
Joined: Sat Sep 24, 2016 12:06 pm

Re: Multiple PPPoE clients to ISP

Wed Jun 27, 2018 1:33 pm

Hi,

Now problem is router. Unable to work with DNS. When I ping at google.com host not found but when I ping at 8.8.8.8 work.

This is my configuration.

Please can anybody help me ?
/interface bridge
add fast-forward=no name=bridge1-LAN

/interface pppoe-client
add disabled=no interface=ether1 name=PPPoE-1 password=XXX user=User1
add disabled=no interface=ether1 name=PPPoE-2 password=XXX user=User2

/interface bridge port
add bridge=bridge1-LAN interface=ether3
add bridge=bridge1-LAN interface=ether4
add bridge=bridge1-LAN interface=ether5

/ip address
add address=192.168.16.1/22 interface=bridge1-LAN network=192.168.16.0

/ip dhcp-server network
add address=192.168.16.0/22 dns-server=192.168.16.1 gateway=192.168.16.1

/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4


/ip firewall filter
add action=fasttrack-connection chain=forward

/ip firewall mangle
add chain=prerouting in-interface=PPPoE-1
add chain=prerouting in-interface=PPPoE-2
add action=mark-routing chain=prerouting connection-mark=PPPoE-1_conn new-routing-mark=PPPoE-1-wan1 src-address=192.168.16.0/22
add action=mark-routing chain=prerouting connection-mark=PPPoE-2_conn new-routing-mark=PPPoE-2-wan2 src-address=192.168.16.0/22

/ip firewall nat
add action=masquerade chain=srcnat out-interface=PPPoE-1 src-address=192.168.16.0/22
add action=masquerade chain=srcnat out-interface=PPPoE-2 src-address=192.168.16.0/22

/ip route
add check-gateway=ping distance=1 gateway=PPPoE-1 routing-mark=PPPoE-1-wan1
add check-gateway=ping distance=1 gateway=PPPoE-2 routing-mark=PPPoE-2-wan2
add check-gateway=ping distance=1 gateway=PPPoE-1,PPPoE-2

Best Regards,
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1740
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: Multiple PPPoE clients to ISP

Thu Jun 28, 2018 8:59 am

 
nicutdk
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 99
Joined: Sat Sep 24, 2016 12:06 pm

Re: Multiple PPPoE clients to ISP

Thu Jun 28, 2018 4:40 pm

Thank You for your answer but it is not for PPPoE.

I read on wiki and I found that:
/ip route
add distance=1 gateway=10.0.0.1%PPPoE-1 routing-mark=WAN1
add distance=1 gateway=10.0.0.1%PPPoE-2 routing-mark=WAN2
Now problem just 1 IP respond at ping from outside.

In log I see:
prerouting: PPPoE-1 out:(unknow 0), src-mac 4c:f9:55:44:55 TCP (ACK,PSH),...........


Regards,

Who is online

Users browsing this forum: No registered users and 41 guests