Community discussions

 
User avatar
emk2203
just joined
Topic Author
Posts: 10
Joined: Tue Feb 07, 2017 11:33 pm
Location: Germany

CAPsMAN - different configs for all 2.4G and all 5G radios in CAPs?

Wed Jul 18, 2018 3:46 pm

I have WAPac access points configured with CAPsMAN from a RB750Gr3. A standard configuration like in the wiki is working.

I want to restrict the 2.4 G radio on all access points (20 MHz width, no extension channel) because of the crowded environment. The 5 G radio on the access points shouldn't be restricted.

My own attempts at this have failed, see below:
# jul/18/2018 13:05:44 by RouterOS 6.42.6
# software id = RN48-R360
#
# model = RouterBOARD 750G r3
# serial number = XXXXXXXXXXXX
/caps-man configuration
add channel.band=2ghz-g/n channel.extension-channel=disabled comment="Restrict\
    \_2.4G to g and n; disable extension channel for crowded environment" \
    name=config2.4G
/interface bridge
add admin-mac=6C:3B:6B:AA:6F:37 auto-mac=no comment=defconf name=bridge
/caps-man configuration
add channel.skip-dfs-channels=no comment=\
    "Basic configuration for 2 APs with CapsMan" country=germany \
    datapath.bridge=bridge name=EMKhome security.authentication-types=\
    wpa-psk,wpa2-psk security.passphrase=XXXXXXXXXXXXXXXX ssid=EMKnet
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge name=defconf
/caps-man manager
set enabled=yes upgrade-policy=suggest-same-version
/caps-man provisioning
add action=create-dynamic-enabled comment="Standard config" \
    master-configuration=EMKhome
add action=create-dynamic-enabled comment=\
    "Add 2.4G extra configurations for 2.4G radios" disabled=yes \
    hw-supported-modes=g master-configuration=EMKhome slave-configurations=\
    config2.4G
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=\
    192.168.88.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=\
    ether1
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
/ip upnp
set allow-disable-external-interface=yes enabled=yes
/ip upnp interfaces
add interface=bridge type=internal
add interface=ether1 type=external
/system clock
set time-zone-name=Europe/Berlin
/system identity
set name=RB750Gr3
/system routerboard settings
set silent-boot=no
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
What am I doing wrong here?
Last edited by emk2203 on Wed Jul 18, 2018 4:35 pm, edited 1 time in total.
RB 750G r3 + RB wAP G-5HacT2HnD
 
diddie17
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Thu Sep 14, 2017 8:53 pm
Location: UK

Re: CAPsMAN - different configs for all 2.4G and all 5G radios in CAPs?

Wed Jul 18, 2018 4:20 pm

There may be an easier or better way, but the way I have done exactly this, which to the best of my knowledge is working fine is to first define all of the possible band combinations that I want to use. The 5GHz channels have extensions and the 2.4GHz channels don't.
/caps-man channel
add band=5ghz-a/n/ac control-channel-width=20mhz extension-channel=Ceee \
    frequency=5180 name="5Ghz - Channel 36"
add band=5ghz-a/n/ac control-channel-width=20mhz extension-channel=Ceee \
    frequency=5260 name="5Ghz - Channel 52"
add band=5ghz-a/n/ac control-channel-width=20mhz extension-channel=Ceee \
    frequency=5500 name="5Ghz - Channel 100"
add band=5ghz-a/n/ac control-channel-width=20mhz extension-channel=Ceee \
    frequency=5580 name="5Ghz - Channel 116"
add band=5ghz-a/n/ac control-channel-width=20mhz extension-channel=Ceee \
    frequency=5660 name="5Ghz - Channel 132"
add band=5ghz-a/n/ac control-channel-width=20mhz extension-channel=Ceee \
    frequency=5765 name="5Ghz - Channel 153"
add band=2ghz-b/g/n control-channel-width=20mhz extension-channel=disabled \
    frequency=2412 name="2GHz Channel 1"
add band=2ghz-b/g/n control-channel-width=20mhz extension-channel=disabled \
    frequency=2437 name="2GHz Channel 6"
add band=2ghz-b/g/n control-channel-width=20mhz extension-channel=disabled \
    frequency=2462 name="2GHz Channel 11"
And then to add Channels and SSID's using the Bands that have been defined.
/caps-man configuration
add channel=2GHz country="united kingdom" hide-ssid=yes mode=ap name=\
    Master-2GHz security=Internal ssid=Master2
add channel=5GHz country="united kingdom" hide-ssid=yes mode=ap name=\
    Master-5GHz security=Internal ssid=Master5
add channel="5Ghz - Channel 36" country="united kingdom" hide-ssid=yes mode=\
    ap name="Master-5GHz - Channel 36" security=Internal ssid=Master5
add channel="5Ghz - Channel 153" country="united kingdom" hide-ssid=yes mode=\
    ap name="Master-5GHz - Channel 153" security=Internal ssid=Master5
add channel="5Ghz - Channel 52" country="united kingdom" hide-ssid=yes mode=\
    ap name="Master-5GHz - Channel 52" security=Internal ssid=Master5
add channel="5Ghz - Channel 100" country="united kingdom" hide-ssid=yes mode=\
    ap name="Master-5GHz - Channel 100" security=Internal ssid=Master5
add channel="5Ghz - Channel 116" country="united kingdom" hide-ssid=yes mode=\
    ap name="Master-5GHz - Channel 116" security=Internal ssid=Master5
add channel="5Ghz - Channel 132" country="united kingdom" hide-ssid=yes mode=\
    ap name="Master-5GHz - Channel 132" security=Internal ssid=Master5
add channel="2GHz Channel 1" country="united kingdom" hide-ssid=yes mode=ap \
    name="Master-2GHz - Channel 1" security=Internal ssid=Master2
add channel="2GHz Channel 6" country="united kingdom" hide-ssid=yes mode=ap \
    name="Master-2GHz - Channel 6" security=Internal ssid=Master2
add channel="2GHz Channel 11" country="united kingdom" hide-ssid=yes mode=ap \
    name="Master-2GHz - Channel 11" security=Internal ssid=Master2
add country="united kingdom" datapath=Manager-forward-vlan-100 mode=ap name=\
    Internal5 security=Internal ssid=Internal
add country="united kingdom" datapath=Manager-forward-vlan-300 mode=ap name=\
    Guest5 security=Guest ssid=Guest
add country="united kingdom" datapath=Manager-forward-vlan-100 mode=ap name=\
    Internal2 security=Internal ssid=Internal
add country="united kingdom" datapath=Manager-forward-vlan-300 mode=ap name=\
    Guest2 security=Guest ssid=Guest
And finally to provision using those
/caps-man provisioning
add action=create-dynamic-enabled comment="Office - 2GHz" \
    master-configuration="Master-2GHz - Channel 1" name-format=prefix \
    name-prefix="Office - 2GHz" radio-mac=XX:XX:XX:XX:XX:XX \
    slave-configurations=Internal2,Guest2
add action=create-dynamic-enabled comment="Office - 5GHz" \
    master-configuration="Master-5GHz - Channel 153" name-format=prefix \
    name-prefix="Office - 5GHz" radio-mac=XX:XX:XX:XX:XX:XX \
    slave-configurations=Internal5,Guest5
Hopefully I've not made any copy and paste errors and hopefully it helps.
 
User avatar
emk2203
just joined
Topic Author
Posts: 10
Joined: Tue Feb 07, 2017 11:33 pm
Location: Germany

Re: CAPsMAN - different configs for all 2.4G and all 5G radios in CAPs?

Thu Jul 19, 2018 10:29 am

Thanks, that is a working solution for the problem.

When you had the MAC addresses in the /caps-man provisioning part, that means that you have provisioned each CAP radio individually by MAC, right? My original approach was trying to find a solution which applies configs to all 2.4G and 5G radios, without the need to address each CAP. Would be interesting to know how this can be done.
RB 750G r3 + RB wAP G-5HacT2HnD

Who is online

Users browsing this forum: No registered users and 34 guests