Community discussions

MikroTik App
 
Spartacus
Member Candidate
Member Candidate
Topic Author
Posts: 132
Joined: Thu Apr 19, 2018 6:38 pm

Issue: Multicast Routing with PIM,

Wed Jul 18, 2018 5:10 pm

Hi,
I need help with Multicast Routing and PIM. I installed the PIM Module on RB3011 OS6.42.6. and PIM is not working for my vlans. I am using a bridge with vlan filtering. All vlans are attached to this bridge. I am using Sonos Player in vlan30 and Controllers in vlan10. The configuration of the FW is ok; all Ports are configured as described by Sonos-Support (see below). IGMP-Snooping in Bridge Settings is enabled.
IGMP.png
I also checked with Wire-Shark and I can see that M-Search-Packages from vlan30 were not received in vlan10. I also disabled all other FW-rules except the Sonos config and it doesn´t work!

I guess it has something to do with the bridge and vlan-Filtering because I checked "Use IP Firewall for VLANs" in the Bridge settings and then Multicast was routed to the other vlans. But if this option is enabled, I cannot access to the internet anymore.
Bridge.png

Can anybody help here?
Regards,
Christian

My PIM config:
/routing pim interface
add comment="Sonos player" interface=vlan30
add interface=vlan10
/routing pim rp
add address=172.16.30.1
InterfaceLists and AddressList:
/ip firewall address-list
add address=172.16.10.0/24 list=SonosControl

/interface list
add name="Sonos Control"

/interface list member
add comment=SONOS interface=vlan10 list="Sonos Control"
My FW configuration:
/ip firewall filter	
add action=accept chain=forward comment="SONOS: forward Multicast traffic" \
    dst-address=239.255.255.250
add action=accept chain=forward comment=\
    "SONOS: forward  Controller events to Players" dst-port=1400,4444,4070 \
    in-interface-list="Sonos Control" out-interface=vlan30 protocol=tcp
add action=accept chain=forward comment=\
    "SONOS: Forward Contoller events  from Players" dst-port=\
    3400,3401,3500,4070 in-interface=vlan30 out-interface-list=\
    "Sonos Control" protocol=tcp
add action=accept chain=forward comment=\
    "SONOS. Forward UPnP Device Discovery events from Players" dst-port=\
    136-139,1900,1901,2869,5353,6969 in-interface=vlan30 out-interface-list=\
    "Sonos Control" protocol=udp
You do not have the required permissions to view the files attached to this post.
 
Spartacus
Member Candidate
Member Candidate
Topic Author
Posts: 132
Joined: Thu Apr 19, 2018 6:38 pm

Re: Issue: Multicast Routing with PIM,

Thu Jul 19, 2018 1:22 pm

Hi,
who can help with Multicast Routing on a bridged vlan?

Christian

Who is online

Users browsing this forum: Bing [Bot], erlinden and 56 guests