Community discussions

 
User avatar
lapsio
Member
Member
Topic Author
Posts: 470
Joined: Wed Feb 24, 2016 5:19 pm

How does MSTP work?

Sat Jul 28, 2018 10:50 pm

I thought that primary reason why we use MSTP is because it's VLAN-aware. However I made following switch config:

/interface bridge
add admin-mac=CC:2D:E0:58:18:E0 auto-mac=no name=br-hardware protocol-mode=mstp vlan-filtering=yes
/interface bridge port
add bridge=br-hardware frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus1 pvid=10
add bridge=br-hardware frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus2 pvid=11
add bridge=br-hardware frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus3 pvid=12
add bridge=br-hardware frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus4 pvid=13
add bridge=br-hardware frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus5 pvid=14
add bridge=br-hardware frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus6 pvid=15
add bridge=br-hardware frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus7 pvid=16
add bridge=br-hardware frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus8 pvid=17
add bridge=br-hardware frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus9 pvid=18
add bridge=br-hardware frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus10 pvid=19
add bridge=br-hardware frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus11 pvid=20
add bridge=br-hardware frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus12 pvid=21
add bridge=br-hardware frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus13 pvid=22
add bridge=br-hardware frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus16 pvid=2
add bridge=br-hardware frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus15 pvid=3
/interface bridge vlan
add bridge=br-hardware tagged=br-hardware,sfp-sfpplus16 vlan-ids=1001
add bridge=br-hardware tagged=sfp-sfpplus16,sfp-sfpplus15 vlan-ids=1002

And following router config:

/interface bridge
add fast-forward=no name=br-service
/interface bridge port
add bridge=br-service interface=vlan10-rb
add bridge=br-service interface=vlan10.1-crs
add bridge=br-service interface=vlan10.2-crs
/interface bridge settings
set use-ip-firewall=yes use-ip-firewall-for-pppoe=yes use-ip-firewall-for-vlan=yes
/interface vlan
add interface=combo1-vlan-rb name=vlan10-rb vlan-id=1000
add interface=sfp-sfpplus1 name=vlan10.1-crs vlan-id=1001
add interface=sfp-sfpplus1 name=vlan10.2-crs vlan-id=1002

And MSTP disables whole port. Why is that? Router is attached to SFP+16 port on switch
MTCNA, MTCRE, MTCINE

Who is online

Users browsing this forum: No registered users and 34 guests