Community discussions

 
User avatar
mdd
just joined
Topic Author
Posts: 18
Joined: Mon Oct 02, 2017 4:25 pm
Location: Klaipeda, Lithuania

VoIP issues

Mon Sep 03, 2018 11:09 am

Hello,

Network:
Voip provided by external provider and all hard phones are provisioned from service providers server.
Mikrotik egde routers CCRXX.
VLAN for voip are created. On all swithes (HP 23xx).
The voip issue we have are: when calls comes in to hard phone and the person picks up the phone - you cannot hear anything, just silence . But after second try it will connect and will be able to speak to caller.
Has anyone any ideas what issues could be and what we could start check.
Mikrotik user from 2017
 
flynno
Member Candidate
Member Candidate
Posts: 241
Joined: Wed Aug 27, 2014 8:11 pm

Re: VoIP issues  [SOLVED]

Mon Sep 03, 2018 5:23 pm

Have you tried disable the SIP in ip firewall service ports?
 
User avatar
mdd
just joined
Topic Author
Posts: 18
Joined: Mon Oct 02, 2017 4:25 pm
Location: Klaipeda, Lithuania

Re: VoIP issues

Tue Sep 04, 2018 3:54 pm

Hi flyno,

After i disabled it lost all device registration. What next step could be ?
Mikrotik user from 2017
 
Samot
Member Candidate
Member Candidate
Posts: 109
Joined: Sat Nov 25, 2017 10:01 pm

Re: VoIP issues

Wed Sep 05, 2018 1:46 pm

Does the caller hear the person or is it dead air/silence for both parties? This sounds like a NAT/congestion issue. How many phones, how much bandwidth and which CCR?
 
User avatar
mdd
just joined
Topic Author
Posts: 18
Joined: Mon Oct 02, 2017 4:25 pm
Location: Klaipeda, Lithuania

Re: VoIP issues

Wed Sep 05, 2018 4:01 pm

It happens just for some calls not for all (70 cisco phones). Just randomly from different network places where the phones are. I have added on switches qos for voice vlan prority 7. But the issue still exists. Trying to sniff out as phone service provider suggested to turn of ALG too. Bandwidth i have allocated min 15mbps / max 20mbps. So far i got more understanding about voip and alg. And not sure 100% but i may need to turn of alg and check why phones are losing registration at all after alg disabled. Maybe FW blocks after ALG disabled ?

2x core routers CCR1036
Mikrotik user from 2017
 
User avatar
mdd
just joined
Topic Author
Posts: 18
Joined: Mon Oct 02, 2017 4:25 pm
Location: Klaipeda, Lithuania

Re: VoIP issues

Thu Sep 13, 2018 11:31 am

Thank you all. After disabled SIP Helper all works now fine.
Mikrotik user from 2017

Who is online

Users browsing this forum: No registered users and 44 guests