Community discussions

MikroTik App
 
User avatar
BraindeadArlequin
just joined
Topic Author
Posts: 3
Joined: Fri Sep 28, 2018 7:09 pm

router without gateway to internet

Fri Sep 28, 2018 7:30 pm

I am trying to setup router (not connected to internet) to provide internal network in which it provides dhcp on all ethernet ports, but doesn't block using another wireless network for access to internet. As a possible solution would be not pushing 0.0.0.0/0 192.168.89.1 route onto dhcp clients or assigning large route weight).

Current configuration:
/interface bridge
  add name=bridge1

/interface list  
  add name=LAN
  
/ip dhcp-server option
  add code=33 name=dhcp_opt33 value=0x18C0A859C0A85901

/ip dhcp-server option sets
  add name=dhcp_optset options=dhcp_opt33

/ip pool
  add name=dhcp_pool ranges=192.168.89.16-192.168.89.253

/ip dhcp-server
  add add-arp=yes address-pool=dhcp_pool disabled=no interface=bridge1 name=dhcp1

/interface bridge port
  add bridge=bridge1 interface=ether1
  add bridge=bridge1 interface=ether2
  add bridge=bridge1 interface=ether3
  add bridge=bridge1 interface=ether4
  add bridge=bridge1 interface=ether5

/interface list member
  add interface=ether1 list=LAN
  add interface=ether2 list=LAN
  add interface=ether3 list=LAN
  add interface=ether4 list=LAN
  add interface=ether5 list=LAN
  add interface=bridge1 list=LAN

/ip address
  add address=192.168.89.1/24 interface=bridge1 network=192.168.89.0

/ip dhcp-server network
  add address=192.168.89.0/24 dns-none=yes netmask=24
 
stoser
Member Candidate
Member Candidate
Posts: 118
Joined: Sun Aug 21, 2016 12:04 am

Re: router without gateway to internet

Sat Sep 29, 2018 6:27 pm

Not quite sure what you are asking. The config you posted is very basic. Your config shows no explicit blocking of anything at all. I do not see firewall rules. The only "blocking"
could be caused by the lack of specified routes...

If you want internet access for your DHCP clients, you will need to add the appropriate default gateway and dns servers in

/ip dhcp-server network

Currently there is no Gateway specified, and no DNS servers are specified. Also you will need to add the appropriate routes in your router if you want the DHCP clients to be able to contact other parts of the network.

For example, The Gateway that you need to specify in the DHCP server Network settings could be the router itself, 192.168.89.1, The you would need to add in the router a default route to the internet (in your case, based on your post, via a wireless link), and also routes to other network subnets, if there are any.
 
User avatar
BraindeadArlequin
just joined
Topic Author
Posts: 3
Joined: Fri Sep 28, 2018 7:09 pm

Re: router without gateway to internet

Mon Oct 01, 2018 12:30 am

You totally missed the point. Lets take this situation...

There is computer with 2 network interfaces - 1 wired and 1 wireless. Wireless is being connected to network with access to internet. Wired network is being connected to router, which isn't connected to internet. The problem is how to make wired network give out dhcp addresses and allow to access internal resources, and still allow users to use wireless network for internet access.

Currently as wired network is being connected, it also adds high priority 0.0.0.0/0 route to wired router which essentially disables access to internet trough wireless network. How i could make it work without needing to configure client systems.

This might be technically impossible, that is without using hacky solutions. And if possible how to create something like split-horizont dns so that for internal resources dns requests are being handled on wired router, and for all other on wireless one. And not using globally resolvable domain names or manual configuration.
 
User avatar
AlainCasault
Trainer
Trainer
Posts: 631
Joined: Fri Apr 30, 2010 3:25 pm
Location: Laval, QC, Canada
Contact:

Re: router without gateway to internet

Mon Oct 01, 2018 3:28 am

Hello,

I think you are over-thinking this.

First, why the computer in the middle? Connect to router to wireless and be done with it. If required, buy a router with a wireless interface. The computer is just an extra point of failure.

If the wired part is only for internal stuff, add firewall rules that prevent those on the wired side to access internet.

You want a 2nd dns? Create your dhcp server for the wired-side clients and have it use whichever dns you want.

Regards,




Sent from Tapatalk

___________________________
Alain Casault, Eng.
If I helped you, let me know!
 
User avatar
BraindeadArlequin
just joined
Topic Author
Posts: 3
Joined: Fri Sep 28, 2018 7:09 pm

Re: router without gateway to internet

Mon Oct 01, 2018 11:24 am

I am sorry if i didn't specify that this question isn't about recommended or right way of organizing network, but about solving it given my constraints.

Who is online

Users browsing this forum: mbovenka and 39 guests