Community discussions

 
plisken
Forum Guru
Forum Guru
Topic Author
Posts: 2317
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

HUAWEI E3372 LTE USB Stick on the Mikrotik router

Wed Oct 03, 2018 6:32 pm

Watch this video tutorial that i made
How to set the HUAWEI E3372 LTE USB Stick on the Mikrotik router. See this on my website. In Dutch but the video is clear.
https://www.wirelessinfo.be/huawei-e337 ... verbinden/
 
charliecrash
just joined
Posts: 6
Joined: Tue Nov 13, 2018 4:04 pm
Location: Sweden

Re: HUAWEI E3372 LTE USB Stick on the Mikrotik router

Sun Dec 02, 2018 1:36 pm

Except when I try. Many many times. Done full resets, deleted all router settings, worked from scratch - but I've never ever seen the device LTE like he does in the video. Really tried to complete every step. I go utterly bonkers...

This is too hard for me. I'm not even sure how to use the terminal codes. Please webfig me to goal...

I need a usb LTE on hEX for total idiots - all necessary steps from unbox to online internet.

Digital Regards
Mikrotik Lover
 
plisken
Forum Guru
Forum Guru
Topic Author
Posts: 2317
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: HUAWEI E3372 LTE USB Stick on the Mikrotik router

Sun Dec 02, 2018 3:08 pm

Where is it wrong?
Do you have the same USB LTE device?
You have to enter the pin code?
What is your original language.

What is the model from your Mikrotik router?

I try to help you
 
charliecrash
just joined
Posts: 6
Joined: Tue Nov 13, 2018 4:04 pm
Location: Sweden

Re: HUAWEI E3372 LTE USB Stick on the Mikrotik router

Tue Dec 04, 2018 11:13 pm

Hello friend 🙂

Ok, my router is the hEX RB750Gr3 with latest stable build, and my usb-modem is a model E3372h-153, not operator locked.

When I do a factory reset of hEX I start in simple mode. Is there anything I should do there?

Then I have to delete the preinstalled bridge and then restart to get an empty router.

Following the video and building a bridge just like you do.

When I get to the point of adding an LTE device it is not possible. I don't have the LTE in the list, only ppp.

I do however have an LTE tab to the right in the row.

When trying ppp device I can make the device connect with the right APN settings, and get a constant turquoise LED but never get any packages.

Hope this clears my problem a bit.

Regards
CC

Edit: My native language is Danish/Swedish, use English a lot but Dutch is not so far from Danish or German imo.
 
plisken
Forum Guru
Forum Guru
Topic Author
Posts: 2317
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: HUAWEI E3372 LTE USB Stick on the Mikrotik router

Wed Dec 05, 2018 8:16 pm

I configured the router and paste the export here.
# model = RouterBOARD 750G r3
/interface lte
set [ find ] mac-address=0C:5B:8F:27:9A:64 name=lte1
/interface bridge
add fast-forward=no name=bridge-mobile
/interface list
add name=LAN
add name=WAN
/ip pool
add name=dhcp_pool-mobile ranges=192.168.100.2-192.168.100.254
/ip dhcp-server
add address-pool=dhcp_pool-mobile disabled=no interface=bridge-mobile name=dhcp-mobile
/interface bridge port
add bridge=bridge-mobile interface=ether1
add bridge=bridge-mobile interface=ether2
add bridge=bridge-mobile interface=ether3
add bridge=bridge-mobile interface=ether4
add bridge=bridge-mobile interface=ether5
/interface list member
add interface=bridge-mobile list=LAN
add interface=ether1 list=LAN
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
add interface=ether5 list=LAN
add interface=lte1 list=WAN
/ip address
add address=192.168.100.1/24 interface=bridge-mobile network=192.168.100.0
/ip dhcp-server network
add address=192.168.100.0/24 gateway=192.168.100.1
/ip firewall filter
add action=fasttrack-connection chain=forward comment="fasttrack-dns tcp" dst-port=53 protocol=tcp
add action=fasttrack-connection chain=forward comment="fasttrack-dns udp" dst-port=53 protocol=udp
add action=accept chain=input comment="Accept established - related - untracked" connection-nat-state="" connection-state=established,related,untracked in-interface-list=WAN
add action=drop chain=input comment="Drop invalid conn" connection-state=invalid in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat out-interface=lte1
/system routerboard settings
set silent-boot=no
Do not forget to enter the pin code. and edit the DNS-server IP's. Put first the USB-dongle into the router.
You do this by double-clicking interface LT1
Activate LTE and 3G if necessary.
I hope it works now.
This code must be placed on an empty router without default configuration.
If this is done reboot the router.


Goodluck
 
plisken
Forum Guru
Forum Guru
Topic Author
Posts: 2317
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: HUAWEI E3372 LTE USB Stick on the Mikrotik router

Wed Dec 05, 2018 8:16 pm

I configured the router and paste the export here.
# model = RouterBOARD 750G r3
/interface lte
set [ find ] mac-address=0C:5B:8F:27:9A:64 name=lte1
/interface bridge
add fast-forward=no name=bridge-mobile
/interface list
add name=LAN
add name=WAN
/ip pool
add name=dhcp_pool-mobile ranges=192.168.100.2-192.168.100.254
/ip dhcp-server
add address-pool=dhcp_pool-mobile disabled=no interface=bridge-mobile name=dhcp-mobile
/interface bridge port
add bridge=bridge-mobile interface=ether1
add bridge=bridge-mobile interface=ether2
add bridge=bridge-mobile interface=ether3
add bridge=bridge-mobile interface=ether4
add bridge=bridge-mobile interface=ether5
/interface list member
add interface=bridge-mobile list=LAN
add interface=ether1 list=LAN
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
add interface=ether5 list=LAN
add interface=lte1 list=WAN
/ip address
add address=192.168.100.1/24 interface=bridge-mobile network=192.168.100.0
/ip dhcp-server network
add address=192.168.100.0/24 gateway=192.168.100.1
/ip firewall filter
add action=fasttrack-connection chain=forward comment="fasttrack-dns tcp" dst-port=53 protocol=tcp
add action=fasttrack-connection chain=forward comment="fasttrack-dns udp" dst-port=53 protocol=udp
add action=accept chain=input comment="Accept established - related - untracked" connection-nat-state="" connection-state=established,related,untracked in-interface-list=WAN
add action=drop chain=input comment="Drop invalid conn" connection-state=invalid in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat out-interface=lte1
/system routerboard settings
set silent-boot=no
Do not forget to enter the pin code. and edit the DNS-server IP's. Put first the USB-dongle into the router.
You do this by double-clicking interface LT1
Activate LTE and 3G if necessary.
I hope it works now.
This code must be placed on an empty router without default configuration.
If this is done reboot the router.


Goodluck
 
charliecrash
just joined
Posts: 6
Joined: Tue Nov 13, 2018 4:04 pm
Location: Sweden

Re: HUAWEI E3372 LTE USB Stick on the Mikrotik router

Thu Dec 13, 2018 12:58 am

Thank you for the code...but this is only a 1/10 of a solution.

I've just spent 6 hours trying to get this code into the router.

It must have been pure luck in the past but I can not connect to a router without a bridge, so for all other newbies and for the future "Dummies"-book - you must use winbox (not webfig) and connect to the neighbour MAC adress. This was probably 1 hour of frustration before i realized that. Stupid me.

Ok, made a new reset and got inside the router and wiped the configuration, rebooted, so far so good.

I really don't know much about terminals so I tried a few times to simply paste the entire code-text at the prompt. No. not possible, don't try this at home.

So how the h... do i get the code in? Googled around and found a bunch of dead ends until I found the .rsc files. Didn't know how to make an .rsc file, so I thought I could export the system .rsc and edit it and then restore from it. Tried that for a long time. a loooong time.
Ran into that "File not found (6)" bug every single time. Didn't matter if I tried from the terminal or the filesystem gui. The correctly imported file does not exist. DUH... Read something about "pause" for the system to accept the .rsc but didn't understand what to do, so ignored.

Finally found the Reset config (do not install default config checkbox) and run "filename.rsc" - method.

It did seem to work, but I couldn't see anything useful in the log about it being executed. Then suddenly there was a bridge and ports running...

So it seemed to get right this time, but still no LTE device, and I did have the LTE device plugged in the USB port at all times. Ony evidence of the modem is the greyed out ppp-out1 device. back to f'in SQUARE ONE!

You call this beginner basics?
 
charliecrash
just joined
Posts: 6
Joined: Tue Nov 13, 2018 4:04 pm
Location: Sweden

Re: HUAWEI E3372 LTE USB Stick on the Mikrotik router

Thu Dec 13, 2018 9:35 am

Allright... Tried this morning to repeat my half baked running sequence, without luck.

#01: I manually reset the router (holding reset button while connecting power and release reset button while USR flashes, not after it's done)

#02: I connect laptop into port 2 and start winbox, login on neighbour mac-adress without password, press the OK button to close message of changelog and config. Router is now in standard config.

#03: I go to files and upload my lteconfig.rsc containing only the unedited code from the post above. File is made with notepad.

#04: I go into system, reset configuration, tick "no default configuration" and in "run after reset" I choose my lteconfig.rsc, click "Reset Configuration" and Yes in next dialog.

What happens is, Router reboots and come up empty. No configurations made. Uploaded file is also gone. Usb modem is connected in usb port at all times.

Where did it go wrong? I'm not sure I've ever got the code to stick. Router is not really accepting files at all. What must be in an .rsc file for the code to run?

Or am I just doing this all wrong?
 
plisken
Forum Guru
Forum Guru
Topic Author
Posts: 2317
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: HUAWEI E3372 LTE USB Stick on the Mikrotik router

Thu Dec 13, 2018 1:33 pm

Have you first add the LTE USB dongle?

Greatings
 
charliecrash
just joined
Posts: 6
Joined: Tue Nov 13, 2018 4:04 pm
Location: Sweden

Re: HUAWEI E3372 LTE USB Stick on the Mikrotik router

Thu Dec 13, 2018 1:43 pm

I'm actually struggling with that at the moment. I can not add an LTE device no matter what I do.
The usbstick is inserted in the router and flashing turquoise.
In terminal I try to add the LTE device just as your lines with same mac-address. Nothing happens
It is not accepting this as an LTE device.
 
plisken
Forum Guru
Forum Guru
Topic Author
Posts: 2317
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: HUAWEI E3372 LTE USB Stick on the Mikrotik router

Thu Dec 13, 2018 2:32 pm

The mac address comes from your own USB dongle.
If you see no LTE at "interfaces", then you can reboot your router with the USB dongle plugged in.
Is it about a different model than the Huawei E3372?
If so, which brand and model
 
charliecrash
just joined
Posts: 6
Joined: Tue Nov 13, 2018 4:04 pm
Location: Sweden

Re: HUAWEI E3372 LTE USB Stick on the Mikrotik router

Thu Dec 13, 2018 2:42 pm

I'm just now finding out the problem with Hilink and Stickmode...
I have the wrong device ID. Mine is 0x1506, accepted ID is only 0x14db

Trying to change that right now. Managed to wipe it completely with a short circuit and now aiming to flash with working firmware.

We'll see how it goes 😁
 
plisken
Forum Guru
Forum Guru
Topic Author
Posts: 2317
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: HUAWEI E3372 LTE USB Stick on the Mikrotik router

Thu Dec 13, 2018 2:47 pm

Let me know and goodluck

Who is online

Users browsing this forum: emilst and 23 guests