Community discussions

 
arash88
just joined
Topic Author
Posts: 9
Joined: Wed Oct 31, 2018 1:33 pm

Share Internet over SXTs

Sat Nov 17, 2018 1:07 pm

Hi everyone,
I have a ptp link with two SXT's configured as same as this Topic with same scenario and same settings. (Though AP1 and AP2 are not mikrotiks).
Ok Now I have Internet on my AP1 but i can't get internet through AP2. What should i do? Currently i have connected these two sub-nets and two network can ping each other but no internet so far.
Thanks in advance guys.
 
plisken
Forum Guru
Forum Guru
Posts: 2317
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Share Internet over SXTs

Sun Nov 18, 2018 8:35 pm

Try this configuration to obtain a stable point to point link.
Spoken in Dutch but just follow my tutorial
https://www.youtube.com/watch?v=FAGbPd0Nm94&t=9s
Goodluck
 
arash88
just joined
Topic Author
Posts: 9
Joined: Wed Oct 31, 2018 1:33 pm

Re: Share Internet over SXTs

Sun Nov 18, 2018 11:48 pm

Try this configuration to obtain a stable point to point link.
Spoken in Dutch but just follow my tutorial
https://www.youtube.com/watch?v=FAGbPd0Nm94&t=9s
Goodluck
Thanks alot @plisken for your nice tutorial but as i said my users are on AP1 and AP2 (two subnets), what should i set for routes in AP1 and AP2? Shouldn't I set IP Addresses on both ether1 ports of SXTs and route them through APs?
Thanks a lot for your time and knowledge
 
plisken
Forum Guru
Forum Guru
Posts: 2317
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Share Internet over SXTs

Mon Nov 19, 2018 9:10 am

Hello,
Maybe you can configure VLAN on the SXTs
But for that I would like to see your complete configuration on a drawing
 
arash88
just joined
Topic Author
Posts: 9
Joined: Wed Oct 31, 2018 1:33 pm

Re: Share Internet over SXTs

Wed Nov 21, 2018 11:22 am

Hello,
Maybe you can configure VLAN on the SXTs
But for that I would like to see your complete configuration on a drawing
Hi @plisken
As i said my settings are the same as this topic and this is my drawing of network. I already have my link running without MPLS, but no internet on AP2. All my users are on two APs.
 
plisken
Forum Guru
Forum Guru
Posts: 2317
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Share Internet over SXTs

Wed Nov 21, 2018 12:27 pm

Hello, do you plug the sxt on the WAN site of your TP-link router?
 
arash88
just joined
Topic Author
Posts: 9
Joined: Wed Oct 31, 2018 1:33 pm

Re: Share Internet over SXTs

Wed Nov 21, 2018 2:43 pm

Hello, do you plug the sxt on the WAN site of your TP-link router?
Hi,
WAN port on AP1 is connected to internet with pptp so SXT1 is connected to lan switch of AP1.
In AP2 when i connect sxt2 to WAN port i get Internet and AP1 network, but also i get 2 problems: 1- AP1 can't see AP2 network anymore 2- Can't discover sxt's and connect to them from AP2 anymore. 3- connection from AP2 to AP1 gets more sloppy with few drops.
So can i get internet on AP2 with both SXT's connected to AP's lan switch?
Thanks alot.
 
plisken
Forum Guru
Forum Guru
Posts: 2317
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Share Internet over SXTs

Wed Nov 21, 2018 5:42 pm

Hello, that you can not see the SXTs anymore is very normal.
On the WAN port of your TP link there is an active firewall that blocks this traffic.
Can you put the TP link in AP mode only?
Instead of the tp-link you can place a switch and there you connect the tplink in ap mode only.
 
arash88
just joined
Topic Author
Posts: 9
Joined: Wed Oct 31, 2018 1:33 pm

Re: Share Internet over SXTs

Wed Nov 21, 2018 8:06 pm

Instead of the tp-link you can place a switch and there you connect the tplink in ap mode only.
Hey plisken, can you explain more what you mean? should i only set my AP2 on AP-only?
 
plisken
Forum Guru
Forum Guru
Posts: 2317
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Share Internet over SXTs

Wed Nov 21, 2018 9:06 pm

Yes, and use a switch to connect SXT2 and the TP-link in AP mode.
 
arash88
just joined
Topic Author
Posts: 9
Joined: Wed Oct 31, 2018 1:33 pm

Re: Share Internet over SXTs

Thu Nov 29, 2018 8:29 pm

Yes, and use a switch to connect SXT2 and the TP-link in AP mode.
Hey @plisken , Thanks alot for helping.
By saying put AP2 in AP mode and use switch you mean i remove my subnet2? because i can't do that. if you mean anything else can you draw me something?
As i said before currently i have a bridge-station bridge link and i don't have any tunnel, should i still go for mpls/vpls? does it help interoperability of my current network?

Thanks.
 
arash88
just joined
Topic Author
Posts: 9
Joined: Wed Oct 31, 2018 1:33 pm

Re: Share Internet over SXTs

Sun Dec 02, 2018 11:39 am

Anyone have any idea for me?
 
mkx
Forum Guru
Forum Guru
Posts: 1018
Joined: Thu Mar 03, 2016 10:23 pm

Re: Share Internet over SXTs

Sun Dec 02, 2018 12:05 pm

Can you post configuration of both SXTs?
BR,
Metod
 
plisken
Forum Guru
Forum Guru
Posts: 2317
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Share Internet over SXTs

Sun Dec 02, 2018 3:04 pm

Can you make a drawing of your configuration?
Then I can see how to configure the SXTs
 
mkx
Forum Guru
Forum Guru
Posts: 1018
Joined: Thu Mar 03, 2016 10:23 pm

Re: Share Internet over SXTs

Sun Dec 02, 2018 3:22 pm

Can you make a drawing of your configuration?
Then I can see how to configure the SXTs
OP linked same config in post #5.
BR,
Metod
 
arash88
just joined
Topic Author
Posts: 9
Joined: Wed Oct 31, 2018 1:33 pm

Re: Share Internet over SXTs

Sun Dec 02, 2018 10:23 pm

Can you make a drawing of your configuration?
Then I can see how to configure the SXTs
OP linked same config in post #5.
Hi dear @mkx and @plisken
Thank you guys so much for showing interest in my problem. As i said i did the exact same as this topic and this is my drawing of my whole network. I have a good link but no internet in AP2. When i put the sxt2's ether1 to AP2's WAN port, i get internet but AP1 loose contact to AP2 network and interoperability is gone now i suppose.
Again thanks guys
 
plisken
Forum Guru
Forum Guru
Posts: 2317
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Share Internet over SXTs

Mon Dec 03, 2018 9:27 am

Login into the SXT1 and in new terminal type "export" and paste the result on this forum.
Remove passwords.
Do the same on SXT 2
I test this configuration and try to help you.
 
plisken
Forum Guru
Forum Guru
Posts: 2317
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Share Internet over SXTs

Mon Dec 03, 2018 1:26 pm

I have hopefully a solution for you. caution this is made with a 5 GHz; SXT G-5HPacD
SXT1
/interface bridge
add fast-forward=no name=bridge-local
add fast-forward=no name=bridge-sxt2
/interface wireless
set [ find default-name=wlan1 ] disabled=no frequency=5200 mode=ap-bridge ssid=sxt2
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=bridge-local interface=ether1
add bridge=bridge-local interface=wlan1
/ip address
add address=10.0.0.1/30 interface=wlan1 network=10.0.0.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=bridge-local
/system clock
set time-zone-name=Europe/Brussels
/system identity
set name=SXT1
/system routerboard settings
set silent-boot=no

SXT2
/interface wireless
set [ find default-name=wlan1 ] disabled=no frequency=5200 mode=station-bridge ssid=sxt2
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=192.168.1.1-192.168.1.200,192.168.1.202-192.168.1.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether1 name=dhcp1
/ip address
add address=10.0.0.2/30 interface=wlan1 network=10.0.0.0
add address=192.168.1.201/24 interface=ether1 network=192.168.1.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=wlan1
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=1.1.1.1,8.8.8.8 gateway=192.168.1.201
/ip firewall nat
add action=masquerade chain=srcnat out-interface=wlan1 src-address=192.168.1.0/24
/system clock
set time-zone-name=Europe/Brussels
/system identity
set name=SXT2
/system routerboard settings
set silent-boot=no
Attention, pay attention to the local settings and the frequency. This is configured on a 5 GHz device
I hope to have helped you.
The TP-Links must be set as AP only.
Can I use your plan on my website please?
 
arash88
just joined
Topic Author
Posts: 9
Joined: Wed Oct 31, 2018 1:33 pm

Re: Share Internet over SXTs

Tue Dec 04, 2018 6:23 pm

I have hopefully a solution for you. caution this is made with a 5 GHz; SXT G-5HPacD
SXT1
/interface bridge
add fast-forward=no name=bridge-local
add fast-forward=no name=bridge-sxt2
/interface wireless
set [ find default-name=wlan1 ] disabled=no frequency=5200 mode=ap-bridge ssid=sxt2
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=bridge-local interface=ether1
add bridge=bridge-local interface=wlan1
/ip address
add address=10.0.0.1/30 interface=wlan1 network=10.0.0.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=bridge-local
/system clock
set time-zone-name=Europe/Brussels
/system identity
set name=SXT1
/system routerboard settings
set silent-boot=no

SXT2
/interface wireless
set [ find default-name=wlan1 ] disabled=no frequency=5200 mode=station-bridge ssid=sxt2
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=192.168.1.1-192.168.1.200,192.168.1.202-192.168.1.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether1 name=dhcp1
/ip address
add address=10.0.0.2/30 interface=wlan1 network=10.0.0.0
add address=192.168.1.201/24 interface=ether1 network=192.168.1.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=wlan1
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=1.1.1.1,8.8.8.8 gateway=192.168.1.201
/ip firewall nat
add action=masquerade chain=srcnat out-interface=wlan1 src-address=192.168.1.0/24
/system clock
set time-zone-name=Europe/Brussels
/system identity
set name=SXT2
/system routerboard settings
set silent-boot=no
Attention, pay attention to the local settings and the frequency. This is configured on a 5 GHz device
I hope to have helped you.
The TP-Links must be set as AP only.
Can I use your plan on my website please?
Thank you dear @plisken so much i will try these settings and hit you back tomorrow. You may use anything you want. Can you give me your sites link?
Off topic: Does MPLS/VPLS link gives me better interoperability or anything better at all?
Again thank you so much.
 
plisken
Forum Guru
Forum Guru
Posts: 2317
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Share Internet over SXTs

Tue Dec 04, 2018 11:14 pm

Hello, your welcome no problem.
My website link is https://www.wirelessinfo.be.
I'm curious and hope it's this configuration that you need.
The TP-Links must now be configured in AP mode.
MPLS / VPLS is faster but makes it more complicated.
So I do not know if you would benefit from it.
Greetings and have a nice day

Goodluck

Who is online

Users browsing this forum: emilst and 26 guests