Community discussions

MikroTik App
 
miltont
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Wed Nov 11, 2015 3:58 am

DST NAT on 3 Mikrotiks

Mon Jan 21, 2019 11:25 pm

Greetings
I need to achieve DST Nat to 10.20.1.46 port 8282
Default Gateway 10.20.1.1
Client has Mikrotik RB

10.20.1.1 RB4011 Model
connects to thru PTP Connection to 10.20.0.1 that has Public Interface 24.139.x.x (Public IP)

Do i have to create DST NAT Rules on the 3 Mikrotiks?
What would be the order of Ips on each Rule?
 
anav
Forum Guru
Forum Guru
Posts: 4640
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: DST NAT on 3 Mikrotiks

Mon Jan 21, 2019 11:58 pm

3 Mikrotiks??
You are only showing one??

Basically Destination NAT rule and firewall rule go hand in hand. One needs an allow rule in the forward chain so that all DST rules will work.
/ip firewall filter
add action=accept chain=forward comment=\
"Allow Port Forwarding" connection-nat-state=dstnat

Then you can make as many dst-nat rules as are required.
/ip firewall nat
add action=dst-nat chain=dstnat comment=MyPortFowardRule dst-port=8282 \
in-interface-list=WAN protocol=tcp to-addresses=10.21.1.46

(assumed protocol TCP as it was not detailed).

If you have multiple MT devices between the server and the internet make a diagram and annotate them with numbers.
For example if there is an MT in between, the only difference is the MT downstreap (its LANIP on the first MT) which is really also its WANIP would be the to-address LOL.
See diagrams will help.
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
mkx
Forum Guru
Forum Guru
Posts: 4331
Joined: Thu Mar 03, 2016 10:23 pm

Re: DST NAT on 3 Mikrotiks

Tue Jan 22, 2019 8:14 am

Whether you have to create 3 DST-NAT rules or not largely depends on topology and configuration of your whole network. Ideally create a simple chart showing your different LAN segments and briefly describe what are your goals. It might turn out that your current setup is over complicated ...
BR,
Metod

Who is online

Users browsing this forum: No registered users and 37 guests