Community discussions

 
Elektromat
just joined
Topic Author
Posts: 6
Joined: Fri Nov 23, 2018 5:54 pm

CRS317 DNS Problem - ERROR: could not resolve dns name

Sat Feb 23, 2019 1:19 am

]Hello,

for a while now the internal DNS resolution on my crs317 is not working anymore.
A ping to 8.8.8.8 is OK.
A ping on google.com does not work
[admin@MikroTik] > ping google.com                  
invalid value for argument address:
    invalid value of mac-address, mac address required
    invalid value for argument ipv6-address
    while resolving ip-address: could not get answer from dns server

The update check returns the following error: ERROR: could not resolve dns name

here the config of my crs317:
[admin@MikroTik] > /export compact
# feb/22/2019 23:02:26 by RouterOS 6.43.12
# software id = WRW5-GD0Y
#
# model = CRS317-1G-16S+
# serial number = XXX
/interface bridge
add name=bridge1
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=sfp-sfpplus1
add bridge=bridge1 interface=sfp-sfpplus2
add bridge=bridge1 interface=sfp-sfpplus3
add bridge=bridge1 interface=sfp-sfpplus4
add bridge=bridge1 interface=sfp-sfpplus5
add bridge=bridge1 interface=sfp-sfpplus6
add bridge=bridge1 interface=sfp-sfpplus7
add bridge=bridge1 interface=sfp-sfpplus8
add bridge=bridge1 interface=sfp-sfpplus9
add bridge=bridge1 interface=sfp-sfpplus10
add bridge=bridge1 interface=sfp-sfpplus11
add bridge=bridge1 interface=sfp-sfpplus12
add bridge=bridge1 interface=sfp-sfpplus13
add bridge=bridge1 interface=sfp-sfpplus14
add bridge=bridge1 interface=sfp-sfpplus15
add bridge=bridge1 interface=sfp-sfpplus16
/interface list member
add interface=ether1 list=WAN
add interface=sfp-sfpplus1 list=LAN
add interface=sfp-sfpplus2 list=LAN
add interface=sfp-sfpplus3 list=LAN
add interface=sfp-sfpplus4 list=LAN
add interface=sfp-sfpplus5 list=LAN
add interface=sfp-sfpplus6 list=LAN
add interface=sfp-sfpplus7 list=LAN
add interface=sfp-sfpplus8 list=LAN
add interface=sfp-sfpplus9 list=LAN
add interface=sfp-sfpplus10 list=LAN
add interface=sfp-sfpplus11 list=LAN
add interface=sfp-sfpplus12 list=LAN
add interface=sfp-sfpplus13 list=LAN
add interface=sfp-sfpplus14 list=LAN
add interface=sfp-sfpplus15 list=LAN
add interface=sfp-sfpplus16 list=LAN
/ip address
add address=192.168.111.220/24 interface=ether1 network=192.168.111.0
/ip dns
set allow-remote-requests=yes servers=192.168.111.1
/ip firewall nat
add action=masquerade chain=srcnat out-interface=all-ethernet
/ip route
add distance=1 gateway=192.168.111.1
/system ntp client
set enabled=yes primary-ntp=136.243.70.198
/system routerboard settings
set boot-os=router-os

The dns cache shows 0 entries.

I'm a bit helpless :!: :?: :!: because it worked at the beginning with older F/W versions.
On my pcs the dns name resolution is OK.

Can someone help me?
 
core007
just joined
Posts: 1
Joined: Mon Jun 17, 2013 6:38 pm

Re: CRS317 DNS Problem - ERROR: could not resolve dns name

Wed Aug 07, 2019 8:24 pm

Same with me.
 
llag
newbie
Posts: 29
Joined: Sat Aug 04, 2018 12:12 am

Re: CRS317 DNS Problem - ERROR: could not resolve dns name

Fri Aug 09, 2019 12:19 am

]Hello,

for a while now the internal DNS resolution on my crs317 is not working anymore.
A ping to 8.8.8.8 is OK.
A ping on google.com does not work
.
.
.
/ip address
add address=192.168.111.220/24 interface=ether1 network=192.168.111.0
/ip dns
set allow-remote-requests=yes servers=192.168.111.1
.
.
[/code]
So does 192.168.111.1 really serve DNS? Maybe it does not run a DNS server os has a firewall blocking DNS requests from the CRS317?

Who is online

Users browsing this forum: No registered users and 33 guests