Page 1 of 1

dhcp offered NOACK

Posted: Thu Mar 28, 2019 9:34 pm
by paulhm81
Hello
I searched the forum for my problem but didn't find an answer.
I have this scenario - a mikrotik router with wireless in a bridge with dhcp on the bridge and a tp-link acces point in client mode (connected to the wifi to provide connection over lan to a pc). Any pc after the access point doesn't get an ip. In the router's dhcp leases it appears as offered but expires. I tried a few things after searching through the forum --- dhcp admin mac, no rtsp or stp, I downgraded the mikrotik to 6.37.4 and it worked but any version after that didn't. The mikrotik is a 951g-2hnd an tried it with a hap lite also with the same results. The AP works without a problem with non mikrotik routers (tp-link or asus). Also tried with a RBD52G-5HacD2HnD and it works fine with the same version (6.44.1).
I saw that in the arp table the pc offered ip appears with a blank mac. Also disabled the input and forward drop rules in the firewall and it didn't work either.

Any ideas what i'm missing?
Thank you!