Community discussions

 
PaoloNB
just joined
Topic Author
Posts: 2
Joined: Tue May 07, 2019 6:33 pm

Problems configuring Mtk to handle PPPoE on home network. Can't pass PADI phase

Tue May 07, 2019 8:31 pm

Greetings

I've been trying to configure my first mikrotik to manage my home network for two weeks now.
I have basic knowledge about networking (enough to set a home network with user friendly routers), and tired of bad router quality, I decided to go for mikrotik and, why not, learn something new.

The scheme is:
ISP modem-router ---------> Mtk hAP ac^2 -------> wired and wireless clients
After some reading and youtube videos, I figured out I want my ISP modem-router in bridge mode and Mtk handling PPPoE, so I did the following config:

1°) Tried quickset with no success
2°) Reset config without default settings and tried this config:
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 \
    password=******** use-peer-dns=yes user=********@speedy
3°) Updated firmware and ROS to latest version
4°) Checked for DHCP client on ether1, disabling encryption in default profile, changing MTU to values lower than 1500 (ISP mrouter uses 1480)
5°) Tried different modem-routers I have (TPLINK TD-W8968, FiberHome HG110, Huawei EchoLife HG520c and Mitrastar DSL-2401HN-T1C)

None of the above steps got me any further than PADI:

20:52:13 system,info,account user admin logged in via local 
20:52:22 pppoe,debug,packet ether1: sent PADI to FF:FF:FF:FF:FF:FF 
20:52:22 pppoe,debug,packet     session-id=0x0000 
20:52:22 pppoe,debug,packet     host-uniq=0x4c005301 
20:52:22 pppoe,debug,packet     service-name= 
20:52:23 pppoe,debug,packet ether1: sent PADI to FF:FF:FF:FF:FF:FF 
20:52:23 pppoe,debug,packet     session-id=0x0000 
20:52:23 pppoe,debug,packet     host-uniq=0x4c005301 
20:52:23 pppoe,debug,packet     service-name= 
20:52:24 pppoe,debug,packet ether1: sent PADI to FF:FF:FF:FF:FF:FF 
20:52:24 pppoe,debug,packet     session-id=0x0000 
20:52:24 pppoe,debug,packet     host-uniq=0x4c005301 
20:52:24 pppoe,debug,packet     service-name= 
20:52:25 pppoe,debug,packet ether1: sent PADI to FF:FF:FF:FF:FF:FF 
20:52:25 pppoe,debug,packet     session-id=0x0000 
20:52:25 pppoe,debug,packet     host-uniq=0x4c005301 
20:52:25 pppoe,debug,packet     service-name= 
20:52:26 pppoe,debug,packet ether1: sent PADI to FF:FF:FF:FF:FF:FF 
20:52:26 pppoe,debug,packet     session-id=0x0000 
20:52:26 pppoe,debug,packet     host-uniq=0x4c005301 
20:52:26 pppoe,debug,packet     service-name= 
20:52:27 pppoe,debug,packet ether1: sent PADI to FF:FF:FF:FF:FF:FF 
20:52:27 pppoe,debug,packet     session-id=0x0000 
20:52:27 pppoe,debug,packet     host-uniq=0x4c005301 
20:52:27 pppoe,debug,packet     service-name= 
20:52:28 pppoe,debug,packet ether1: sent PADI to FF:FF:FF:FF:FF:FF 
20:52:28 pppoe,debug,packet     session-id=0x0000 
20:52:28 pppoe,debug,packet     host-uniq=0x4c005301 
20:52:28 pppoe,debug,packet     service-name= 
20:52:29 pppoe,debug,packet ether1: sent PADI to FF:FF:FF:FF:FF:FF 
20:52:29 pppoe,debug,packet     session-id=0x0000 
20:52:29 pppoe,debug,packet     host-uniq=0x4c005301 
20:52:29 pppoe,debug,packet     service-name= 
20:52:30 pppoe,debug,packet ether1: sent PADI to FF:FF:FF:FF:FF:FF 
20:52:30 pppoe,debug,packet     session-id=0x0000 
20:52:30 pppoe,debug,packet     host-uniq=0x4c005301 
20:52:30 pppoe,debug,packet     service-name= 
20:52:31 pppoe,debug,packet ether1: sent PADI to FF:FF:FF:FF:FF:FF 
20:52:31 pppoe,debug,packet     session-id=0x0000 
20:52:31 pppoe,debug,packet     host-uniq=0x4c005301 
20:52:31 pppoe,debug,packet     service-name= 
20:52:32 pppoe,ppp,debug : CCP close 
20:52:32 pppoe,ppp,debug : BCP close 
20:52:32 pppoe,ppp,debug : IPCP close 
20:52:32 pppoe,ppp,debug : IPV6CP close 
20:52:32 pppoe,ppp,debug : MPLSCP close 
20:52:32 pppoe,ppp,debug : LCP lowerdown 
20:52:32 pppoe,ppp,debug : LCP down event in initial state 

I've seen in some videos that some rules under mangle are created automatically when setting up PPPoE, but It doesn't happen in my case, I guess it's because that happens once any response comes from the ISP-mrouter.

Would you please point what I'm doing wrong, or any suggestion?

This is how /interface looks actually:
[admin@MikroTik] /interface> print
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU
 0  R  ether1                              ether            1500  1598       9214
 1     ether2                              ether            1500  1598       9214
 2     ether3                              ether            1500  1598       9214
 3     ether4                              ether            1500  1598       9214
 4  R  ether5                              ether            1500  1598       9214
 5  X  wlan1                               wlan             1500  1600       2290
 6  X  wlan2                               wlan             1500  1600       2290
 7     pppoe-out1                          pppoe-out 
[admin@MikroTik] /interface>
And RB model:
# jan/02/1970 00:02:16 by RouterOS 6.44.3
# software id = BFWB-6JA2
#
# model = RBD52G-5HacD2HnD
Thank you in advance, and sorry for any misspell, english is not my mother language

Paolo
 
PaoloNB
just joined
Topic Author
Posts: 2
Joined: Tue May 07, 2019 6:33 pm

Re: Problems configuring Mtk to handle PPPoE on home network. Can't pass PADI phase  [SOLVED]

Wed May 15, 2019 1:36 pm

Hi!

You can mark this as solved. All I had to do was to create a VLAN with VLAN-ID 20 on ether1, and now it works fine. This is for ISP Movistar from Argentina, just in case it's of any use for someone else.
/interface vlan> print 
Flags: X - disabled, R - running 
 #   NAME                   MTU ARP             VLAN-ID INTERFACE                
 0 R vlan1                 1492 enabled              20 ether1   
Regards

Paolo

Who is online

Users browsing this forum: No registered users and 33 guests