Community discussions

 
Zetera
newbie
Topic Author
Posts: 41
Joined: Sat Apr 21, 2018 6:57 pm

Multiple Entries for same IPs in ARP table?

Wed May 15, 2019 4:00 pm

Attached is an issue I've been experiencing with some of our pieces of MikroTik equipment. It seems that there are multiple entries in the ARP table for the same IP addresses. I've also added it below. What would be the reasons that this might occur? The reason this is an issue is that it often causes issues with monitoring and being able to properly communicate with the equipment. Any assistance would be greatly appreciated.

I've also exported a hide-sensitive config for anyone's review for further information.
 1 DC 10.2.0.2        74:3E:2B:09:76:60 vlan1002                                            
 3 DC 10.2.0.254      74:3E:2B:09:35:20 vlan1002                                                 
 5 DC 10.2.0.252      74:3E:2B:09:76:C0 vlan1002                                 
 6 DC 10.2.0.253      74:3E:2B:09:38:70 vlan1002                                             
 8 DC 10.2.0.250      74:3E:2B:09:6E:50 vlan1002                                 
 9 D  10.2.0.253                        br-AP                                                                       
16 D  10.2.0.250                        br-AP                                                              
18 D  10.2.0.252                        br-AP                                        
20 D  10.2.0.2                          br-AP                                 
# may/15/2019 08:43:00 by RouterOS 6.40.9
# software id = FJQ0-NYB2
#
# model = RouterBOARD 750G r2
# serial number = 64FC02200A28
/interface ethernet
set [ find default-name=ether1 ] name=ether1-WAN
set [ find default-name=ether2 ] name=ether2-master
/interface bridge
add name=br-AP
add name=br-Wired
/ip neighbor discovery
set ether1-WAN discover=no
/interface vlan
add interface=ether5 name=vlan1000 vlan-id=1000
add interface=ether5 name=vlan1002 vlan-id=1002
add interface=br-AP name=vlan1003 vlan-id=1003
add interface=br-AP name=vlan2000 vlan-id=2000
add interface=br-AP name=vlan2001 vlan-id=2001
add interface=br-AP name=vlan2002 vlan-id=2002
add interface=br-AP name=vlan2003 vlan-id=2003
add interface=ether5 name=vlan2004 vlan-id=2004
add interface=ether5 name=vlan2005 vlan-id=2005
add interface=ether5 name=vlan2006 vlan-id=2006
add interface=ether5 name=vlan2007 vlan-id=2007
add interface=ether5 name=vlan2008 vlan-id=2008
add interface=ether5 name=vlan2009 vlan-id=2009
add interface=ether5 name=vlan2010 vlan-id=2010
add interface=ether5 name=vlan2011 vlan-id=2011
add interface=ether5 name=vlan2012 vlan-id=2012
add interface=ether5 name=vlan2013 vlan-id=2013
add interface=ether5 name=vlan2014 vlan-id=2014
add interface=ether5 name=vlan2015 vlan-id=2015
add interface=ether5 name=vlan2016 vlan-id=2016
add interface=ether5 name=vlan2017 vlan-id=2017
add interface=ether5 name=vlan2018 vlan-id=2018
add interface=ether5 name=vlan2019 vlan-id=2019
add interface=ether5 name=vlan2020 vlan-id=2020
add interface=ether5 name=vlan2021 vlan-id=2021
add interface=ether5 name=vlan2022 vlan-id=2022
add interface=ether5 name=vlan2023 vlan-id=2023
add interface=ether5 name=vlan2024 vlan-id=2024
add interface=ether5 name=vlan2025 vlan-id=2025
add interface=ether5 name=vlan2026 vlan-id=2026
/interface ethernet
set [ find default-name=ether3 ] master-port=ether5
set [ find default-name=ether4 ] master-port=ether5
/interface ethernet switch port
set 4 default-vlan-id=1000 vlan-mode=secure
/ip dhcp-server option
add code=60 name=Option60 value="'Ruckus CPE'"
add code=43 name=Option43 value="0x060ds'173.95.43.134'"
/ip dhcp-server option sets
add name=Ruckus options=Option60,Option43
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
add dns-name=hotspot.addmydevice.com hotspot-address=10.1.50.1 \
    html-directory=flash/hotspot login-by=cookie,http-chap,https name=hsprof1
/ip pool
add name=pool-vlan1003 ranges=10.3.0.10-10.3.1.254
add name=pool-wired ranges=10.4.0.10-10.4.0.254
add name="pool-vlan 1000" ranges=10.0.0.2-10.0.0.254
add name="pool-vlan 1" ranges=10.1.0.2-10.1.0.254
add name="pool-vlan 1002" ranges=10.2.0.2-10.2.0.254
add name="pool-vlan 1003" ranges=10.3.0.2-10.3.0.254
add name=pool-vlan2000 ranges=10.20.0.2-10.20.0.254
add name=pool-vlan2001 ranges=10.21.0.2-10.21.0.254
add name=pool-vlan2002 ranges=10.22.0.2-10.22.0.254
add name=pool-vlan2003 ranges=10.23.0.2-10.23.0.254
add name=pool-vlan2004 ranges=10.24.0.2-10.24.0.254
add name=pool-vlan2005 ranges=10.25.0.2-10.25.0.254
add name=pool-vlan2006 ranges=10.26.0.2-10.26.0.254
add name=pool-vlan2007 ranges=10.27.0.2-10.27.0.254
add name=pool-vlan2008 ranges=10.28.0.2-10.28.0.254
add name=pool-vlan2009 ranges=10.29.0.2-10.29.0.254
add name=pool-vlan2010 ranges=10.30.0.2-10.30.0.254
add name=pool-vlan2011 ranges=10.31.0.2-10.31.0.254
add name=pool-vlan2012 ranges=10.32.0.2-10.32.0.254
add name=pool-vlan2013 ranges=10.33.0.2-10.33.0.254
add name=pool-vlan2014 ranges=10.34.0.2-10.34.0.254
add name=pool-vlan2015 ranges=10.35.0.2-10.35.0.254
add name=pool-vlan2016 ranges=10.36.0.2-10.36.0.254
add name=pool-vlan2017 ranges=10.37.0.2-10.37.0.254
add name=pool-vlan2018 ranges=10.38.0.2-10.38.0.254
add name=pool-vlan2019 ranges=10.39.0.2-10.39.0.254
add name=pool-vlan2020 ranges=10.40.0.2-10.40.0.254
add name=pool-vlan2021 ranges=10.41.0.2-10.41.0.254
add name=pool-vlan2022 ranges=10.42.0.2-10.42.0.254
add name=pool-vlan2023 ranges=10.43.0.2-10.43.0.254
add name=pool-vlan2024 ranges=10.44.0.2-10.44.0.254
add name=pool-vlan2025 ranges=10.45.0.2-10.45.0.254
add name=pool-vlan2026 ranges=10.46.0.2-10.46.0.254
/ip dhcp-server
add address-pool=pool-vlan1003 disabled=no interface=vlan1003 lease-time=12h \
    name=dhcp-vlan1003
add address-pool=pool-wired disabled=no interface=br-Wired lease-time=12h \
    name=dhcp-wired
add address-pool="pool-vlan 1002" disabled=no interface=vlan1002 lease-time=\
    1d name="dhcp-vlan 1002"
add address-pool="pool-vlan 1000" disabled=no interface=vlan1000 lease-time=\
    1d name="dhcp-vlan 1000"
add address-pool=pool-vlan2000 disabled=no interface=vlan2000 lease-time=3d \
    name=dhcp2000
add address-pool=pool-vlan2001 disabled=no interface=vlan2001 lease-time=3d \
    name=dhcp2001
add address-pool=pool-vlan2002 disabled=no interface=vlan2002 lease-time=3d \
    name=dhcp2002
add address-pool=pool-vlan2003 disabled=no interface=vlan2003 lease-time=3d \
    name=dhcp2003
add address-pool=pool-vlan2004 disabled=no interface=vlan2004 lease-time=3d \
    name=dhcp2004
add address-pool=pool-vlan2005 disabled=no interface=vlan2005 lease-time=3d \
    name=dhcp2005
add address-pool=pool-vlan2006 disabled=no interface=vlan2006 lease-time=3d \
    name=dhcp2006
add address-pool=pool-vlan2007 disabled=no interface=vlan2007 lease-time=3d \
    name=dhcp2007
add address-pool=pool-vlan2008 disabled=no interface=vlan2008 lease-time=3d \
    name=dhcp2008
add address-pool=pool-vlan2009 disabled=no interface=vlan2009 lease-time=3d \
    name=dhcp2009
add address-pool=pool-vlan2010 disabled=no interface=vlan2010 lease-time=3d \
    name=dhcp2010
add address-pool=pool-vlan2011 disabled=no interface=vlan2011 lease-time=3d \
    name=dhcp2011
add address-pool=pool-vlan2012 disabled=no interface=vlan2012 lease-time=3d \
    name=dhcp2012
add address-pool=pool-vlan2013 disabled=no interface=vlan2013 lease-time=3d \
    name=dhcp2013
add address-pool=pool-vlan2014 disabled=no interface=vlan2014 lease-time=3d \
    name=dhcp2014
add address-pool=pool-vlan2015 disabled=no interface=vlan2015 lease-time=3d \
    name=dhcp2015
add address-pool=pool-vlan2016 disabled=no interface=vlan2016 lease-time=3d \
    name=dhcp2016
add address-pool=pool-vlan2017 disabled=no interface=vlan2017 lease-time=3d \
    name=dhcp2017
add address-pool=pool-vlan2018 disabled=no interface=vlan2018 lease-time=3d \
    name=dhcp2018
add address-pool=pool-vlan2019 disabled=no interface=vlan2019 lease-time=3d \
    name=dhcp2019
add address-pool=pool-vlan2020 disabled=no interface=vlan2020 lease-time=3d \
    name=dhcp2020
add address-pool=pool-vlan2021 disabled=no interface=vlan2021 lease-time=3d \
    name=dhcp2021
add address-pool=pool-vlan2022 disabled=no interface=vlan2022 lease-time=3d \
    name=dhcp2022
add address-pool=pool-vlan2023 disabled=no interface=vlan2023 lease-time=3d \
    name=dhcp2023
add address-pool=pool-vlan2024 disabled=no interface=vlan2024 lease-time=3d \
    name=dhcp2024
add address-pool=pool-vlan2025 disabled=no interface=vlan2025 lease-time=3d \
    name=dhcp2025
add address-pool=pool-vlan2026 disabled=no interface=vlan2026 lease-time=3d \
    name=dhcp2026
/snmp community
add addresses=::/0 name=RqBpmdRYBUs0Jdb
add addresses=::/0 name=uVfzZZilzotAtUq read-access=no write-access=yes
/interface bridge port
add bridge=br-Wired interface=ether2-master
add bridge=br-AP interface=ether5
/interface ethernet switch vlan
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    1000
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    1002
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    1003
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2000
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2001
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2002
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2003
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2004
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2005
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2006
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2007
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2008
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2009
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2010
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2011
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2012
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2013
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2014
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2015
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2016
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2017
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2018
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2019
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2020
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2021
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2022
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2023
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2024
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2025
add independent-learning=yes ports=ether5,switch1-cpu switch=switch1 vlan-id=\
    2026
/ip address
add address=10.2.0.1/24 interface=br-AP network=10.2.0.0
add address=10.3.0.1/23 interface=vlan1003 network=10.3.0.0
add address=10.4.0.1/24 interface=br-Wired network=10.4.0.0
add address=10.0.0.1/24 interface=vlan1000 network=10.0.0.0
add address=10.2.0.1/24 interface=vlan1002 network=10.2.0.0
add address=10.1.0.1/24 interface=ether2-master network=10.1.0.0
add address=10.20.0.1/24 interface=vlan2000 network=10.20.0.0
add address=10.21.0.1/24 interface=vlan2001 network=10.21.0.0
add address=10.22.0.1/24 interface=vlan2002 network=10.22.0.0
add address=10.23.0.1/24 interface=vlan2003 network=10.23.0.0
add address=10.24.0.1/24 interface=vlan2004 network=10.24.0.0
add address=10.25.0.1/24 interface=vlan2005 network=10.25.0.0
add address=10.26.0.1/24 interface=vlan2006 network=10.26.0.0
add address=10.27.0.1/24 interface=vlan2007 network=10.27.0.0
add address=10.28.0.1/24 interface=vlan2008 network=10.28.0.0
add address=10.29.0.1/24 interface=vlan2009 network=10.29.0.0
add address=10.30.0.1/24 interface=vlan2010 network=10.30.0.0
add address=10.31.0.1/24 interface=vlan2011 network=10.31.0.0
add address=10.32.0.1/24 interface=vlan2012 network=10.32.0.0
add address=10.33.0.1/24 interface=vlan2013 network=10.33.0.0
add address=10.34.0.1/24 interface=vlan2014 network=10.34.0.0
add address=10.35.0.1/24 interface=vlan2015 network=10.35.0.0
add address=10.36.0.1/24 interface=vlan2016 network=10.36.0.0
add address=10.37.0.1/24 interface=vlan2017 network=10.37.0.0
add address=10.38.0.1/24 interface=vlan2018 network=10.38.0.0
add address=10.39.0.1/24 interface=vlan2019 network=10.39.0.0
add address=10.40.0.1/24 interface=vlan2020 network=10.40.0.0
add address=10.41.0.1/24 interface=vlan2021 network=10.41.0.0
add address=10.42.0.1/24 interface=vlan2022 network=10.42.0.0
add address=10.43.0.1/24 interface=vlan2023 network=10.43.0.0
add address=10.44.0.1/24 interface=vlan2024 network=10.44.0.0
add address=10.45.0.1/24 interface=vlan2025 network=10.45.0.0
add address=10.46.0.1/24 interface=vlan2026 network=10.46.0.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=\
    ether1-WAN
/ip dhcp-server network
add address=10.0.0.0/24 gateway=10.0.0.1
add address=10.1.0.0/24 gateway=10.1.0.1
add address=10.2.0.0/24 dhcp-option=Option43,Option60 gateway=10.2.0.1
add address=10.3.0.0/23 gateway=10.3.0.1
add address=10.4.0.0/24 gateway=10.4.0.1
add address=10.20.0.0/24 gateway=10.20.0.1
add address=10.21.0.0/24 gateway=10.21.0.1
add address=10.22.0.0/24 gateway=10.22.0.1
add address=10.23.0.0/24 gateway=10.23.0.1
add address=10.24.0.0/24 gateway=10.24.0.1
add address=10.25.0.0/24 gateway=10.25.0.1
add address=10.26.0.0/24 gateway=10.26.0.1
add address=10.27.0.0/24 gateway=10.27.0.1
add address=10.28.0.0/24 gateway=10.28.0.1
add address=10.29.0.0/24 gateway=10.29.0.1
add address=10.30.0.0/24 gateway=10.30.0.1
add address=10.31.0.0/24 gateway=10.31.0.1
add address=10.32.0.0/24 gateway=10.32.0.1
add address=10.33.0.0/24 gateway=10.33.0.1
add address=10.34.0.0/24 gateway=10.34.0.1
add address=10.35.0.0/24 gateway=10.35.0.1
add address=10.36.0.0/24 gateway=10.36.0.1
add address=10.37.0.0/24 gateway=10.37.0.1
add address=10.38.0.0/24 gateway=10.38.0.1
add address=10.39.0.0/24 gateway=10.39.0.1
add address=10.40.0.0/24 gateway=10.40.0.1
add address=10.41.0.0/24 gateway=10.41.0.1
add address=10.42.0.0/24 gateway=10.42.0.1
add address=10.43.0.0/24 gateway=10.43.0.1
add address=10.44.0.0/24 gateway=10.44.0.1
add address=10.45.0.0/24 gateway=10.45.0.1
add address=10.46.0.0/24 gateway=10.46.0.1
/ip dns
set servers=216.146.35.35,205.171.2.65,4.2.2.4
/ip dns static
add address=10.10.10.1 name=router
/ip firewall address-list
add address=199.89.56.32/28 comment=CCI list=RemoteManagement
/ip firewall filter
add action=accept chain=input comment="allow webfig" dst-port=80 \
    in-interface=ether1-WAN protocol=tcp src-address-list=RemoteManagement
add action=accept chain=input comment="allow winbox" dst-port=8291 \
    in-interface=ether1-WAN protocol=tcp src-address-list=RemoteManagement
add action=accept chain=input comment="allow ftp" dst-port=21 in-interface=\
    ether1-WAN protocol=tcp src-address-list=RemoteManagement
add action=accept chain=input comment="allow snmp" dst-port=161 in-interface=\
    ether1-WAN protocol=tcp src-address-list=RemoteManagement
add action=accept chain=input comment="allow api" dst-port=8728 in-interface=\
    ether1-WAN protocol=tcp src-address-list=RemoteManagement
add action=accept chain=input comment="accept ICMP" protocol=icmp \
    src-address-list=RemoteManagement
add action=drop chain=forward comment="deny intervlan traffic" in-interface=\
    !ether1-WAN out-interface=all-vlan
add action=accept chain=input comment="accept established,related" \
    connection-state=established,related
add action=fasttrack-connection chain=forward comment=fasttrack \
    connection-state=established,related
add action=accept chain=forward comment="accept established,related" \
    connection-state=established,related
add action=drop chain=input comment="drop all management from WAN" \
    in-interface=ether1-WAN protocol=tcp
add action=drop chain=forward comment="drop invalid packets" \
    connection-state=invalid
add action=drop chain=forward comment="drop all from WAN not DSTNATed" \
    connection-nat-state=!dstnat connection-state=new in-interface=ether1-WAN
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    out-interface=ether1-WAN
add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    src-address=10.1.50.0/24
add action=dst-nat chain=dstnat dst-port=20001 in-interface=ether1-WAN \
    protocol=tcp src-address-list=RemoteManagement to-addresses=10.2.0.252 to-ports=\
    22
add action=dst-nat chain=dstnat dst-port=20002 in-interface=ether1-WAN \
    protocol=tcp src-address-list=RemoteManagement to-addresses=10.2.0.250 to-ports=\
    22
add action=dst-nat chain=dstnat dst-port=20003 in-interface=ether1-WAN \
    protocol=tcp src-address-list=RemoteManagement to-addresses=10.2.0.254 to-ports=\
    22
add action=dst-nat chain=dstnat dst-port=20004 in-interface=ether1-WAN \
    protocol=tcp src-address-list=RemoteManagement to-addresses=10.2.0.253 to-ports=\
    22
add action=dst-nat chain=dstnat dst-port=20005 in-interface=ether1-WAN \
    protocol=tcp src-address-list=RemoteManagement to-addresses=10.2.0.2 to-ports=22
/snmp
set enabled=yes
/system clock
set time-zone-name=America/New_York
/system ntp client
set enabled=yes server-dns-names=time.nist.gov,pool.ntp.org
You do not have the required permissions to view the files attached to this post.
 
User avatar
cdiedrich
Forum Veteran
Forum Veteran
Posts: 817
Joined: Thu Feb 13, 2014 2:03 pm
Location: Basel, Switzerland // Bremen, Germany
Contact:

Re: Multiple Entries for same IPs in ARP table?  [SOLVED]

Wed May 15, 2019 5:59 pm

You have the same IP range (10.20.0/24) in br-AP and vlan1002.
-Chris
Christopher Diedrich
MTCNA, MTCUME, MTCWE
Basel, Switzerland
Bremen, Germany

There are 10 types of people: Those who understand binary and those who don't.
There are two types of people: Those who can extrapolate from incomplete data
 
Zetera
newbie
Topic Author
Posts: 41
Joined: Sat Apr 21, 2018 6:57 pm

Re: Multiple Entries for same IPs in ARP table?

Wed May 15, 2019 7:52 pm

That certainly was it... Wish I noticed that sooner. Thanks!

Who is online

Users browsing this forum: Bing [Bot] and 23 guests