Community discussions

 
leonardomodesto
just joined
Topic Author
Posts: 1
Joined: Fri Jun 07, 2019 5:18 pm

Begginer help - Remote access

Fri Jun 07, 2019 5:39 pm

What's up people, recently i configured a RB 750 on my workplace and everything seems fine but one problem is making me wonder what's wrong with my routing. I have two internet connections and an application server running on my network. I did the pcc and a failover configuration and everything is ok, but i can't access my router and my server throught both connections. Some clients can access the server through my primary link just fine but others cannot and i can only access my mikrotik for my secondary internet connection. Anyone can help me see what's wrong here?

/interface bridge
add comment="PONTE - PORTA 4 E 5" name=Ponte
/interface ethernet
set [ find default-name=ether1 ] comment="LINK 1 - VITOR" speed=100Mbps
set [ find default-name=ether2 ] comment="LINK 2 LIVE TIM" speed=100Mbps
set [ find default-name=ether3 ] comment="Entrada Link 3 Vazio" speed=100Mbps
set [ find default-name=ether4 ] comment="REDE INTERNA - SWITCH" speed=\
100Mbps
set [ find default-name=ether5 ] comment="REDE INTERNA -SWITCH P5" speed=\
100Mbps
/interface bridge port
add bridge=Ponte hw=no interface=ether4
add bridge=Ponte hw=no interface=ether5

/ip address
add address=10.0.0.254/24 comment="ENDERE\C7O RB" interface=ether4 network=\
10.0.0.0
add address=191.6.164.166/23 comment="LINK VITOR - PORTA 1" interface=ether1 \
network=191.6.164.0

/ip dhcp-server lease
add address=10.0.0.11 comment="SERVIDOR DCATIV" mac-address=F0:4D:A2:E0:5A:48

/ip firewall mangle
add action=accept chain=prerouting comment="Bypass REDE INTERNA" dst-address=\
10.0.0.0/24 src-address=10.0.0.0/24
add action=mark-connection chain=prerouting comment="Entrada Conexao Link 1" \
in-interface=ether1 new-connection-mark=Link1-Conexao passthrough=yes
add action=mark-connection chain=prerouting comment="Entrada Conexao Link 2" \
in-interface=ether2 new-connection-mark=Link2-Conexao passthrough=yes
add action=mark-connection chain=prerouting comment=\
"PCC MARCA CONEX\C3O LINK 2 - 8/0" dst-address-type=!local in-interface=\
Ponte new-connection-mark=Link2-Conexao passthrough=yes \
per-connection-classifier=both-addresses:8/0
add action=mark-connection chain=prerouting comment=\
"PCC MARCA CONEX\C3O LINK 2 - 8/1" dst-address-type=!local in-interface=\
Ponte new-connection-mark=Link2-Conexao passthrough=yes \
per-connection-classifier=both-addresses:8/1
add action=mark-connection chain=prerouting comment=\
"PCC MARCA CONEX\C3O LINK 2 - 8/2" dst-address-type=!local in-interface=\
Ponte new-connection-mark=Link2-Conexao passthrough=yes \
per-connection-classifier=both-addresses:8/2
add action=mark-connection chain=prerouting comment=\
"PCC MARCA CONEX\C3O LINK 2 - 8/3" dst-address-type=!local in-interface=\
Ponte new-connection-mark=Link2-Conexao passthrough=yes \
per-connection-classifier=both-addresses:8/3
add action=mark-connection chain=prerouting comment=\
"PCC MARCA CONEX\C3O LINK 2 - 8/4" dst-address-type=!local in-interface=\
Ponte new-connection-mark=Link2-Conexao passthrough=yes \
per-connection-classifier=both-addresses:8/4
add action=mark-connection chain=prerouting comment=\
"PCC MARCA CONEX\C3O LINK 1 - 8/5" dst-address-type=!local in-interface=\
Ponte new-connection-mark=Link1-Conexao passthrough=yes \
per-connection-classifier=both-addresses:8/5
add action=mark-connection chain=prerouting comment=\
"PCC MARCA CONEX\C3O LINK 1 - 8/6" dst-address-type=!local in-interface=\
Ponte new-connection-mark=Link1-Conexao passthrough=yes \
per-connection-classifier=both-addresses:8/6
add action=mark-connection chain=prerouting comment=\
"PCC MARCA CONEX\C3O LINK 1 - 8/7" dst-address-type=!local in-interface=\
Ponte new-connection-mark=Link1-Conexao passthrough=yes \
per-connection-classifier=both-addresses:8/7
add action=mark-routing chain=output comment="Saida Conexao Link 1" \
connection-mark=Link1-Conexao new-routing-mark=Link1-Rota passthrough=yes
add action=mark-routing chain=output comment="Saida Conexao Link 2" \
connection-mark=Link2-Conexao new-routing-mark=Link2-Rota passthrough=yes
add action=mark-routing chain=prerouting comment="PCC MARCA ROTA - LINK 1" \
connection-mark=Link1-Conexao in-interface=Ponte new-routing-mark=\
Link1-Rota passthrough=yes src-address-list=""
add action=mark-routing chain=prerouting comment="PCC MARCA ROTA - LINK 2" \
connection-mark=Link2-Conexao in-interface=Ponte new-routing-mark=\
Link2-Rota passthrough=yes src-address-list=""
add action=mark-routing chain=prerouting comment=\

/ip firewall nat
add action=masquerade chain=srcnat comment="NAT Link 1 - Vitor" \
out-interface=ether1 src-address=10.0.0.0/24
add action=masquerade chain=srcnat comment="NAT Link 2 - Live Tim" \
out-interface=ether2 src-address=10.0.0.0/24
add action=dst-nat chain=dstnat comment="PORTA SERVIDOR LINK 2" dst-port=1500 \
in-interface=ether2 protocol=tcp to-addresses=10.0.0.11 to-ports=1500
add action=dst-nat chain=dstnat comment="PORTA SERVIDOR LINK 1" dst-port=1500 \
in-interface=ether1 protocol=tcp to-addresses=10.0.0.11 to-ports=1500

/ip route
add comment="ROTA LINK 1 - PCC" distance=2 gateway=1.1.1.1 routing-mark=\
Link1-Rota
add comment="ROTA LINK 2 - PCC" distance=1 gateway=208.67.222.222 \
routing-mark=Link2-Rota
add check-gateway=ping comment="ROTA LINK 2 - LIVE TIM" distance=1 gateway=\
208.67.222.222
add check-gateway=ping comment="ROTA LINK 1 - VITOR" distance=2 gateway=\
1.1.1.1
add comment="Monitoramento LINK 1" distance=2 dst-address=1.1.1.1/32 gateway=\
191.6.164.161 scope=10
add comment="Monitoramento LINK 2" distance=1 dst-address=208.67.222.222/32 \
gateway=192.168.1.1 scope=10

Who is online

Users browsing this forum: No registered users and 28 guests