Community discussions

 
christoph1990
just joined
Topic Author
Posts: 2
Joined: Tue Jun 11, 2019 11:11 am

Mikrotik VPN Connection

Tue Jun 11, 2019 11:13 am

Hello,

I am pretty new to MikroTik and am trying to build a connection between 2 Routers over VPN.
I want to use PPP and l2tp Protocol. But cant seem to figure out what the problem is.
I configured everything according to a friend of mine who has it already setup and the only result i gain is the ping of winbox tells me i have a bad interface.
Which i cannot relate.
What could "bad Interface" mean ?

Dearest regards,
Christoph
 
christoph1990
just joined
Topic Author
Posts: 2
Joined: Tue Jun 11, 2019 11:11 am

Re: Mikrotik VPN Connection

Wed Jun 12, 2019 9:16 am

!update
 
WeWiNet
Member Candidate
Member Candidate
Posts: 159
Joined: Thu Sep 27, 2018 4:11 pm

Re: Mikrotik VPN Connection

Wed Jun 12, 2019 10:43 am

No need to update the topic,
rather add useful information like provide your config without sensitive info, system diagram etc.
WeWiNet

**
MTCNA
hapac2, map, hap-lite, ltap-mini, RB4011 :-) !!!
 
User avatar
ingdaka
Member Candidate
Member Candidate
Posts: 165
Joined: Thu Aug 30, 2012 3:06 pm
Location: Albania
Contact:

Re: Mikrotik VPN Connection

Wed Jun 12, 2019 11:38 pm

Please post your configurations here! And see what happen!
Ilir Daka
Electronic & Network Engineer
E-mail: ilirdaka@live.com
Mob: +355692982151
WhatsApp: +355692982151
Mikrotik Official Consultant
CCNA | Fortinet NSE3 | MTCRE | MTCSE
 
plisken
Forum Guru
Forum Guru
Posts: 2421
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Mikrotik VPN Connection

Thu Jun 13, 2019 9:44 pm

Hello, go to "new terminal" and type "export" copy and paste this code into this window on this forum.
Before you do that remove passwords and other sensitive data.
In this way we can view the configuration and possibly correct it.
 
AidanAus
newbie
Posts: 25
Joined: Wed May 08, 2019 7:35 am

Re: Mikrotik VPN Connection

Fri Jun 14, 2019 10:10 am

You can find the basic config for a l2tp server, mikrotik client and widows client below, you can put the IP address of the local and remote side in either the profile the secret is using or in the secret. A good idea would be to have a profile with one local address put in it then in the remote address you can put a pool in but doing what is in below is fine for just setting this up and playing around with it.
Also setting IPsec to required means that all clients have to use it, this isnt an isue for windows clients as they have to use IPsec if they are using the inbuilt vpn client but the Mikrotik doesnt have to. If you want to use both ipsec and non ipsec encrypted l2tp you would set the use-ipsec to required.


For the mikrotik:
/interface l2tp-server server
set enabled=yes ipsec-secret=Password1 use-ipsec=required default-profile=default-encryption
/ppp secret
add name=test password=Password2 add local-address=192.168.50.1 remote-address=192.168.40.1


For the windows client:
VPN provider= windows built in
connection name =(what ever you would like to name it)
Server name or address= (IP address of the router you applyed the configuration on, please ping this address to make sure it is reachable)
VPN type= L2TP/IPsec with pre-shared key
Pre-shared key = Password1
type of sign in info = username and password
username = test
password = Password2

for mikrotik client:
/interface l2tp-client
add connect-to=(IP address of the router you applyed the configuration on, please ping this address to make sure it is reachable) disabled=no ipsec-secret=Password1 name=l2tp-out1 \
password=Password2 use-ipsec=yes user=test
 
plisken
Forum Guru
Forum Guru
Posts: 2421
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Mikrotik VPN Connection

Tue Jun 25, 2019 2:53 pm

CAUTION! This webpages are not safe
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: No registered users and 17 guests