Community discussions

 
mahumada
just joined
Topic Author
Posts: 4
Joined: Fri Feb 22, 2019 6:49 pm

Simulation two WAN with one ISP

Wed Jun 26, 2019 5:06 pm

How can I do a simulation of two WANs with different GWs if I have a single ISP in order to be able to practice load balancing?
Thank you.
You do not have the required permissions to view the files attached to this post.
 
2frogs
Long time Member
Long time Member
Posts: 540
Joined: Fri Dec 03, 2010 1:38 am

Re: Simulation two WAN with one ISP

Thu Jun 27, 2019 7:25 am

Use Virtual Machine software (I use VirtualBox) to setup 2 Virtual CHR's. You need 2 virtual ethernet interfaces for each. They need minimal setup:
##Gateway1
/ip address
add address=192.168.100.1/24 interface=ether2 network=192.168.100.0
/ip dhcp-client
add disabled=no interface=ether1
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1

##Gateway2
/ip address
add address=192.168.200.1/24 interface=ether2 network=192.168.200.0
/ip dhcp-client
add disabled=no interface=ether1
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
And now on your Real Router add:
/ip address
add address=192.168.100.2/24 interface=bridge1 network=192.168.100.0
add address=192.168.200.2/24 interface=bridge1 network=192.168.200.0
Now you can use 192.168.100.1 & 192.168.200.1 as your gateways in the tutorials. Example:
/ip route
add check-gateway=ping distance=1 gateway=192.168.100.1 routing-mark=GW1
add check-gateway=ping distance=1 gateway=192.168.200.1 routing-mark=GW2
 
User avatar
ingdaka
Member Candidate
Member Candidate
Posts: 183
Joined: Thu Aug 30, 2012 3:06 pm
Location: Albania
Contact:

Re: Simulation two WAN with one ISP

Fri Jun 28, 2019 10:32 pm

If you have 2 different gateways is one situation, if you have only 1 gateway you need L2 loadbalancing with is via portchannel
Ilir Daka
Electronic & Network Engineer
E-mail: ilirdaka@live.com
Mob: +355692982151
WhatsApp: +355692982151
Mikrotik Official Consultant
CCNA | Fortinet NSE3 | MTCRE | MTCSE
 
stoser
Member Candidate
Member Candidate
Posts: 107
Joined: Sun Aug 21, 2016 12:04 am

Re: Simulation two WAN with one ISP

Mon Jul 01, 2019 4:59 am

If all you want to do is simulate and view the traffic going out two different interfaces, you can probably use the

IP%interface

notation for the gateway values in the routing rules. So if your ISP LAN gateway is 192.168.0.1, and your WAN1 interface name is "ether1", and your WAN2 interface name is "ether2" use

192.168.0.1%ether1 for the gateway value in your routing rule for WAN1, with the corresponding routing mark and
192.168.0.1%ether2 for the gateway value in your routing rule for WAN2, with the corresponding routing mark
 
samwoodblack
just joined
Posts: 2
Joined: Fri Jul 12, 2019 4:41 pm
Location: London

Re: Simulation two WAN with one ISP

Fri Jul 12, 2019 4:49 pm

I think that idea with virual machine is the best.
My latest comparison. Writing articles about technology and gadgets.

Who is online

Users browsing this forum: MSN [Bot] and 35 guests