Community discussions

 
mshahid85
newbie
Topic Author
Posts: 26
Joined: Thu Mar 01, 2018 12:19 pm

Block Youtube but not with gmail

Thu Jul 11, 2019 12:24 pm

Hi,

i have hex lite router, i want to block youtube in my LAN but gmail block also with it. please tell me how to block only youtube without blocking google and gmail.

Thanks..
mshahid85
 
User avatar
ingdaka
Member Candidate
Member Candidate
Posts: 165
Joined: Thu Aug 30, 2012 3:06 pm
Location: Albania
Contact:

Re: Block Youtube but not with gmail

Thu Jul 11, 2019 12:44 pm

Ilir Daka
Electronic & Network Engineer
E-mail: ilirdaka@live.com
Mob: +355692982151
WhatsApp: +355692982151
Mikrotik Official Consultant
CCNA | Fortinet NSE3 | MTCRE | MTCSE
 
evince
Member
Member
Posts: 306
Joined: Thu Jul 05, 2012 12:11 pm
Location: Weiswampach - Luxemburg
Contact:

Re: Block Youtube but not with gmail

Thu Jul 11, 2019 12:53 pm

No, do not use L7, but TLS Host.

/ip firewall filter
add action=reject chain=forward comment="block youtube" protocol=tcp reject-with=icmp-network-unreachable tls-host=*youtube*
 
mshahid85
newbie
Topic Author
Posts: 26
Joined: Thu Mar 01, 2018 12:19 pm

Re: Block Youtube but not with gmail

Mon Jul 15, 2019 8:48 am

Both are not working................. any other solution????
 
User avatar
nichky
Long time Member
Long time Member
Posts: 526
Joined: Tue Jun 23, 2015 2:35 pm

Re: Block Youtube but not with gmail

Mon Jul 15, 2019 1:07 pm

try Content instead of TLS-Host
Last edited by nichky on Mon Jul 15, 2019 1:37 pm, edited 1 time in total.
Nikola Suminoski
MikroTik Consultan
MTCRE l MTCWE

!) Safe Mode is your friend;
 
evince
Member
Member
Posts: 306
Joined: Thu Jul 05, 2012 12:11 pm
Location: Weiswampach - Luxemburg
Contact:

Re: Block Youtube but not with gmail

Mon Jul 15, 2019 1:28 pm

TLS is working, i do use it @ work. Where did you place your rule? do you have matching?
 
User avatar
nichky
Long time Member
Long time Member
Posts: 526
Joined: Tue Jun 23, 2015 2:35 pm

Re: Block Youtube but not with gmail

Mon Jul 15, 2019 1:38 pm

youtube.com or *.youtube.com or *youtube*
Nikola Suminoski
MikroTik Consultan
MTCRE l MTCWE

!) Safe Mode is your friend;
 
mshahid85
newbie
Topic Author
Posts: 26
Joined: Thu Mar 01, 2018 12:19 pm

Re: Block Youtube but not with gmail

Mon Jul 15, 2019 4:10 pm

/ip firewall filter
add action=reject chain=forward comment="block youtube" protocol=tcp reject-with=icmp-network-unreachable tls-host=*youtube*

i copied and paste on my router, but youtube is still working on my PC.........
 
4hadsunny
just joined
Posts: 1
Joined: Sun Jul 14, 2019 9:09 am

Re: Block Youtube but not with gmail

Mon Jul 15, 2019 7:38 pm

/ip firewall filter add chain=forward dst-port=443 protocol=tcp tls-host=*.youtube.com action=reject
Farhad Hosen Sunny
(MTCNA,MTCRE)
 
ChristopherFS
just joined
Posts: 6
Joined: Sun Jul 14, 2019 5:50 pm

Re: Block Youtube but not with gmail

Mon Jul 15, 2019 8:00 pm

Maybe fasttrack is active. Perhaps is need to disable fast track to the firewall review the packet again.
 
User avatar
ingdaka
Member Candidate
Member Candidate
Posts: 165
Joined: Thu Aug 30, 2012 3:06 pm
Location: Albania
Contact:

Re: Block Youtube but not with gmail

Mon Jul 15, 2019 8:14 pm

Put new created rules on top of firewall list!
Ilir Daka
Electronic & Network Engineer
E-mail: ilirdaka@live.com
Mob: +355692982151
WhatsApp: +355692982151
Mikrotik Official Consultant
CCNA | Fortinet NSE3 | MTCRE | MTCSE
 
td32
Frequent Visitor
Frequent Visitor
Posts: 88
Joined: Fri Nov 18, 2016 5:55 am

Re: Block Youtube but not with gmail

Mon Jul 15, 2019 9:22 pm

wouldn't a simple dns block work for this case, redirect all dns port 53 requests to your local dns resolver(in case they use any third party dns) and set a static dns to 0.0.0.0 for youtube.com

Who is online

Users browsing this forum: No registered users and 36 guests