Community discussions

 
EvgeniyOsipov
just joined
Topic Author
Posts: 2
Joined: Thu Feb 28, 2019 6:49 pm

2 ISP + L2TP/IPsec

Sat Jul 27, 2019 8:54 pm

Hello,
On mikrotik I have two ISP (dhcp client (main) and ppoe(reserve)) and configured l2tp/ipsec server.
Everything works good, except one thing - when I manually changing to second ISP (reserved channel) for one PC through mangle rule, then can't reach (ping, rdp, etc) this PC from VPN client (outside LAN). But can reach another PCs as usual.
How orginize routes or mangle rules for VPN clients for reaching LAN PCs (ping, rdp, vnc, like in regular LAN) despite the changes of ISP?
Thank you for any advice.
 
User avatar
cdiedrich
Forum Veteran
Forum Veteran
Posts: 896
Joined: Thu Feb 13, 2014 2:03 pm
Location: Basel, Switzerland // Bremen, Germany
Contact:

Re: 2 ISP + L2TP/IPsec

Wed Jul 31, 2019 2:00 pm

I guess you add routing marks for this PC, correct?
You'll need to add a route to this PC with its new routing mark to work.
like:
/ip route add dst-address=192.168.88.22 gateway=bridge routing-mark=myWan2-mark
Edit:
And probably (if even not more likely) a route to the vpn client with that routing mark. This can be accomplished with static addresses in the ppp client definition and a static l2tp server binding.

-Chris
Christopher Diedrich
MTCNA, MTCUME, MTCWE
Basel, Switzerland
Bremen, Germany

There are 10 types of people: Those who understand binary and those who don't.
There are two types of people: Those who can extrapolate from incomplete data
 
EvgeniyOsipov
just joined
Topic Author
Posts: 2
Joined: Thu Feb 28, 2019 6:49 pm

Re: 2 ISP + L2TP/IPsec

Fri Aug 02, 2019 11:05 am

I guess you add routing marks for this PC, correct?
You'll need to add a route to this PC with its new routing mark to work.
like:
/ip route add dst-address=192.168.88.22 gateway=bridge routing-mark=myWan2-mark
Edit:
And probably (if even not more likely) a route to the vpn client with that routing mark. This can be accomplished with static addresses in the ppp client definition and a static l2tp server binding.

-Chris
Hello, thank you for answer!
Please see https://1drv.ms/u/s!AkiJ7dh7F4kUhIlxBvFCFnYktEJujg, I can't make it work through Routes.

Who is online

Users browsing this forum: Bing [Bot] and 27 guests