Community discussions

 
rbuserdl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 87
Joined: Thu Mar 22, 2018 1:53 pm

Basic questions about Queues

Thu Aug 01, 2019 12:02 am

Hello,

I have the following settings in queue tree:
/queue tree
add max-limit=9500k name=Level1_dw parent=vlan2-voip queue=default
add name=VoIP_dw packet-mark=VoIP parent=Level1_dw priority=1

add max-limit=9500k name=Level1_up parent=wan1
add name=VoIP_up packet-mark=VoIP parent=Level1_up priority=1

add max-limit=9500k name=Level2_dw parent=lan queue=default
add name=Other_dw packet-mark=LessPriority parent=Level2_dw priority=2

add max-limit=9500k name=Level2_up parent=wan1 queue=default
add name=Other_up packet-mark=LessPriority parent=Level2_up priority=2

add max-limit=9500k name=Level3_dw parent=lan queue=pcq-download-default
add name=WiFi_dw packet-mark=WiFi parent=Level3_dw priority=2

add max-limit=9500k name=Level3_up parent=wan1 queue=pcq-upload-default
add name=Wifi_up packet-mark=WiFi parent=Level3_up priority=2 queue=pcq-upload-default
I changed some names to english to be more clear.
I would want to use "limit-at" instead of "max-limit", to ensure a minimum bandwidth to voip traffic, I can do this directly or do I need to set all queues in the same parent? I mean: does "limit-at" work although it is the only queue with the same parent?

I forget the second question, will ask it later :p

Thanks in advance.
Regards
Damián
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1790
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: Basic questions about Queues  [SOLVED]

Thu Aug 01, 2019 11:58 pm

Hey

"Limit-at" of a queue is always respected (even if it doesn't make sense). So yes you can use it to guarantee assignment, but be careful wrt total bandwidth available.

"CIR (Committed Information Rate) – (limit-at in RouterOS) worst case scenario, flow will get this amount of traffic rate regardless of other traffic flows. At any given time, the bandwidth should not fall below this committed rate."
See https://wiki.mikrotik.com/wiki/Manual:Queue
 
rbuserdl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 87
Joined: Thu Mar 22, 2018 1:53 pm

Re: Basic questions about Queues

Fri Aug 02, 2019 6:01 pm

Thank you Sebastia!!!

What do you mean with
"At any given time, the bandwidth should not fall below this committed rate"
?
For example, if I set 1 Mbps to voip traffic, what happen when the total bandwidth consuming of voip is about 50 Kbps (25 Kbps from one IP and the other half from another IP) ?
The manual says:
limit-at (NUMBER/NUMBER) : normal upload/download data rate that is guaranteed to a target
I wanted to accomplish the following scenario:
- I have 10 Mbps in WAN1
- I want to warantee a min bandwith to voip traffic, to never have problems with the calls (For example, 1 Mbps)
- So I want to limit the other traffic to 9 Mbps, without using the max-limit option, because sometimes the total bandwidth changes and I will need to change max-limit allways
Can I accomplish this scenario?

Thanks in advance.
Regards,
Damián
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1790
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: Basic questions about Queues

Sat Aug 03, 2019 2:35 pm

At any given time, the bandwidth should not fall below this committed rate
That's from manual, not mine. What I think is meant: the total bandwidth of the interface should be at least the sum of "limit-at" see examples here https://wiki.mikrotik.com/wiki/Manual:HTB

if you reserve 1M (limit-at) but only use 50k, the remainder will be available to parent and can be borrowed by other queues.

What you're looking for is dynamic limit, and at this time Mikrotik doesn't offer anything for this out-of-the-box.
 
rbuserdl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 87
Joined: Thu Mar 22, 2018 1:53 pm

Re: Basic questions about Queues

Tue Aug 06, 2019 4:36 pm

Thanks Sebastia!!!

This is the article which I was looking for, before I posted
Anyway, all examples in this article has 1 parent and all queues depends on this parent queue (Queue01 on the examples)
I think I will test this with the current settings, just setting CIR instead of MIR, if this does not work, I will think another structure, maybe one parent queue for each affected interface

Regards,
Damián
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1790
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: Basic questions about Queues

Wed Aug 07, 2019 3:49 pm

For queues to make sense you need to have a global maximum, if there is non, each subqueue can borrow without limit, and there won't be any prioritisation.

such queue tree needs to be attached to independent interface, ex wan, lan. This can be "naked" interface, etherX, or a bridge grouping some interfaces

Who is online

Users browsing this forum: Google [Bot] and 43 guests