Community discussions

 
mikusk
just joined
Topic Author
Posts: 11
Joined: Thu Aug 01, 2019 8:20 pm

wifi speed - 2 clients only

Thu Aug 08, 2019 8:39 pm

Hi,

I have hAP lite where ether3 is connected to computer with samba share when I connect second computer to ether2 and try copy there is almost cable speed close to 100 Mbps.
I configured WIFI to allow maximum MCS7 - which is 65 / 72 MBps - 1 stream only
ht-supported-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7
ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7
When I connect 1 client mobil or PC all looks good PC is constantly on 72 Mbps and mobil bouncing between 72 and 65 and real transfer speed was around 40 Mbps for Mobil and 60 Mbps for Notebook

Mobil - https://drive.google.com/file/d/1uXWJur ... sp=sharing
Notebook - https://drive.google.com/file/d/1TEiQft ... sp=sharing

Then I tried both mobile + notebook at the same time. I was awaiting than total speed will be 65 + 65 or 72 + 72 as hAP lite has 2 streams and real transfer speed will be close to 100 Mbps, but real speed was even worse 40 - 50 Mbps so it looks like 25 per client :-(

Both clients - https://drive.google.com/file/d/1X5cx6I ... sp=sharing

am I doing something wrong or is this normal ? I know that hAP lite is quite cheap but WIFI specification is 2 streams which is 144 Mbps for 20MHz I was awaiting that I can achieve something close to ethernet speed when 2 clients are connected to WiFi and each using just one stream ... I am on very clear 6 channel.

My config:
/interface bridge
add admin-mac=74:4D:28:0F:CF:64 auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-g/n basic-rates-a/g=12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps basic-rates-b="" disabled=no distance=\
    indoors frequency=2437 ht-supported-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 mode=ap-bridge rate-set=configured ssid=\
    MikroTik-0FCF68 supported-rates-a/g=12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b="" wireless-protocol=802.11 wps-mode=\
    disabled
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=wlan1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=192.168.88.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new \
    in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
/ip ssh
set allow-none-crypto=yes forwarding-enabled=remote
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
Thanks for any help explanation ..
MK
 
2frogs
Long time Member
Long time Member
Posts: 540
Joined: Fri Dec 03, 2010 1:38 am

Re: wifi speed - 2 clients only

Thu Aug 08, 2019 9:10 pm

What you are seeing is normal. The data rate is the combined theoretically possible rate for upload and download. Since the AP and Client can only send or receive and do so to a single device at a time it will half the data rate. And as you noticed, if you connect a second device and try to download/upload at same time, it gets halved again. The more streams the device is capable the higher the over all throughput, but your throughput will still be about half the data rate and divided between each active user.
 
mikusk
just joined
Topic Author
Posts: 11
Joined: Thu Aug 01, 2019 8:20 pm

Re: wifi speed - 2 clients only

Thu Aug 08, 2019 11:43 pm

Thanks for explanation. I was thinking that If I have 2 spatial streams there will be one for each client 144 / 2 = 72.

It looks like 2nd spatial stream is not used at all :-(

May be that spatial stream can be used only towards one clients ...

In laptop there is Intel AC 7260 which is 2x2 so It should connect with 144

I will change my settings to allow use 2 spatial streams and will see if I got better results.

Thanks and regards,
MK


Sent from my SM-J530F using Tapatalk

Who is online

Users browsing this forum: No registered users and 30 guests