Community discussions

 
misucatinas
just joined
Topic Author
Posts: 24
Joined: Thu Mar 01, 2018 9:11 am

Using VPN for only RDP (3389)

Mon Aug 12, 2019 4:32 pm

Hi, many company have router mikrotik for VPN to acces at home to company`s server. I want to configure to access only rdp, not on sharing (\\fileserver) or any access of network.
How to configure to limit access?
Thank you.
 
User avatar
Exiver
Member Candidate
Member Candidate
Posts: 110
Joined: Sat Jan 10, 2015 6:45 pm
Location: Germany

Re: Using VPN for only RDP (3389)

Mon Aug 12, 2019 4:36 pm

You should go with the ip-firewall configuration under /ip firewall filter. Best way is to block everything and allow only protocols and ports you want to be accessed. That means you can filter everything except clients source-address to your RDP servers destination address and port (as well as the return path - but this can be done with accepting established/related connections)

Take a look at the wiki to see how to get started:

https://wiki.mikrotik.com/wiki/Manual:I ... all/Filter
 
misucatinas
just joined
Topic Author
Posts: 24
Joined: Thu Mar 01, 2018 9:11 am

Re: Using VPN for only RDP (3389)

Thu Sep 12, 2019 2:42 pm

Ok,
I added
add action=drop chain=forward disabled=no dst-address=192.168.88.0/24 in-interface=all-ppp src-address=192.168.0.0/24
And I configured to allow RDP and it`s not work.
What`s wrong?


L.E.:
I added
add chain=forward action=accept protocol=tcp dst-port 3389 in-interface=VPN comment="Allow RDP via VPN"
and it`s works!
Sorry and thanks.

Who is online

Users browsing this forum: MSN [Bot] and 38 guests