Page 1 of 1

Can't set up Google Home Mini

Posted: Mon Sep 09, 2019 10:43 pm
by eyevandy
This past week I set up a new home network - an RB760iGS and two Unifi AP's. I'm a software developer but not that great at networking - 90% of the options in RouterOS are over my head. Typically I can google through something like this but I'm hitting a wall.

My network seems to be running pretty well except for my Google Home Mini - it bails during setup. After selecting the wireless network to connect to, it gives the error "Could not communicate with your Google Home Mini." I (tried to) set up uPNP but I have no idea if it's correct. Other than that I haven't configured anything. On the AP's I've only changed broadcast channels. But it's very possible I need to change something on the wireless network and not the router.

Thank you!

Config:
# sep/09/2019 15:00:18 by RouterOS 6.45.5
# software id = UGQK-1D1D
#
# model = RB760iGS
# serial number = AE370A86F330
/interface bridge
add admin-mac=74:4D:28:F0:C7:B2 auto-mac=no comment=defconf name=bridge
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=sfp1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether2 network=192.168.88.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
/ip upnp
set allow-disable-external-interface=yes enabled=yes
/ip upnp interfaces
add interface=ether3 type=internal
add interface=ether5 type=internal
add interface=ether1 type=external
/system clock
set time-zone-name=America/Detroit
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

Re: Can't set up Google Home Mini  [SOLVED]

Posted: Tue Sep 10, 2019 7:21 pm
by sutrus
Complete Guide to Connecting Google Home Mini to Wi-Fi
https://www.mymemory.co.uk/blog/complete-guide-to-connecting-google-home-mini-to-wi-fi/

Correct upnp
/ip upnp
set allow-disable-external-interface=yes enabled=yes
/ip upnp interfaces
add interface=bridge type=internal
add interface=ether1 type=external

/ip dns set allow-remote-requests=yes - is it really needed?
If yes, it is a good idea to secure mikrotik from DNS attacks. Move these rules up in the firewall
/ip firewall filter
add action=reject chain=input comment="Reject DNS from WAN" dst-port=53 in-interface-list=WAN protocol=tcp reject-with=\
    icmp-port-unreachable
add action=reject chain=input comment="Reject DNS from WAN" dst-port=53 in-interface-list=WAN protocol=udp reject-with=\
    icmp-port-unreachable

Re: Can't set up Google Home Mini

Posted: Tue Sep 10, 2019 9:40 pm
by eyevandy
The uPNP changes seemed to work -- thanks!