Community discussions

 
Boukis
just joined
Topic Author
Posts: 1
Joined: Tue Sep 10, 2019 10:18 pm

Bridge Filtering, VLANs and issue with RSTP

Tue Sep 10, 2019 10:39 pm

We got 2 CRS300 series Ethernet switches in 2 different sites.

We use Bridge VLAN with vlan filtering

We need to bridge via EoIP 2 different VLANs.
VLAN100 on the 1st switch with VLAN100 on the second switch and VLAN200 on the 1st switch with VLAN200 on the second switch.

We add EoIP interfaces as bridge port end we specifi PVIDs.

We make the following test as a Lab and we notice that RSTP blocks the 1 EoIP interface.
set name=R1

/interface bridge
add name=br vlan-filtering=yes

/interface eoip
add mac-address=02:76:31:79:D1:E5 name=eoip-tunnel1 remote-address=10.100.100.2 tunnel-id=1
add mac-address=02:76:31:79:D1:E5 name=eoip-tunnel2 remote-address=10.100.100.2 tunnel-id=2

/interface bridge port
add bridge=br interface=ether2 pvid=100
add bridge=br interface=ether3 pvid=200
add bridge=br interface=eoip-tunnel1 pvid=100
add bridge=br interface=eoip-tunnel2 pvid=200

/interface bridge vlan
add bridge=br untagged=ether1,eoip-tunnel1 vlan-ids=100
add bridge=br untagged=ether2,eoip-tunnel2 vlan-ids=200

/ip address
add address=10.100.100.1/30 interface=ether23 network=10.100.100.0
set name=R2

/interface bridge
add admin-mac=02:74:DD:A9:C0:D3 auto-mac=no name=br vlan-filtering=yes

/interface eoip
add mac-address=02:2E:D1:D2:F3:F9 name=eoip-tunnel1 remote-address=10.100.100.1 tunnel-id=1
add mac-address=02:2E:D1:D2:F3:F9 name=eoip-tunnel2 remote-address=10.100.100.1 tunnel-id=2

/interface bridge port
add bridge=br interface=ether2 pvid=100
add bridge=br interface=ether3 pvid=200
add bridge=br interface=eoip-tunnel1 pvid=100
add bridge=br interface=eoip-tunnel2 pvid=200

/interface bridge vlan
add bridge=br untagged=ether1,eoip-tunnel1 vlan-ids=100
add bridge=br untagged=ether2,eoip-tunnel2 vlan-ids=200

/ip address
add address=10.100.100.2/30 interface=ether23 network=10.100.100.0
I guess we have some miss configuration on VLANs

Who is online

Users browsing this forum: No registered users and 16 guests