Page 1 of 1

Sharing the bandwidth doesn't work

Posted: Sun Oct 06, 2019 6:52 pm
by Barcode
Hello!

I just bought a MikroTik RB941-2nD-TC router, to share the bandwidth with my computer and with my brother's computer and I did all the things like in the tutorials and it doesn't work...
My main router is a Telekom router, model is Speedport Entry 2i maybe this router has something to do with it?

Re: Sharing the bandwidth doesn't work

Posted: Tue Oct 08, 2019 1:36 am
by Zacharias
I just bought a MikroTik RB941-2nD-TC router, to share the bandwidth with my computer and with my brother's computer and I did all the things like in the tutorials and it doesn't work...
But you don't say what exactly you did....
How did you try to share that bandwidth? Provide more details...

Re: Sharing the bandwidth doesn't work

Posted: Tue Oct 08, 2019 1:13 pm
by Barcode
Well, in queue list I tried to add both computers with IP and the same amount of limit, then I tried it with ether2 and ether 4 still nothing, tried doing with a parent queue, still nothing, tried adding pcq-s for upload and download and nothing.

Re: Sharing the bandwidth doesn't work

Posted: Tue Oct 08, 2019 3:41 pm
by Zacharias
You can export your queue configuration and post it here...

Re: Sharing the bandwidth doesn't work

Posted: Tue Oct 08, 2019 4:13 pm
by Barcode
Flags: X - disabled, I - invalid, D - dynamic
0 name="queue1" target=ether2 parent=queue3 packet-marks="" priority=8/8
queue=default-small/default-small limit-at=0/0 max-limit=11M/25M
burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s bucket-size=0.1/0.1

1 name="queue2" target=ether4 parent=queue3 packet-marks="" priority=8/8
queue=default-small/default-small limit-at=0/0 max-limit=11M/25M
burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s bucket-size=0.1/0.1

2 name="queue3" target=ether1 parent=none packet-marks="" priority=8/8
queue=default-small/default-small limit-at=0/0 max-limit=0/0
burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s bucket-size=0.1/0.1

Re: Sharing the bandwidth doesn't work

Posted: Tue Oct 08, 2019 8:58 pm
by Zacharias
In your parent set Max download and upload limit, which is the total available bandwidth...
Then in the advaced tab of your parent select pcq algorithm.

Re: Sharing the bandwidth doesn't work

Posted: Tue Oct 08, 2019 9:23 pm
by Barcode
Still doesn't work

Re: Sharing the bandwidth doesn't work

Posted: Tue Oct 08, 2019 10:40 pm
by Zacharias
Put your parent on top and all the childs bellow the parent..

Re: Sharing the bandwidth doesn't work

Posted: Tue Oct 08, 2019 10:52 pm
by Barcode
Yeah, I did it like this

Re: Sharing the bandwidth doesn't work

Posted: Tue Oct 08, 2019 11:15 pm
by Zacharias
Did it work? How are you testing if it works or not?

Re: Sharing the bandwidth doesn't work

Posted: Tue Oct 08, 2019 11:18 pm
by Barcode
I tested it on speedtest, and I'm still getting the full bandwidth

Re: Sharing the bandwidth doesn't work

Posted: Tue Oct 08, 2019 11:45 pm
by Zacharias
Every time i look at your export i find mistakes.. :D
On your parent interface you ve set as target ether1, this is wrong...

Parents target should be both interfaces, ether2 and ether4 in your case.. either add them both or add them in a bridge and add that bridge as a target...

Re: Sharing the bandwidth doesn't work

Posted: Tue Oct 08, 2019 11:52 pm
by Barcode
I set the target eth2,4 still not working :(

Flags: X - disabled, I - invalid, D - dynamic
0 name="queue1" target=ether2 parent=queue3 packet-marks="" priority=8/8
queue=default-small/default-small limit-at=0/0 max-limit=11M/25M
burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s bucket-size=0.1/0.1

1 name="queue2" target=ether4 parent=queue3 packet-marks="" priority=8/8
queue=default-small/default-small limit-at=0/0 max-limit=11M/25M
burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s bucket-size=0.1/0.1

2 name="queue3" target=ether2,ether4 parent=none packet-marks="" priority=8/8
queue=pcq-upload-default/pcq-upload-default limit-at=0/0
max-limit=50M/22M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
bucket-size=0.1/0.1

Re: Sharing the bandwidth doesn't work

Posted: Tue Oct 08, 2019 11:58 pm
by Zacharias
Your childs are still not bellow your parent... parent must be in position 0, child1 in position 2, child2 in position 3....

Also on the parents advanced tab use pcq upload for the upload and pcq download for the download..Not pcq upload to both...

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 09, 2019 12:11 am
by Barcode
Still dont

Flags: X - disabled, I - invalid, D - dynamic
0 name="queue3" target=ether2,ether4 parent=none packet-marks="" priority=8/8
queue=pcq-upload-default/pcq-download-default limit-at=0/0
max-limit=22M/50M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
bucket-size=0.1/0.1

1 name="queue1" target=ether2 parent=queue3 packet-marks="" priority=8/8
queue=pcq-upload-default/pcq-download-default limit-at=0/0
max-limit=11M/25M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
bucket-size=0.1/0.1

2 name="queue2" target=ether4 parent=queue3 packet-marks="" priority=8/8
queue=pcq-upload-default/pcq-download-default limit-at=0/0
max-limit=11M/25M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
bucket-size=0.1/0.1

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 09, 2019 12:16 am
by Zacharias
Please post your code inside code tags..

Childs do not need to have pcq selected... parent does.. anyways..

In your firewall is fasttrack enabled? If yes delete it..

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 09, 2019 12:28 am
by Barcode
I fixed the pcqs, and disabled fasttrack then rebooted the router still doesn't work..

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 09, 2019 8:26 pm
by Zacharias
Simple queues are really simple to create... am sure you miss something...
I will have to see your whole router configuration because certainly you do something wrong..

In the wiki you can find examples of simple queues..

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 09, 2019 10:17 pm
by Barcode
Yeah, that's what I'm saying, it's really simple, and I can google aswell :D.
That's why I'm questioning the thing that maybe my telekom router fucks this all up.
If u tell me how I can send you all the router's configuration i'll send it.

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 09, 2019 10:20 pm
by Zacharias
You can export your configuration with hide-sensitive and post it here inside code tags...

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 09, 2019 10:29 pm
by Barcode
Here it is

[admin@MikroTik] > /export hide-sensitive
# oct/09/2019 21:25:09 by RouterOS 6.45.3
# software id = 427L-2LVJ
#
# model = RB941-2nD
# serial number = 93710A7F5981
/interface bridge
add admin-mac=74:4D:28:C2:3F:CA auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=2 band=2ghz-b/g/n channel-width=20/40mhz-Ce country=hungary disabled=no distance=indoors frequency=auto frequency-mode=regulatory-domain mode=ap-bridge ssid=MikroTik-C23FCE wireless-protocol=802.11
/interface ethernet
set [ find default-name=ether1 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
set [ find default-name=ether2 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
set [ find default-name=ether3 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
set [ find default-name=ether4 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=dynamic-keys supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
add name=vpn ranges=192.168.89.2-192.168.89.255
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge lease-time=3d name=defconf
/ppp profile
set *FFFFFFFE local-address=192.168.89.1 remote-address=vpn
/queue simple
add max-limit=22M/50M name=queue3 packet-marks="" queue=pcq-upload-default/pcq-download-default target=ether2,ether4
add max-limit=11M/25M name=queue1 parent=queue3 queue=default/default target=ether2
add max-limit=11M/25M name=queue2 parent=queue3 queue=default/default target=ether4
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=wlan1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface l2tp-server server
set enabled=yes use-ipsec=yes
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/interface pptp-server server
set enabled=yes
/interface sstp-server server
set default-profile=default-encryption enabled=yes
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether2 network=192.168.88.0
/ip cloud
set ddns-enabled=yes
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server lease
add address=192.168.88.254 client-id=1:b0:6e:bf:c5:56:a8 mac-address=B0:6E:BF:C5:56:A8 server=defconf
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=accept chain=input connection-type="" dst-port=8291 protocol=tcp
add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 protocol=udp
add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
add action=accept chain=input comment="allow l2tp" dst-port=1701 protocol=udp
add action=accept chain=input comment="allow pptp" dst-port=1723 protocol=tcp
add action=accept chain=input comment="allow sstp" dst-port=443 protocol=tcp
add action=accept chain=input comment=remote dst-port=8291 protocol=tcp
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=192.168.89.0/24
/ppp secret
add name=vpn
/system clock
set time-zone-name=Europe/Budapest
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

Re: Sharing the bandwidth doesn't work

Posted: Thu Oct 10, 2019 12:06 am
by Zacharias
Please put your code inside code tags...

I do not see anything wrong! It should work...
Try to put in your parent all your subnet as target, instead of ether3,4 , put 192.168.88.0/24 and in your childs instead of ether 3 and ether 4 as targets use the IP addresses of your computers...

Re: Sharing the bandwidth doesn't work

Posted: Thu Oct 10, 2019 12:16 am
by Barcode
Idk what are code tags, but still doesn't work with the IPs

Re: Sharing the bandwidth doesn't work

Posted: Thu Oct 10, 2019 1:47 am
by CZFan
You need to elaborate on what you mean "share" with your brother. If you want to share the bandwidth dynamically, i.e. when you not using, he gets 100% and vice versa, then all you need is the below:

If you both use internet, then it will dynamically share, to test, start a speed test on both pc's at the same time

PS. Note the "code tags"
/queue simple
add max-limit=22M/50M name=Q1 queue=pcq-upload-default/pcq-download-default target=192.168.88.0/24

Re: Sharing the bandwidth doesn't work

Posted: Thu Oct 10, 2019 4:00 pm
by Zacharias
Czfan if you see the earlier posts he uses simple queues with parents and childs... if you limit the childs up/down then even if there is more bandwidth available he will not get it...
Also if he does use all the subnet 192.168.88.0/24 as you told him then he will limit everyones traffic in the network and Not only to the computers he actually wants to.
The implementation he exported earlier seems just fine, i think there is a mistake somewhere else but i will have to see all the routers configuration...

Re: Sharing the bandwidth doesn't work

Posted: Thu Oct 10, 2019 4:25 pm
by xvo
That should work:
/queue simple
add dst=ether1 max-limit=22M/50M name=queue3 queue=default/default target=ether2,ether4
add dst=ether1 limit-at=11M/25M max-limit=22M/50M name=queue1 parent=queue3 queue=default/default target=ether2
add dst=ether1 limit-at=11M/25M max-limit=22M/50M name=queue2 parent=queue3 queue=default/default target=ether4
However, I'm not sure about slave interfaces as a target. Perhaps that has to be changed to ip address ranges.
Also please be sure that max-limit is at least 5-10% lower than achievable provider speed.

P.s.: also you need to move this address to the bridge:
/ip address
add address=192.168.88.1/24 interface=bridge network=192.168.88.0
instead of:
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether2 network=192.168.88.0

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 16, 2019 9:18 am
by Barcode
You need to elaborate on what you mean "share" with your brother. If you want to share the bandwidth dynamically, i.e. when you not using, he gets 100% and vice versa, then all you need is the below:

If you both use internet, then it will dynamically share, to test, start a speed test on both pc's at the same time

PS. Note the "code tags"
/queue simple
add max-limit=22M/50M name=Q1 queue=pcq-upload-default/pcq-download-default target=192.168.88.0/24
This one works, but I want to limit both of our bandwidth equally, maybe you can help with that aswell?

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 16, 2019 9:19 am
by Barcode
That should work:
/queue simple
add dst=ether1 max-limit=22M/50M name=queue3 queue=default/default target=ether2,ether4
add dst=ether1 limit-at=11M/25M max-limit=22M/50M name=queue1 parent=queue3 queue=default/default target=ether2
add dst=ether1 limit-at=11M/25M max-limit=22M/50M name=queue2 parent=queue3 queue=default/default target=ether4
However, I'm not sure about slave interfaces as a target. Perhaps that has to be changed to ip address ranges.
Also please be sure that max-limit is at least 5-10% lower than achievable provider speed.

P.s.: also you need to move this address to the bridge:
/ip address
add address=192.168.88.1/24 interface=bridge network=192.168.88.0
instead of:
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether2 network=192.168.88.0
Did this, and still nothing.

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 16, 2019 10:19 am
by xvo
Did you also try to change targets from interface names to address ranges?

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 16, 2019 12:15 pm
by Barcode
Yep, did that before

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 16, 2019 12:58 pm
by xvo
I have no other ideas.
Almost identical config works for me.

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 16, 2019 1:29 pm
by Barcode
Yeah, that's why I wrote this topic, and my guess is that my main telekom router is blocking something or idk

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 16, 2019 4:49 pm
by xvo
Try setting max-limit much lower than your actual speed (5M/10M for example) and see if the queues still don't work.
To rule out the possibility, that your ISP shaper takes effect before your mikrotik.

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 16, 2019 7:43 pm
by Barcode
Tried that also, also not working

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 16, 2019 8:03 pm
by xvo
Still can't find anything in your config that could interfere with queues.

Re: Sharing the bandwidth doesn't work

Posted: Wed Oct 16, 2019 8:34 pm
by ChristopherFS
Good Afternoon,
Try disable fasttrack connection!!!
If you use the router out-of box probally it came with fasttrack enabled.
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked

Re: Sharing the bandwidth doesn't work

Posted: Thu Oct 17, 2019 2:06 pm
by Barcode
It's disabled.

Re: Sharing the bandwidth doesn't work

Posted: Thu Oct 17, 2019 2:37 pm
by Zacharias
Your queues are correct..
so either you test it the wrong way or traffic shapping happens before the MikroTik...