Community discussions

 
jcromer
just joined
Topic Author
Posts: 1
Joined: Thu Nov 07, 2019 7:33 pm

VLAN Setup with CRS326-24G-2S+ and the CRS309-1G-8S+

Fri Nov 08, 2019 4:06 am

Hello. I am new to Mikrotik equipment and network is not my strong suit. I come primarily from a compute and storage background. I have purchased a couple of different switches to place in my lab environment, the CRS326-24G-2S+ and the CRS309-1G-8S+. I am attaching a basic diagram of how a server in the lab would connect to the two switches. I have a total of 6 servers that will be attached the same way.
Network_Layout.png
Each server has a 1G OOB port, a 1G NDC port and 10G PCI Nic port. Ether1-6 on CRS326-24G-2S+ are connected to each server's 1G OOB ports. Ether9-14 on CRS326-24G-2S+ are connected to each server's 1G LOM ports. sfp-sfpplus1-6 on CRS309-1G-8S+ are connected to each server's 10G PCI Nic ports.

sfp-sfpplus8 on CRS309-1G-8S+ is connected to sfp-sfpplus1 on CRS326-24G-2S+.

Ether24 on CRS326-24G-2S+ is connected to ISP router.

On both the 326 and 309 the bridge name is bridge,

One the CRS326-24G-2S+ i would like to set up:
VLAN 100 (Tagged) - OOB and MGMT
VLAN 200 (Untagged) - PXE

I created VLANs using:

/interface bridge vlan add vlan-ids=100 bridge=bridge untagged=bridge,ether24,sfp-plus1 tagged=ether1,ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether11,ether12,ether13,ether14
/interface bridge vlan add vlan-ids=200 bridge=bridge untagged=ether9,ether10,ether11,ether12,ether13,ether14

PVID=200 on ether9-ether14

On the CRS326-24G-2S+ I would like to set up:
VLAN 300 (Tagged) - CTRL
VLAN 400 (Tagged) - DATA
VLAN 500 (Tagged) - STORAGE
VLAN 600 (Untagged) - EXTERNAL

I created VLANs using:

/interface bridge vlan add vlan-ids=300 bridge=bridge tagged=sfp-sfpplus1,sfp-sfpplus2,sfp-sfpplus3,sfp-sfpplus4,sfp-sfpplus5,sfp-sfpplus6
/interface bridge vlan add vlan-ids=400 bridge=bridge tagged=sfp-sfpplus1,sfp-sfpplus2,sfp-sfpplus3,sfp-sfpplus4,sfp-sfpplus5,sfp-sfpplus6
/interface bridge vlan add vlan-ids=500 bridge=bridge tagged=sfp-sfpplus1,sfp-sfpplus2,sfp-sfpplus3,sfp-sfpplus4,sfp-sfpplus5,sfp-sfpplus6
/interface bridge vlan add vlan-ids=600 bridge=bridge untagged=sfp-sfpplus1,sfp-sfpplus2,sfp-sfpplus3,sfp-sfpplus4,sfp-sfpplus5,sfp-sfpplus6

PVID=600 on sfp-sfpplus1-6

What I am basically trying to achieve is the ability to connect to the OOB and management interfaces on my servers from my local network. All other traffic should remain in it's respective VLAN. Everything appears to be working so far and I can connect to OOB and NDC interfaces on my servers without any issues. Just wanted to put this out there to make sure that I am not missing anything or doing anything stupid. If someone look over everything to double check my work that would be great.

If you made it to the end, thanks for reading. :D
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: No registered users and 37 guests